Issue with mapping drive to Windows Server 2003

I am using a Windows Server 2003 platform to share files to three desktops running Windows XP Pro. When I try to map to a drive on the server I am prompted to enter a password with "servername/guest" in the username field, which is greyed out. What is necessary to setup this connection so that I am not prompted to enter a password. No matter what I put into the pasword field it is not accepted, I know I have the right password. All computers are on the same workgroup, do they need to be on a domain? I understand that this server is way to much for what I am using it for but it's what we are stuck with.
LVL 2
accrainAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
KCTSConnect With a Mentor Commented:
DO NOT enable to guest account unless you want to leave your system wide open to abuse.

If you have a Windows 2003 Server then it makes no sense to run it as a workgroup - you suffer from all the limitations of a workgroup including the 10 connection limit and that fact that users need accounts on all machines that they access. You are also not utilising the expensove software that you have paid for.

Either (preferred) :-
Set up a proper domain and add the computers to the domain. Create domain accounts for the users. Assign the users the necessary rights on the share
or
Create user accounts with the same names and passwords on the server as local accounts, grant the users permissions on the shares/folders
0
 
Netman66Commented:
Enable the Guest account.
Make sure the Shares have Everyone - Full Control
Also, make sure the NTFS permissions contain the Everyone group with whatever rights you need.

0
 
accrainAuthor Commented:
Can anyone recommend a link or book to a step by step tutorial for settings up a domain... Something like, "Domains for Dummies". Not very proficent with this topic. thanks for your advice...
0
All Courses

From novice to tech pro — start learning today.