[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 600
  • Last Modified:

Web.config file for database connection.

I have the following:

<connectionStrings>
            <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
            <remove name="LocalSqlServer"/>
            <add name="LocalSqlServer" connectionString="Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
      </connectionStrings>
------------------------------------------------------------------------
I have installed sql server 2005 enterprise and attached TimeTracker.mdf

How can I chage the above to conform to SQL Server 2005.
0
mathieu_cupryk
Asked:
mathieu_cupryk
  • 10
  • 8
  • 2
1 Solution
 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
you only have to change the dat Source parameter into the instance of the sql server 2005.
0
 
mathieu_cuprykAuthor Commented:
The instance is Quincy which is the server name
what else do I do?
0
 
McExpCommented:
Assuming that inside of TimeTracker.mdf you have a database called TimeTracker the following should give you what you need.

  <connectionStrings>
    <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=Quincy;Initial Catalog=TimeTracker;Integrated Security=True;" providerName="System.Data.SqlClient"/>
  </connectionStrings>
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
as said, you need to specify the instance name:
Data Source=.\Quincy

what else to do depends on what problem(s) you get after adjusting the connection string.
0
 
McExpCommented:
An Sql Server connectionstring requires two bits of information the server name (DataSource) and Database name (Initial Catalog). My first post gives you the format for the connectionString this second should give you the info you need to configure to your requirements.

Once again, assuming all of the info is in one database (TimeTracker) the following should work

  <connectionStrings>
    <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=Quincy;Initial Catalog=TimeTracker;Integrated Security=True;" providerName="System.Data.SqlClient"/>
    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="Data Source=Quincy;Initial Catalog=TimeTracker;Integrated Security=True;" providerName="System.Data.SqlClient"/>
  </connectionStrings>
0
 
mathieu_cuprykAuthor Commented:
I was just doing what you were writting;

I found a news group however, I got this message.

Cannot open database "TimeTracker" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Cannot open database "TimeTracker" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.
0
 
mathieu_cuprykAuthor Commented:
http://forums.asp.net/t/1181594.aspx

Then I got this:
Cannot open database "TimeTracker" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Cannot open database "TimeTracker" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.
0
 
McExpCommented:
Are you using anonymous auth on your site?
0
 
mathieu_cuprykAuthor Commented:
Well is it ok if I went into properties of sql server and change quincy\administrator to
NT AUTHORITY\NETWORK SERVICE under Files --> Owner
0
 
McExpCommented:
Your Sql server will only allow you to connect from an account that has permissions, if you add the 'NT AUTHORITY\NETWORK SERVICE' to the users in Sql Server and give the appropriate permissions to give that user access to the required tables all should be ok!
0
 
McExpCommented:
That is dangerous, that gives the website full permissons as DBO to do whatever to your website.

If you are not internet facing it is not such a big issue, however if not you are leaving yourself very vunrable to hackers!
0
 
mathieu_cuprykAuthor Commented:
Now when I do a register.aspx page I get this error guys:

The role 'ProjectAdministrator' was not found.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Configuration.Provider.ProviderException: The role 'ProjectAdministrator' was not found.

Source Error:

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

  <%@ Page Language="C#" Debug="true" %>

or:

2) Add the following section to the configuration file of your application:

<configuration>
   <system.web>
       <compilation debug="true"/>
   </system.web>
</configuration>

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.  
0
 
McExpCommented:
So I'm assuming your using a Roles Provider?

What is the database that contains your Membership database?
0
 
mathieu_cuprykAuthor Commented:
Sql server 2005.
and the instance is quincy
and the name of the db is TimeTracker.
0
 
McExpCommented:
So what is your Roles provider configuration set too, please provide full web.config
0
 
mathieu_cuprykAuthor Commented:
ok but I fix it with aspnet_regsql.exe
--------------------------------------------
Here is my web.config, I like learning new things.

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
  <connectionStrings>
    <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=Quincy;Initial Catalog=TimeTracker;Integrated Security=True;" providerName="System.Data.SqlClient"/>
    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="Data Source=Quincy;Initial Catalog=TimeTracker;Integrated Security=True;" providerName="System.Data.SqlClient"/>
  </connectionStrings>



  <system.web>
            <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
                  <providers>
                        <clear />
                        <add name="AspNetXmlSiteMapProvider"
                              type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
                              siteMapFile="web.sitemap"
                              securityTrimmingEnabled="true"  />
                  </providers>
            </siteMap>
            <authentication mode="Forms">
                  <forms loginUrl="~/TimeTracker/login.aspx"/>
            </authentication>
            <compilation debug="false" />
            <customErrors mode="RemoteOnly"/>
            <machineKey decryptionKey="AutoGenerate,IsolateApps"/>
            <roleManager enabled="true" />
      </system.web>
</configuration>
0
 
McExpCommented:
Congratulations, You say you've fixed it?

I was only going to check that you didn't have any custom provider definitions that would be pointed at the wrong db. you havent as you've left the config defualt. An example of a custom Provider is shown below: -





		<roleManager enabled="true" cacheRolesInCookie="true" defaultProvider="AccessRoleProvider">
			<providers>
				<add connectionStringName="ASPNetDB" applicationName="RAdmin" name="AccessRoleProvider" type="Samples.AccessProviders.AccessRoleProvider"/>
			</providers>
		</roleManager>

Open in new window

0
 
mathieu_cuprykAuthor Commented:
I will put this in my config in comments for future reference. I learned alot. Thanks man.
A+
0
 
mathieu_cuprykAuthor Commented:
This is the bulk of the answer.
0
 
mathieu_cuprykAuthor Commented:
This is great job.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 10
  • 8
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now