Solved

Cisco ASA 5505 VPN client setup problem

Posted on 2007-11-18
3
2,487 Views
Last Modified: 2009-06-17
I setup the Cisco ASA 5505 with the VPN wizard and while it connects from the outside it causes the clients to loose DNS and will not allow them to connect to the server or drive shares. Here is a copy of the current running config:

domain-name test.local
enable password xxxxxxxxx encrypted
names
name 00.00.00.00 bham
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address bham 255.255.255.252
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxxxxxxxxx encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name test.local
access-list inbound extended permit tcp any host bham eq 3389
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list inside_nat0_outbound extended permit ip any 172.16.1.96 255.255.255.
224
pager lines 24
logging enable
logging monitor debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpngroup 172.16.1.100-172.16.1.125 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.1.100 3389 netmask 255.255.25
5.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 00.00.00.00 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
group-policy xxxxxxx internal
group-policy xxxxxxx attributes
 wins-server value 192.168.1.1
 dns-server value 192.168.1.1
 vpn-tunnel-protocol IPSec
 default-domain value test
username xxxxxx password xxxxxxxxx encrypted privilege 0
username xxxxx attributes
 vpn-group-policy abc
username xxxxx password xxxxxxxxxx encrypted privilege 15
tunnel-group xxxxxxx type ipsec-ra
tunnel-group xxxxxxx general-attributes
 address-pool vpngroup
 default-group-policy acivpn205
tunnel-group xxxxxxx ipsec-attributes
 pre-shared-key *
prompt hostname context
0
Comment
Question by:Pangeia
  • 2
3 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 20308432
Add the following command and see if it helps:

crypto isakmp nat-traversal 20

This command is needed if your VPN client is sitting behind a remote NAT device when using the VPN...if this is the case and you don't have that command in the config, the VPN client won't be able to see inside hosts on the 192.168.1.x network, including your DNS server that you're pushing out to them.
0
 

Author Comment

by:Pangeia
ID: 20309457
That worked for the remote desktop to the server but I still loose the internet connection and the mapped drives do not connect. Any ideas?
0
 

Author Comment

by:Pangeia
ID: 20396482
I also had to add split-tunnel to get it all working but thank you.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
Sometimes, you want your microsoft VPN to route all the traffic to the remote network. Usually your employer network. This makes it possible to access all the nodes inside this remote LAN, even if they have no "public DNS" entries. To do so, you wo…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now