Solved

How do I configure BIND to correct this issue?

Posted on 2007-11-19
4
543 Views
Last Modified: 2010-05-18
I have Apache, PHP, and MySQL running on this desktop (Windows XP). The websites work correctly and have never caused any problems. Recently I decided I wanted to point www.thebloodyred.com to one of the websites I run on my webserver using BIND9. It works, except I get errors from http://www.checkdns.net. I believe these same errors are preventing me from running a mailserver under the program "hMailServer". First and foremost I'm interested in getting the errors presented to me fixed.

The errors are:

1. CheckDNS.NET checks if all NS have the same version
  Master DNS defined by SOA (ns1.thebloodyred.com.thebloodyred.com) was not found among NS records.
  All 2 your servers have the same zone version 2004041700

2. CheckDNS.NET is verifying if NS are alive
  NS list mismatch: registration authority reports that domain is hosted on the following servers: 'ns1.thebloodyred.com; ns2.thebloodyred.com', but DNS server ns1.thebloodyred.com reports domain to be hosted on 'ns2.thebloodyred.com.thebloodyred.com; ns1.thebloodyred.com.thebloodyred.com'. Please make sure that you configure the same DNS servers in registrar database and on your DNS

3. CheckDNS.NET tests mail-servers
  Domain thebloodyred.com has only one mail-server
  Checking mail server (PRI=10) mail.thebloodyred.com [75.132.178.93]
  Error connecting to mail server mail.thebloodyred.com [75.132.178.93] port 25 : timed out waiting for connection
  Some of your MX do not work properly

---------------------------------------------------------------------------------------------------

I know it's bad to have both nameservers on the same physical machine, but I don't have more than one so it'll have to make due. I believe the problem is in my 127.0.0.rev or thebloodyred.com.zone files.

Contents of 127.0.0.rev

$TTL 900

@            SOA      ns1.thebloodyred.com. (      
                  admin.thebloodyred.com.      
                  2004041700            
                  21600                  
                  1800                  
                  604800                  
                  900 )                  

@            NS      ns1.thebloodyred.com.
@            NS      ns2.thebloodyred.com.

1            PTR      ns1.thebloodyred.com.
2            PTR      ns2.thebloodyred.com.
3            PTR      mail.thebloodyred.com.
4            PTR      www.thebloodyred.com.
5            PTR      kill.thebloodyred.com.
6            PTR      forum.thebloodyred.com.

thebloodyred.com.zone

$TTL 900            

@            SOA      ns1.thebloodyred.com (            
                  postmaster      
                  2004041700      
                  21600            
                  1800            
                  604800            
                  900 )            

@            NS      ns1.thebloodyred.com            
@            NS      ns2.thebloodyred.com            

@            A      75.132.178.93      

@            MX      10 mail            

ns1            A      75.132.178.93      
ns2            A      75.132.178.93      

mail            A      75.132.178.93      

www            A      75.132.178.93      

kill            A      75.132.178.93      

forum            A      75.132.178.93       
0
Comment
Question by:maikar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 2

Accepted Solution

by:
gmilhon earned 500 total points
ID: 20322566
Change these lines:

@            NS      ns1.thebloodyred.com            
@            NS      ns2.thebloodyred.com  

To this:

@            NS      ns1
@            NS      ns2

Having the @ sign at the beginning means you don't have to have the FQDN.
0
 
LVL 2

Expert Comment

by:gmilhon
ID: 20405097
Did this resolve your problem?
0
 
LVL 1

Expert Comment

by:Computer101
ID: 20649422
Forced accept.

Computer101
EE Admin
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: kevp75
Hey folks, 'bout time for me to come around with a little tip. Thanks to IIS 7.5 Extensions and Microsoft (well... really Windows 8, and IIS 8 I guess...), we can now prime our Application Pools, when IIS starts. Now, though it would be nice t…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question