[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

need step by step enable rdp to xp machine behind a firewall, w2k3 server providing dns/dhcp

Posted on 2007-11-19
10
Medium Priority
?
315 Views
Last Modified: 2013-11-21
I have need to work from my home xp system and want to use rdp to connect to my desktop system at the office.  I am a newbie sysadmin.  My system at office is behind a sonic wall soho3, and my w2k3 server is providing dns adn dhcp.  I enabled the firewall to pass wan to my 192.168.1.103 (my desktop) but no good.  every time i try from home to get in I get my server.  server uses no-ip to mimick a static ip.

What to do?
0
Comment
Question by:195ecentralave
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 13

Expert Comment

by:cshepfam
ID: 20312393
since you are a newbie, i'm going to suggest the easiest route to go without having to configure your firewall or pay any money for a third party software.



go to www.logmein.com.  this is a free remote tool that you will install on your home computer and the computer at your office.  its not a big file and its very secure.  when you're at home and access your computer at the office, you can configure it to blank out your screen and lock your mouse and keyboard so noone can see what you're doing or mess with it.


its very good software.  you don't have to configure you firewall, open ports, etc.  just a quick install and you're good to go.


hope that helps
0
 
LVL 6

Expert Comment

by:mmcodefive
ID: 20312397
Never RDP to a computer that is using DHCP. Set your workstation to a static ip or create a reservation in DHCP in windows to a certian ip. Verify you NAT your outside ip to your inside ip for that workstation ip address NOT the server. Verify you have port 3389 open on your firewall.

I think your problem is that you have your firewall set to nat the server to the outside instead of the worstation. If you only have one public ip you can redirect the workstation RDP port (3389) to another outside port like 3390 and just connect on that port.
0
 

Author Comment

by:195ecentralave
ID: 20317125
Thanks, mmcodefive, you are on to it, i think. I am always getting the only static ip there is in the office, and that is the server.  how do i  verify the nat from my outside ip to the inside workstation ip?  I know what the workstation ip is, its 192.168.1.103, and that is not changing although i know that it can.  i know how to set it static on the workstation, but will have to look up how to reserve it in the server dhcp.  Do i have to do both?  CAn i just set the workstation to static ip?  Thanks,
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:195ecentralave
ID: 20317133
btw. I have logmein working, its too slow thats why i am trying to go with rdp.
0
 
LVL 6

Expert Comment

by:mmcodefive
ID: 20317406
Thats fine set the workstation to static. If you NAT your server and you have one ip you cant nat also the workstation. Best bet take off nat for everything. Setup port forwarding 3389 for the server RDP and 3390 for the workstation.
0
 

Author Comment

by:195ecentralave
ID: 20325100
Ok, will do but how do i set the workstation to use port 3390 for rdp? Where does this setting get changed in windows xp?
0
 
LVL 6

Expert Comment

by:mmcodefive
ID: 20331269
I can send you a registry key to change it. Better just set on your firewall external port 3390 and internal port 3389
0
 

Author Comment

by:195ecentralave
ID: 20336588
That would be most appreciated, Mmcodefive.  my email is richardwestco@woh.rr.com
thanks,
0
 
LVL 6

Accepted Solution

by:
mmcodefive earned 2000 total points
ID: 20346962
just put this code in a .reg file like change_port.reg

http://support.microsoft.com/kb/306759
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp]
"PortNumber"=dword:00000d3e

Open in new window

0
 

Author Closing Comment

by:195ecentralave
ID: 31409930
Thanks, I will post a follow up question  if I don't get through. Thanks for the extra effort.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
Know what services you can and cannot, should and should not combine on your server.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question