?
Solved

File server network share slow

Posted on 2007-11-19
16
Medium Priority
?
360 Views
Last Modified: 2013-12-02
Hi Experts. I have a scenario here that is quite a puzzle and I'm offering 500 points straight up as anyone with the solution will definitely earn all 500.

Situation: I have an almost new HP Proliant ML370 running as a file server at location A. It was installed about 2 months ago and all has been well until last week.

I have a remote office (location B) about 300 metres away that is linked to location A by a 20Mb alvarion wireless link.

Last week the issue started. Users in location B accessing the file server at location A are experiencing alot of latency (there is another server at location B where most of their stuff is but they do access some shared files at location A also). For example copying a 20 Mb file from my HP Proliant to a machine in location B can take 4-5 mins. Copying the same 20 Mb file to a PC at location A from HP server only takes 5 seconds.

Location A has about 60 users, location B about 30 users.

What I've said to far all indicates 'oh you've got a problem with your wireless link' between locations. This however isnt the case as the guys who installed the link have come in, tested it and all is fine (throughput testing shows all 20Mbs available). Also, to prove this more if I copy a 20Mb file from an old file server (currently functioning as a DC) located at location A - to a machine located at location B it copies in about 30 seconds, what I'd expect over the link.

Also, if I plug a laptop straight into wireless link and both locations I get perfect speeds between the 2 so I cant see the wireless link being the bottleneck. That then points to the new server as the bottleneck...

...However users on the 100Mbs LAN at location A get perfect speeds when connecting to the Proliant server (the server incidently has 2 X Gb ethernet ports and is operating at 1Gbs). My PC for example is at location A and I've just copied a 120 Mb file to my machine from the server in 15 seconds, again, what I'd expect.

I've troubleshooted this over and over, rebooted every switch, every machine, every server, virus defs on machines are upto date. I've replaced the switch at the remote location B.

Ideas please!
0
Comment
Question by:BGilhooley
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 1

Author Comment

by:BGilhooley
ID: 20314152
Something else I should add that seems just strange to me but may make sense to someone else is this.:

If I sit at my PC in location A, copy 20 Mb file from my mapped drive on new Proliant server at location A.
Paste the file to a mapped drive on file server B in location B it works fine, 15 odd seconds it takes.

However if I log onto any machine in location B and browse to the same share on the new proliant in location A, copy the file and paste it to the C drive it takes 4-5 minutes. Why I dont understand.

Incidentally, the servers are windows 2003. All PC's are Win XP. The network at both locations is 100mb ethernet. No VLAN's, one router.
0
 
LVL 10

Expert Comment

by:fm250
ID: 20314865
Try to map the share of the workstaion in location B from the server itself and see. but location A should be faster than location B since 100mb vs. 20mb.

Another test is to make a share on location A -another machine not in the server- and test it from location B. this will let you know if it is the server or the netwrok.
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20318831
- Mapping a share to a workstation in location B from the new server itself (in location A) results in a very slooow copy.
- Mapping a share to the same workstation in location B from a workstation in location A results in a good speed copy of the same file.

- Making a share on another machine in location A, testing it from location B, results in a good copy speed.

Basically everything is normal except when copying files to/from new server in location A to any machine in location B. However, when copying files from/to new server to any machine in location A the speed is excellent (eg. 120mb file copied in 5 seconds).

Anyone any experience of anything similar?
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 
LVL 56

Expert Comment

by:andyalder
ID: 20319098
How is the teaming set up on the dual NICs? Get that wrong and you get some wierd effects - check with the green NIC icon in system tray. If not in system tray then it's in control panel or you haven't installed the proliant suppport pack.
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20319115
Teaming isnt setup on the NIC's. I've tried both NIC's aswell obviously with no difference.
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20319627
This is a real grasping at straws bit but anyway. in the event viewer of the problem server the following error is reoccuring:

Event Type:      Warning
Event Source:      DnsApi
Event Category:      None
Event ID:      11197
Date:            20/11/2007
Time:            09:56:29
User:            N/A
Computer:      SERVER
Description:
The system failed to update and remove host (A) resource records (RRs) for network adapter
with settings:

   Adapter Name : {AC894743-9293-4B52-BAE2-20BB45B29F51}
   Host Name : server
   Primary Domain Suffix : mydomain.com
   DNS server list :
           192.168.1.2, 192.168.1.253   (THESE ARE MY DNS SERVERS)
   Sent update to server : <?>
   IP Address(es) :
     192.168.1.252  (IP ADDRESS OF PROBLEM SERVER)

0
 
LVL 10

Expert Comment

by:fm250
ID: 20320727
Please try these:

first: unistall all NICs then reinstall them back again with latest drivers from the manufacture company (not from microsoft update)

- scond: remove the server A record and any other records from the DNS. Also from wins  server if you have it and then recreate it again with apropraite ip.

- finally: restart your server:
Another question for you: do you have object auding on? if it is on what are the options selected?
0
 
LVL 15

Expert Comment

by:getzjd
ID: 20322014
I had a similar issue with a snap server.  If you can, set your file server / switches both to 100MB full  rather than autosense
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20328832
I tried a different network card and it worked so theres something mad going on with the cards in the machine. They're onboard HP 1gb cards so perhaps its a system board issue. Just downloaded the latest card drivers so I'll be updating them tonight, see if that makes any difference...
0
 
LVL 10

Expert Comment

by:fm250
ID: 20329639
If you still have warranty on the system call HP. They should replace it for you right away. it is a hardware issue.


hope this helps!
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20333521
I updated the drivers, however when updating them the first time by doing:

Run - Install drivers - Install. The machine blue screened, mentioned the problem as ndis.sys. I've checked about that and it generally indicates a NIC or other hardware issue such as system board.

After the blue screen I tried the dirvers again this time by extracting them first and then updating driver in device manager and it worked that way.

so, it definitely looks like I have a hardware related NIC or system board problem. I've been onto my HP reseller and they are contacting HP this morning. will post more later...
0
 
LVL 10

Accepted Solution

by:
fm250 earned 2000 total points
ID: 20334670
According to what you said, it seems it is certainly is a hardware issue and therefore HP should replace either the board or the related defective part right away. What kind of warranty do you have? you should always have same day service and part replacement for servers.

I have 4 hours same day replacement and laber with Dell and they are very good with that. With HP I think that you need to push on them. So just follow up with them on phone calls and emails. good luck!
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20372603
HP got me to install a HP (its actaually Broadcom manufactured) 1Gb NIC which i did and the speed is fine. my problem is they say they've never seen an issue like this before and are unconvinced its the system board. I've told them by now its a black and white issue for me as when i plug into one of the onborad NICs i get the issue, wehn i try any other NIC its fine. The call has been escalated but so far i havnt got them to agree to replace the board which is what I want!
0
 
LVL 1

Author Comment

by:BGilhooley
ID: 20448620
Just to close off here and let people know what happened here it is. HP are (at last) relenting and are sending an engineer today to replace the system board. Took alot of persuasion as they were adament it was an environmental issue but i was able to prove otherwise in the end. I'll award points later on when board is replaced and I can confirm 100% this as the issue...
0
 
LVL 10

Expert Comment

by:fm250
ID: 20450267
I use Dell product and the don't question when it is a hardware problem, which is the good thing about them, they replaced my server motherboard that cost around $2000 in less than 4 hours.

Don't give up on them though and Don't use HP products again if you can -only printers as they still good with printers-.

good luck
0
 
LVL 1

Author Closing Comment

by:BGilhooley
ID: 31409970
Board was replaced last night and the new board works fine. this was a really really weird problem, I showed the engineer here what was happening and he was as perplexed as I've been!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
New style of hardware planning for Microsoft Exchange server.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question