Solved

maximum request length error when deploying model

Posted on 2007-11-19
2
1,805 Views
Last Modified: 2012-05-05
Please bear with me as I am new to SQL reporting services.
I am testing SQL reporting to see if it meets our neads. I am trying to deploy a model and I receive the error I attached. I have increased the maximum request length in the machine.config file but i still receive the same error. Is that the correct place to change that parameter? Any help would be greatly appreciated. Thanks!
Larry
Error	1	System.Web.Services.Protocols.SoapException: There was an exception running the extensions specified in the config file. ---> System.Web.HttpException: Maximum request length exceeded.    at System.Web.HttpRequest.GetEntireRawContent()    at System.Web.HttpRequest.get_InputStream()    at System.Web.Services.Protocols.SoapServerProtocol.Initialize()    --- End of inner exception stack trace ---    at System.Web.Services.Protocols.SoapServerProtocol.Initialize()    at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, HttpContext context, HttpRequest request, HttpResponse response, Boolean& abortProcessing)	c:\documents and settings\administrator.pyrotek-cor\my documents\visual studio 2005\projects\labmex model\labmex model\Lab Mex.smdl	0	0

Open in new window

0
Comment
Question by:lschroeder
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 
LVL 31

Accepted Solution

by:
James Murrell earned 500 total points
ID: 20314990
Hi,

CAUSE
This problem occurs because the default value for the maxRequestLength
parameter in the <httpRuntimesection of the Machine.config file is 4096 (4
megabytes). As a result, files that are larger than this value are not
uploaded by default.

RESOLUTION
To resolve this problem, use one of the following methods: • In the
Machine.config file, change the maxRequestLength attribute of the
<httpRuntimeconfiguration section to a larger value. This change affects
the whole computer.
• In the Web.config file, override the value of maxRequestLength for the
application. For example, the following entry in Web.config allows files that
are less than or equal to 8 megabytes (MB) to be uploaded:<httpRuntime
maxRequestLength="8192" />

References : http://support.microsoft.com/defaul...kb;EN-US;295626
0
 
LVL 31

Expert Comment

by:James Murrell
ID: 20318239
thanks
0

Featured Post

Revamp Your Training Process

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Ever wondered why sometimes your SQL Server is slow or unresponsive with connections spiking up but by the time you go in, all is well? The following article will show you how to install and configure a SQL job that will send you email alerts includ…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Via a live example, show how to shrink a transaction log file down to a reasonable size.
Viewers will learn how the fundamental information of how to create a table.

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question