Solved

DB2 User Access denied

Posted on 2007-11-19
5
3,112 Views
Last Modified: 2012-08-13
Hi DB2 experts , I have a problem in a user accessing database?
This is a DB2 V9.1 problem for attaching the new Brokernet user id to db2instance and database.  
Here is what I did:
   1) Add an new OS ID "brokernet" successfully.
 
   2) Update the instance: db2inst1 with the new ID "brokernet" successfully.
          [db2adm@de-kpbwp-ldb03 instance]$ sudo ./db2iupdt db2inst1 /u:brokernet,brokernet
          Password:
          DBI1070I Program db2iupdt completed successfully.
   
  3) Authenticate the new ID "brokernet" to DB2 instance failed.
         [db2inst1@de-kpbwp-ldb03 ~]$ db2 attach to db2inst1user brokernet using brokernet new brokernet confirm brokernet
        SQL30082N  Security processing failed with reason "24" ("USERNAME AND/OR
        PASSWORD INVALID").  SQLSTATE=08001

0
Comment
Question by:1981m
  • 2
  • 2
5 Comments
 
LVL 37

Expert Comment

by:momi_sabag
ID: 20318066
which os is this ?
what do you mean by "Add an new OS ID "brokernet" successfully" ?
are you sure it's password is brokernet ?
0
 

Author Comment

by:1981m
ID: 20321267
yep I am sure the pwd is same as the user name.
0
 
LVL 37

Expert Comment

by:momi_sabag
ID: 20321315
are you connecting from the server or from a client on a different machine ?
if the client is on a different machine you need to make sure you created the user on the server machine
0
 

Author Comment

by:1981m
ID: 20324112
I created it on the server and the OS is RHEL 4.x.
I trying to connect from the client  to the server.
0
 

Accepted Solution

by:
prmurphy63026 earned 250 total points
ID: 20383731
So is the new userid in DB2's administrator group?

Use  /u to specify the account name and password for the DB2 service.
This option is required when creating a partitioned database
instance.

I'm believe this will make the userID the instance owner.  As the instance owner you are 'God'.

In this command:
db2 attach to db2inst1user brokernet using brokernet new brokernet confirm brokernet

it appears there is a missing space between 'db2inst1' and 'user'. I assume that was a typo.

I would recommend setting the password at the OS level and not within the login and confirm the password change by giving the UID login privileges and logging in.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

November 2009 Recently, a question came up in the DB2 forum regarding the date format in DB2 UDB for AS/400.  Apparently in UDB LUW (Linux/Unix/Windows), the date format is a system-wide setting, and is not controlled at the session level.  I'm n…
Recursive SQL in UDB/LUW (it really isn't that hard to do) Recursive SQL is most often used to convert columns to rows or rows to columns.  A previous article described the process of converting rows to columns.  This article will build off of th…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

29 Experts available now in Live!

Get 1:1 Help Now