• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3123
  • Last Modified:

Why will this command not work for me? net use x: \\tsclient\c

I have users logging in to a term server. For a long time now the users login script would run this command. (net use x: \\tsclient\x /PERSISTENT:YES). This command would map the users locally mapped x: drive to drive letter X: on the terminal session they logged in to.
Now all of a sudden this has stopped working and I have no idea why.
0
dkitts
Asked:
dkitts
  • 5
  • 4
  • 2
1 Solution
 
victorjones1Commented:
Change tsclient to the server's ip address:

net use x: \\192.168.x.x\c /PERSISTENT:YES
0
 
dkittsAuthor Commented:
I cant do that. This goes in a login script so I wont ever know the connecting IP. Plus there will be many different connecting ips.
One thing I did see, In windows 2003 if you browse the networks. Click "Entire Network" the inside there click on "Microsoft Terminal Services". you will see \\tsclient which should be your computer. Now when you click tsclient I believe there you should see all your drive letters. So from a term server you can type \\tsclient\x and see the drive x on your client pc. None of this is working and I am at a loss. I suspect a Group Policy object is blocking this.
0
 
imitchieCommented:
In Remote Desktop Connection, have they unticked the box "Drives"?
Have you upgraded their MSTSC.EXE program?
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
victorjones1Commented:
That is the ip of the server, not the connecting machine.  Is your server using a static ip address?
0
 
dkittsAuthor Commented:
Drives is unchecked. This appears to be happening with both the old mstsc program and new one.
0
 
victorjones1Commented:
Make sure the windows firewall is either off or allowing remote desktop connections
0
 
dkittsAuthor Commented:
I cant use the ip of the server either. that would not connect me to the users drive mapping on his local pc.
0
 
victorjones1Commented:
So the tsclient folder is not on the server, it is on each individual users' PC?
0
 
imitchieCommented:
>> Drives is unchecked. This appears to be happening with both the old mstsc program and new one.

well it should BE checked
0
 
victorjones1Commented:
If the folder you want resides on each individuals different PC & each user has a unique user name then:

1 Open Active Directory, open user Properties, click on the Profile tab
2 Click the radio button next to Connect
3 Enter \\network pc name\x into the text box, and click OK

This will connect directly to the x folder regardless of where the user logs in.  

Basically, if remote user abc needs to be automatically connected to folder 123 on pc xyz then you would enter \\xyz\123 in user abc's AD profile. As long as the folders you want to connect to are shared and the windows firewall is off on that PC this should fix your problem.
0
 
dkittsAuthor Commented:
none of this worked. i would like to close this. question.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now