[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Unable to access server via VNC with firewall turned on in SLES10

Posted on 2007-11-19
2
Medium Priority
?
2,220 Views
Last Modified: 2013-11-30
Hi,

Running SLES 10 on my test machine.  Having trouble accessing the server remotely with the firewall turned on.  I have allowed the following services on Network interface (External Zone) 1. SSH 2. Remote administration 3. Remote access to Display manager.  The VNC server is running properly on the server. If I disable the firewall, I can connect without a problem.  What else do I need to do to allow remote access via vnc.  Note;  I can connect via ssh with the firewall turned on.
0
Comment
Question by:Cobraiti
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 2

Assisted Solution

by:gmilhon
gmilhon earned 400 total points
ID: 20316751
The Remote administration and remote access to display manager services aren't the services for VNC. You need a service that allows TCP port 5900. That is the protocol and port that VNC uses, you need to configure this service and allow access to it.
0
 
LVL 35

Accepted Solution

by:
ShineOn earned 1600 total points
ID: 20316811
VNC listening ports are usually 5900, 5901, etc. - the http ports are 5800, 5801, etc.

The remote access to display manager is the remote X-server service "xdmcp" which service translates to TCP port 6000-6005 and UDP  port 177.  You shouldn't need to open those unless you're going to use an X session outside the realm of VNC.

If you enable "remote administration" then TCP ports 5801 and 5901 are opened up.  That's all well-and-good if you set up remote VNC sessions only for X session 1.  If you want to use X session 0 (remote desktop) you have to manually open up ports 5800 (html VNC) and/or 5900 (VNC client.)  If you want multiple VNC sessions, you have to have more ports open in that range, but you also have to set it up so X will handle more sessions with VNC "devices."

Hope this helps.  Again, for session zero, in other words whatever the actual system's GUI looks like, interactively, you need the 5800 or 5900 port, not what SuSE Firewall plugs in for "remote administration" which is session 1, 5801/5901.

0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Desktop Connections allow you to control remote host machines via the magic of the Internet and RDP (Remote Desktop Protocol). For the purposes of this article we will assume you are connecting from your home PC or laptop to a remote offic…
Fine Tune your automatic Updates for Ubuntu / Debian
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question