Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2049
  • Last Modified:

Diable reconnect at logon

I have an XP client served by a 2003 small business server.  Originally the server logon script mapped a drive (for example H:User).  The User on the client also once mapped the drive (H:User) locally using windows explorer "map drive option".  The "reconnect at logon" check box was checked true.  The user now does not want the H: drive mapped to the client anymore.  I have modified the logon script on the server to remove the "net use" command that mapped the H: drive; however, the client maps the drive itself because of the local map command that was once executed using the "reconnect at logon" option.  

How can I get the client not to automatically locally reconnect at logon  so that the drive does not get mapped.  Is this a registry entry or is there a command the can be run locally to prevent this from occurring.
0
timlatter
Asked:
timlatter
  • 5
  • 2
1 Solution
 
beckman55Commented:
try this

net  use  /persistent:no
net  use  z:  /delete



0
 
beckman55Commented:
Right click on my computer and select "disconnect network drive"
0
 
beckman55Commented:
a lot of people are saying it doesn't completely go away until you do the above steps AND you must reboot.  Let me know if that works for you
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
beckman55Commented:
something else:

Issue has been resolved.  During login sequence other processess causing the drives not to map and unmap properly.

Set GP  "Run LogonScript Sync" policy, prevents the shell to be started before all logon scripts are finished.
0
 
qz8dswCommented:
A slight change to beckmans instructions.
Open a command prompt and the below should get rid of the drive for good.
net  use  H:  /delete

I'd also use the net  use  /persistent:no as suggested as right now persistant connections could very well be turned on.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/net_use.mspx?mfr=true

"/persistent:{yes | no} : Controls the use of persistent network connections. The default is the setting used last. Deviceless connections are not persistent. Yes saves all connections as they are made, and restores them at next logon. No does not save the connection being made or subsequent connections. Existing connections are restored at the next logon. Use /delete to remove persistent connections."

Terry
0
 
beckman55Commented:
respectfully is that any different from the first post:  besides my example using "z"

try this

net  use  /persistent:no
net  use  z:  /delete
0
 
qz8dswCommented:
Hi beckman,

Yes and I did point out it was a "A slight change to beckmans instructions."
I was correcting the incorrect drive letter and backing up what you'd originally said about why to do the persistent:no command as well with a link from Microsoft.
Experts can agree on a way forward, and your first post would be the way to go with the correct drive letter.

Terry
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now