Google's start.domain.com

I recently registered my domain with google.com/enom domain services and similarly took their offer of hosting some google apps.  The apps I'm letting google handle are mail, calendar and docs.

Now, I housed www in a different location (d1.mydomain.com).  It works perfectly since I simply changed the CNAME of www and pointed it to d1.mydomain.com.

What I want now is for mydomain.com pointed to www.mydomain.com.  Whenever I type http://eblocsoft.com it always goes to http://start.eblocsoft.com.  I removed the CNAME start pointing to d1.mydomain.com because it always show i.e. http://start.mydomain.com/index.html which looks quite unprofessional.  What I simply want to accomplish is if I type in the URL mydomain.com it will point to http://mydomain.com or simply http://www.mydomain.com.

I even implemented .htaccess script within the index.html folder to redirect mydomain.com to www.mydomain.com.  The code is shown as follows:

RewriteEngine on
RewriteCond %{HTTP_HOST} ^mydomain\.com
RewriteRule ^(.*)$ http://www.mydomain.com/$1 [R=permanent,L]

My DNS settings are shown in this link:

http://i235.photobucket.com/albums/ee293/vinceortega/20071119pst1823h_DNSSettings_enom.jpg

Can anyone please help me how to accomplish this? Thanks!

vinceortegaAsked:
Who is Participating?
 
Mark GilbertConnect With a Mentor Senior Performance EngineerCommented:
You should be able to create a wildcard alias (cname) to point to the www record.  That way, anything.yourdomainname.com should go to the www.  
0
 
Mark GilbertConnect With a Mentor Senior Performance EngineerCommented:
Additionally what you can do is do this in your htaccess:

RewriteEngine on
RewriteCond %{HTTP_HOST} ^domain\.com [NC]
RewriteRule ^(.*)$ http://www.domain.com/$1 [R=301,L]
0
 
vinceortegaAuthor Commented:
Thanks, lngwa!

But, I think that didn't do much good although I understand that it should work that way.

Maybe, by registering my domain and services (mail, etc.) under google apps, http://domain.com is always pointing to http://start.domain.com by some script they implement in their servers.

I simply can't remove the A records for google's servers because I use some of their services.

They have this 'Start' service setting to bring you to a control panel of all services that you signed up with them.  This will house snapshots of mail, calendar, etc.

As I've said earlier, I removed the start record and when I followed your suggestion of making a wildcard alias pointing to www. that still didn't work.  I even changed the .htaccess in my server as what you have suggested likewise.

For 11 hours, I thought that I was simply waiting for dns to propagate and even flushed my dns.  The problem I guess was not solved by your suggestions above because of the installed scripts of google within their servers.  The browser kept on redirecting to http://start.eblocsoft.com.

I finally made the last change (in eNom DNS service) about a few minutes ago by redirecting start host to http://www.domain.com by adding a URL-Redirect record within eNom.  It only took a few seconds for dns to propagate and it gets redirected to http://www.domain.com now.

I guess my problem is solved of seeing the 'start' in address.

Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.