• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5494
  • Last Modified:

apache warning "/.htaccess indexes options not allowed here"

I am hosting a site.  I can access the site externally.  In my apache2 error_log file I get:

/var/www/mywebsite/community/media/.htaccess: Option Indexes not allowed here, referer: http://mywebsite/community

mywebsite is just a placeholder.

my httpd.conf:

NameVirtualHost *:80
<VirtualHost *:80>
ServerName mywebsite.com
ServerAlias mywebsite.com *.mywebsite.com
DocumentRoot /var/www/mywebsite
ErrorLog /var/www/mywebsite/error_log
</VirtualHost>

I looked in /var/www/mywebsite/community/media and I see a .htaccess file.  Here it is:  

Options -Indexes
<FilesMatch "^.*\.php|.*\.html|.*\.pl$">
ForceType application/x-httpd-php-source
</FilesMatch>


What is wrong here?
Thanks in advance for your help,
 
0
AgilityIS
Asked:
AgilityIS
1 Solution
 
AgilityISAuthor Commented:
i got it

<Directory /var/www/mywebsite/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
</Directory>

Thanks, it just took a little more reading in the good ole apache book.
0
 
EE_AutoDeleterCommented:
ijk111,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now