Solved

Cannot Use VPN Client to Establish IPSec Tunnel Outside Network

Posted on 2007-11-19
14
495 Views
Last Modified: 2010-04-09
Hello Experts -
It's me again.  I got my PIX setup thanks to you but now I can't use the VPN client to connect to a client outside my network.  I have isakmp nat-traversal 20 setup but it's not allowing the VPN traffic.  What do I need to do?  Here's my config...

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Fd2kjuwTlagiu7qU encrypted
passwd Fd2kjuwTlagiu7qU encrypted
hostname pixfirewall
domain-name mycompany.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
access-list Remote_Users_splitTunnelAcl permit ip 192.168.32.0 255.255.255.0 192.168.24.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.32.0 255.255.255.0 192.168.24.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.24.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.32.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Remote_DHCP 192.168.24.11-192.168.24.40
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.32.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Remote_Users address-pool Remote_DHCP
vpngroup Remote_Users dns-server 68.87.72.130 68.87.77.130
vpngroup Remote_Users split-tunnel Remote_Users_splitTunnelAcl
vpngroup Remote_Users idle-time 1800
vpngroup Remote_Users password ********
telnet timeout 5
ssh 192.168.32.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
dhcpd address 192.168.32.11-192.168.32.40 inside
dhcpd dns 68.87.72.130 68.87.77.130
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username username password 9k0WvCzRDylvQEpn encrypted privilege 15
terminal width 80

Thanks for everything.
chezbrgrs
0
Comment
Question by:chezbrgrs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 3
14 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20318941
 Hi chezbrgrs
   You need this
   fixup protocol pptp 1723
   If you upgrade the IOS to 7.0, it will be used as inspections

Regards
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20320210
Are you trying to use IPSEC or PPTP, as MrHusy alludes to?
0
 

Author Comment

by:chezbrgrs
ID: 20320251
I'm using UDP/IPSEC.  I thought enabling isakmp nat-traversal would take care of all port issues
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 28

Expert Comment

by:batry_boy
ID: 20320341
What type of VPN device are you trying to connect to on the outside?  Does it support using IPSEC over TCP?  I've seen some environments where UDP doesn't work but TCP does.  I've also seen the reverse.  If the other end supports TCP, try that and see what you get.
0
 

Author Comment

by:chezbrgrs
ID: 20320414
It's a PIX 515.  It works fine when I'm not behind my own PIX.
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20333030
did fixup work? if didnt try this
access-list outside_access_in permit gre any any
access-group outside_access_in in interface outside
0
 

Author Comment

by:chezbrgrs
ID: 20334154
Is that fixup for IPSEC tunnels as well?  I thought batry_boy implied it was only for PPTP.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20334381
The fixup is only for PPTP tunnels being initiated from inside the PIX outbound to an external PPTP server.  MrHusy's suggestion of allowing inbound GRE traffic is to allow PPTP traffic initiated externally to come inbound.
0
 

Author Comment

by:chezbrgrs
ID: 20335350
After looking around on the web, does the isakmp traversal need to be setup on the endpoint VPN.  It's setup on mine but I'm not sure about the other one.
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20335385
"MrHusy's suggestion of allowing inbound GRE traffic is to allow PPTP traffic initiated externally to come inbound."

yep batry you re correct, I misunderstood, ignore it.
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 20337218
>>After looking around on the web, does the isakmp traversal need to be setup on the endpoint VPN.  It's setup on mine but I'm not sure about the other one.

Yes, it needs to be set up on the firewall that you're connecting to.  Since you're behind a NAT device (your PIX)when you make the VPN connection, this command will be necessary for you to see traffic behind the remote PIX.  However, it typically allows you to connect, but not see any hosts.  You're reporting that you can't even connect so this sounds a little different.

Have you tried connecting from a different site other than from behind your PIX?  This may isolate the problem further by telling you if it's something to do with your PIX or not.  I'm thinking you need to start looking at the remote PIX configuration.
0
 

Author Comment

by:chezbrgrs
ID: 20339092
I took a look at the remote PIX configuartion.  It's running 6.1 and isakmp nat-traversal was not introduced until 6.3.  I can't upgrade it now so do I have any alternatives to using nat-traversal?
0
 

Author Comment

by:chezbrgrs
ID: 20340237
Thanks batry_boy.  I upgraded to 6.3(5) and issued the isakmp nat-traversal command.  It's now working...thanks for your persistance.

chezbrgrs
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20345695
Good deal...glad to help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question