How to forward mail to another smtp-server if the recipient is not found locally but has the same domain name


Our setup:
We have a internet domainname at our webhosting provider:
Our local domain is also called
All external mails are delivered to our provider and are downloaded to our Exchange via gfi mailessentials.
All our employees & external representatives have a mailadress
Our external representatives work at home and download the mail from our provider.

Our problem:
We can send internal mails to and external mails to without a problem.
But if we send a mail to our representatives ( we get a non delivery message from our exchange-server: #550 5.1.1 RESOLVER.ADR.RecipNotFound; not found ##

Untill last week we used Exchange 2003 without a problem. There was a setting to route mail for unknown recipients to the smtp-server of our provider.

Attached my non delivery message (in Dutch)
Uw bericht kan niet worden bezorgd bij de volgende personen of distributielijsten:
Dit e-mailadres van de geadresseerde is niet gevonden in het e-mailsysteem van de geadresseerde. Microsoft Exchange probeert dit bericht niet opnieuw te verzenden. Controleer het e-mailadres van de geadresseerde en probeer dit bericht nog eens te versturen of geef de volgende diagnosetekst door aan uw systeembeheerder.
Verzonden door Microsoft Exchange Server 2007 
Diagnostische gegevens voor beheerders:
#550 5.1.1 RESOLVER.ADR.RecipNotFound; not found ##
Oorspronkelijke berichtkoppen:
Received: from ([]) by
 ([]) with mapi; Sun, 18 Nov 2007 23:28:13 +0100
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: Youri Aerts <>
To: "''" <>
Date: Sun, 18 Nov 2007 23:28:12 +0100
Subject: test
Thread-Topic: test
Thread-Index: AcgqMk3ORZAPYm7oSSiO6mW1UxDnow==
Message-ID: <>
Accept-Language: nl-NL, en-US
Content-Language: nl-NL
X-MS-TNEF-Correlator: <>
MIME-Version: 1.0

Open in new window

Who is Participating?
CompuFitAuthor Commented:
I already read this, but don't ounderstand what to add to the accepted domains.
I already have 1 item here: type: Authorative.

Shoul I add our smtp server from our provider? (

CompuFitAuthor Commented:
Playing with th different "Accepted domain"-settings, I found the solution:

Our domain "" was already in there with type "Authoriative".
I changed this to "Internal relay" and now this works fine.
CompuFitAuthor Commented:
Found the solution myself after being pointed in the right direction.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.