File Association Problem

I am currently using CRXI. When saving report to my desktop or local drive; then double clicking on the report icon is not being associated with the crystal so therefore crystal does not start up. I have to open up Crystal itself then choose Open from the menu to open up reports.

I have tried right clicking on the icon then choosing Open With > Choose Program, then check always use the selected program to open this type of file; XI does not appear in the list of programs. I then browse to the folder that has crw32.exe in it and choose this. Again this does not associate crystal with the file.

Can anybody help?

Thanks
halifaxmanAsked:
Who is Participating?
 
dreamyguyConnect With a Mentor Commented:
1.Have you tried re-installing the application? I guess that's the easiest way to fix all the file associations.
2. Other way would be to go to a working machine, open up the registry and go to HKCR\.rpt (or whatever the extension of the document is that has the issue) export to a reg file it by right clicking on it and choosing export, move it over to the machine with the issue, take a backup of the exisiting key on the problematic machine, delete it and then import the fresh (working) registry key.
0
 
and235100Commented:
Go to Control Panel, Folder Options, File Types tab.

Add in a new association - with the correct extension and associated path to the program.



0
 
and235100Commented:
(normally .rpt or .rpc)
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
halifaxmanAuthor Commented:
thanks for the answer, the file extension rpt is associated with internet explorer for whatever reason, when I try and  change it to CR it doesnt happen
0
 
and235100Commented:
Okay - delete the association - reboot - and put in a new one, linked to the correct program.
0
 
halifaxmanAuthor Commented:
the delete option for that one is greyed out
0
 
sramesh2kCommented:
Hi halifaxman,

If I understand correctly, in the Open with dialog, the (Crystal Reports) crw32.exe entry does not appear in the list of programs even though you choose "Browse..." and locate the file manually?
0
 
2PiFLCommented:
You have to be at least a Power User to make those changes permanent.
0
 
halifaxmanAuthor Commented:
sramesh2k - thats correct
0
 
sramesh2kCommented:
>> sramesh2k - thats correct

See if registering crw32.exe using this tool helps.
http://windowsxp.mvps.org/openwithadd.htm
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.