Images not displaying on Amazon website

Posted on 2007-11-20
Last Modified: 2009-05-20

For some weeks now, we have had problems getting the images on the Amazon website to display. The problem seems to be that the servers where the images are stored ( and similar) cannot be resolved by our internal DNS correctly. Apparently Amazon now host their product images on Akamai servers which are aliased to the above address. I have tried to create a manual zone on our W2k3 DNS servers to circumvent this problem without success.

No other websites we access have this problem.

Can anyone suggest a method by which we can circumvent this problem. Our library people use Amazon a lot.


Question by:pemyers
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
LVL 71

Expert Comment

by:Chris Dent
ID: 20318933

On your DNS Server could you do:

set type=ns

It should come up with a fairly big pile of them on Ultradns.

If that fails, how do you handle Public Name Resolution? Forwarders or Root Hints? If you use Forwarders could you try removing them and re-testing (so we can see if it's your server, or a server upstream from yours)?

It should work really if it's Root Hints. There's one issue that springs to mind, but to know if that could be it: What do you use as a Firewall on your network?


Author Comment

ID: 20320486
Our DNS is set up with two zonal servers forwarding non-internal requests to a non-zonal server which uses root hints to resolve names. As I said this works for every other website we use. I tried your suggestions for nslookup and I do get results for both and When I try for A or CNAME records I get the Server Failed message in nslookup.

We are using a multi-tech RouteFinder 600vpn as a firewall.

I hace since found other people in various forums with the same problem, but unfortunately no resolution.
LVL 71

Accepted Solution

Chris Dent earned 250 total points
ID: 20320565

Interesting... has both NS and CNAME bound to it. That's just blatantly illegal syntax and should have stopped the zone from loading on an RFC complaint Name Server.


> set type=ns
Server:  <Mine>
Address:  <Mine>

Non-authoritative answer:   nameserver =   nameserver =   nameserver =   nameserver =       internet address =       internet address =       internet address =       internet address =
> set type=cname
Server:  <Mine>
Address:  <Mine>

Non-authoritative answer:   canonical name =

Is this the only thing that fails for you?

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.


Author Comment

ID: 20321183
Yes. As I said before, I haven't experienced this problem with any other website.



Author Comment

ID: 20358458
Not really a solution but pointed me in the right direction. I switched from using Root-Hints to using Forwarders and I was able to resolve the Amazon image servers.


Expert Comment

ID: 20508214
I was getting the same problem at one of my clients' sites. I resolved it by creating forwarders in the Windows 2003 DNS Manager and specifying the client's ISP DNS servers as the fowarder IP addresses.

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
rDNS on single IP and multiple domains 11 77
Configuring DAG with different CU level ? 6 66
external website is 16 39
domain controller shut down question 6 65
If you have a multi-homed DNS setup in windows, you can have issues with connectivity to the server that hosts the DNS services (or even member servers of your domain if this same DNS server is a DC). This is because windows registers all of its IPs…
I will assume you are running a non-server version of some sort of Windows throughout this article. There are many flavors of Windows since Windows Server 2000 - 2008, XP Home & Pro, Vista Home & Pro, and Windows 7 Starter, Home, Pro, Ultimate, etc.…
In a recent question ( here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question