Nero 7 turns some AVI files into stills ("Picture Video Source")

I have suddenly developed a problem with Nero 7. When I drop an AVI file from my Fuji digital camera into the timeline, it changes it to a still picture that is described as "Picture Video Source" that runs about 10 seconds in the timeline, even though the original AVI is much longer. Other sources of AVI file are fine. Has anyone else had similar problems with Nero? Did you find the problem and a solution?

Thanks in advance,
Who is Participating?
MereteConnect With a Mentor Commented:
Hi, dont really know coudl be many things, I would upload the files off the camera first to the hdd.
Is this a true avi or a raw avi, taking short movies with a digital camera come in various formats and can not always be functional, how much space on the card comes into play, is this something you have done often and the problem has just started?
If you can go back and retrace your steps things like was the camera low on battery? have you installed any new programs?
Play the avi in something else and see it the file is okay otherwisae it maybe corrupted.
As I said sometimes we take a shot believe it its good but didnt notice it failed.
You can drop it on gspot GSpot is a free utility which identifies the codec required to play an AVI file and supplies other information as well. it could inform you if the file is corrupted.

Do you still require assistance,
Your question is still open?
Is your account still active
You can now close your own question use the delete link
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.