Solved

MSQL Reports Service Error installing Team Foundation Server

Posted on 2007-11-20
11
545 Views
Last Modified: 2013-11-26
I'm installing TFS on W2k3 R2 with MSQL2005

Finishing the TFS setup, I got this message:

"Error 29112. Team Foundation Report Server Configuration: Report Server is not properly configured or the Reporting Services Web site could not be reached. Use the Report Server Configuration tool to confirm that Report Server is configured properly and that Reporting Service Web site can be founda before running the installation again. For more information see the Team Foundation Installation Guide."

Then, I go to the SQL Report Configuration page and I see the error in Web Reports Site configuration.
But trying to configuring I got this message:

"ReportServicesConfigUI.WMIProvider.WMIProviderException: A virtual directory must first be created before performing this operation.

   at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.SetWebServiceIdentity(String applicationPool)"

Any idea?  I created the Virtual Directorys but something I'm missing cause I still getting this same error trying to configure the Web Report Service.

Thanks!
0
Comment
Question by:CaLoFs79
  • 6
  • 5
11 Comments
 
LVL 18

Expert Comment

by:Yveau
ID: 20322761
Also created the application pool ?

Guess you already saw this one:
http://msdn2.microsoft.com/en-US/library/ms143736.aspx

Hope this helps ...
0
 

Author Comment

by:CaLoFs79
ID: 20323103
Yup, I saw it before that. And I followed those instructions.
Yes, I created the application pool and the virtual directory, I did it twice checking the instruction but not, still getting the same error in the "Reporting Services Configuration" of the MSQL.

"A virtual directory must first be created before performing this operation."
 
:/
0
 
LVL 18

Expert Comment

by:Yveau
ID: 20323311
... did you create the physical path on the machine before mapping the virtual directory to it ?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:CaLoFs79
ID: 20323345
Yes, I used the default in MSQL reporting system.

C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager

And

C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer

Is that ok, or maybe I'm using the wrong one :P
0
 
LVL 18

Expert Comment

by:Yveau
ID: 20323754
... shouldn't you create a virtual folder for the website ?
I checked my installation documents and found d:\websites\reportingservices ...  you've got 2 ? I only have 1 ... And those folders do exist on the drive ?
0
 

Author Comment

by:CaLoFs79
ID: 20323903
Yes, I created them from zero.
I'm using the default website in IIS.
--
For default the MSQL setup these virtual folder in the default website, right? Or should I create them in other website? how can I check that?

In the "Reporting Services Configuration Manager" the "Report Manager Virtual Directory" and "Report Server Virtual Directory" looks fine (with the check).
Only the "Web Service Indentity" looks is disabled (with the X).
I'm using them because I found them there when I got the error.

1. I create the virtual folder
2. I set the application pool as it demands: "ReportManager" and "ReportServer"

is that Right?
0
 
LVL 18

Accepted Solution

by:
Yveau earned 500 total points
ID: 20324005
Yep sounds like a clean and proper setup to me ...
You did restart the webservice ... probably ten times by now :-)

... looks like you need one of the IIS experts for this one ... I'm just a simple database guy ... sorry !
0
 

Author Comment

by:CaLoFs79
ID: 20335388
Well, I Found the solution.

I just deleted the "SQL web reporting services Virtual Directories" of the "Default Website" in the IIS manager and using the "Reporting Services Configuration" a create a "new" virtual directories for the server and manager options. then in the "Web Service Identity" put the new Application Pools just created before.

And that's it. It works now. Now all the blank spaces are filled and running.

Looks like a bad configuration while installing sql.

Thank you Yveau.
0
 

Author Comment

by:CaLoFs79
ID: 20335395
More explained.

I clicked the "New" button, created a new virtual
directory for each and deleted the old ones in IIS Manager. I then created
new virtual directories again using the old (default) names so I could be
back to the original configuration. Then I changed the Web Service Identity
from DefaultAppPool to ReportServer and everything was fine. This assumes the
UrlRoot in rsreportserver.config is correct.

Regards,

CaLoFs
0
 

Author Closing Comment

by:CaLoFs79
ID: 31410190
I found the solution by my self. but thank you very much for the help. You helped a lot looking for the right steps to take.

0
 
LVL 18

Expert Comment

by:Yveau
ID: 20335997
Thanks for the feedback !
Glad I could be of any help and thanks for the grade !
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

More often than not, we developers are confronted with a need: a need to make some kind of magic happen via code. Whether it is for a client, for the boss, or for our own personal projects, the need must be satisfied. Most of the time, the Framework…
Use this article to create a batch file to backup a Microsoft SQL Server database to a Windows folder.  The folder can be on the local hard drive or on a network share.  This batch file will query the SQL server to get the current date & time and wi…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question