• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 242
  • Last Modified:

Poor performance after upgrade to 2003 Enterprise

We're running Citrix Metaframe 4.0 on Server 2003 Enterprise on an IBM HS20 blade server.  We upgraded this past weekend from Server 2003 Standard, and increased the memory from 4GB to 8GB.  Of course, added the /PAE switch to the boot.ini file.  (The upgrade also forced us to roll back SP2, to the 2003 Ent upgrade, then install SP2 again)....Ran all the Windows updates and upgraded to IE7 from 6.  We usually run about 50-60 Citrix thin client users on this server with out too much problem, except quite a bit of sluggishness, hence the upgrade to Enterprise to allow the added memory....Since the upgrade, the server is even more sluggish, forcing us to cut users'  ICA connection color depth from 16bit to 256 to speed things up, which isn't acceptable in the long term.   Windows sees the full 8GB of memory, but there's still over 5GB of unused memory.....double dual core processors are at 50-70%.    Any suggestions to speed up the responsiveness would be great.   Example of sluggishness: scrolling down a list can be very slow as the page visibly "wipes across" to refresh the screen.
0
itatahh
Asked:
itatahh
2 Solutions
 
TheMetrixCommented:
I would start looking at your network and not just the servers.

We had a slow connection and users being dropped for no reason at all on our Citrix System for about a year. I kept thinking it was with out servers or with the workstations and thin clients. Come to find out it was a network problem. A router between out Plant here and our offices down south had gone bad.
0
 
robocatCommented:
If your Citrix server performance was not limited by RAM but by CPU, adding the extra RAM will not help and the /PAE switch can actually degrade performance slightly.
Since you state that the server leaves 5 GB RAM unused, this may be the case.

Try to reboot without the /PAE and see if performance goes back to the previous level. If not, you may have some other problem.


0
 
itatahhAuthor Commented:
Neither of these solutions really solved the problem, which seems to have simmer down.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now