Solved

Fault tolerance configuration with 2 NIC

Posted on 2007-11-20
14
1,369 Views
Last Modified: 2013-11-09
Hi,

We have one dell server in which there are 2 Gigabit NIC cards (LAN Card), usually in that we will be using only one NIC card, other will be not used.

I need to know how to configure the other as the backup NIC card as something like fault tolerance. If the first one which we are using fails automatically the second should work.

The OS is windows 2003 Std Edition.

I need to have the same ip address on both the nic cards.

Pls let me know how to configure the same.
0
Comment
Question by:expertblr
  • 7
  • 6
14 Comments
 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20326302
To get this configured, both "ends" must support it: the NIC driver and the network switch where both NICs are attached.
Its called "NIC teaming", and can be configured for aggregation and/or fault tolerance.

I think Dell uses Broadcom NICs. You need the Broadcom driver and the Broadcom configuration tool. You will create a "virtual" NIC that gets the IP address containing both physical NICs.
What you need to configure on your switch depends on the manufacturer of your hardware.

0
 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20326314
Broadcom calls it "BASP"

55.)        What is BASP (Broadcom Advanced Server Program)?

BASP is a Broadcom intermediate software driver for Windows Server 2003, Windows 2000, Windows NT, NetWare, and Linux that provides load-balancing, fault-tolerance, and VLAN features. These features are provided by creating teams (virtual adapters) that consist of multiple NIC interfaces. A team can consist of one to eight NIC interfaces, and each interface can be designated as primary or standby. All primary interfaces in a team will participate in load-balancing operations by sending and receiving a portion of the total traffic. Standby interfaces will take over in the event that all primary interfaces have lost their links. VLANs can be added to a team to allow multiple VLANs with different VLAN IDs. A virtual adapter is created for each VLAN added. Load-balancing and fault-tolerance features will work with any third party's NIC adapters. VLANs only work with Broadcom NIC adapters.

http://www.broadcom.com/support/ethernet_nic/faq_drivers.php
0
 

Author Comment

by:expertblr
ID: 20326467
Hi,

I have dell server in which i have 2 Gbic NIC Cards which are Broadcom Nextreme Gigabit and if i go the Nic or LAN properties i am able to see the option Network Load balancing currently that option is unchecked.

Now pls tell me how do i configure such that if one network card fails the other should come up automatically ( same ip address for both the nic cards) and i have cisco 4507 switch which is also having gigabit ports where this server is connected.

0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20326563
Since I'm not up-to-date with Cisco's IOS, I hope I'm able to help you. I found an info via google that the newer Cisco IOS versions will automatically recognize when you connect teamed network cards. So configure your team on the Dell server. A new network card will appear. Make sure it gets the correct IP config. Then check if your system is reachable.

If this is not working, here's how you normally would configure it manually on the older switches (can't test here, so be careful!). Adjust the port names to your config!

interface port-channel1
description port-channel1
spanning-tree portfast
!
exit
!
interface GigabitEthernet1/1
description port-channel NIC 1
spanning-tree portfast
channel-group 1 mode on
!
exit
!
interface GigabitEthernet1/2
description port-channel NIC 2
spanning-tree portfast
channel-group 1 mode on
!
0
 

Author Comment

by:expertblr
ID: 20326594
Hi,

How to configure the team on the dell server??????????

And note i dont want to do any network load balancing
0
 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20326761
0
 

Author Comment

by:expertblr
ID: 20327138
For my secnario which one would you refer


Smart Load Balancingâ„¢ and Failover
Link Aggregation (802.3ad).
Generic Trunking (FEC/GEC)/802.3ad-Draft Static
SLB (Auto-Fallback Disable).

Pls let me know
0
 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20327463
Smart Load Balancing and Failover
0
 

Author Comment

by:expertblr
ID: 20327567
Hi,

Should i have to assign different ip addresses for different nic or same for both the nic, how it is?????
0
 
LVL 28

Accepted Solution

by:
Michael Pfister earned 250 total points
ID: 20327797
No, the 2 NICs won't get an IP address at all. The IP address will must be assigned to the new team!
0
 
LVL 9

Expert Comment

by:dreamyguy
ID: 20327838
0
 

Author Comment

by:expertblr
ID: 20328007
Ok I will check this and let you know ........
0
 

Author Comment

by:expertblr
ID: 20338605
Hi,

It worked fine, but the problem is at time of primary network card failure and at the time of switching i am seeing one or two request time outs ( i had given continous ping and checked)

Thanks
0
 
LVL 28

Expert Comment

by:Michael Pfister
ID: 20349381
Yes, you will see a short connectivity drop. But TCP can handle that so your users won't notice.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Issue with  IP address/conflict 10 95
CMDB relationships for hardware assets 2 75
Disabling energy efficient ethernet on all hardware models 6 51
Cisco WLAN 5520 licensing 10 35
We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question