• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1474
  • Last Modified:

No DNS across VPN and can't access Exchange server

I'm working on a client's machine (at home) where DNS doesn't seem to be working across the VPN. We are establishing the VPN between the clients computer and the router at their office. The VPN router is a Linksys RV082 and we are using the built in pptp server. The VPN establishes fine. I can ping the server. When I ping via the server name, I get proper IP address resolution.

THe DSL router is handing out a 192.168.1.x address scheme. The VPN is on 192.168.0.x. I can ping the server as I said which is on 192.168.0. 1.

DNS on the server (SBS 2003) is set correctly for DNS with proper forward and reverse zones.

On the home computer, the router is handing out ip address and handling DNS. On the VPN setting, I set the IP address configuration to automatically get the IP Address (which is handed out by the Linksys Router) but I set the DNS manually to point to the server (192.168.0.1).

I added a record to the host file where
192.168.0.1    servername

I reduced the mtu to prevent fragmenting (ping -f -l 1500 www.somedomain.com). The fragmenting stopped once the packet size was reduce to 1350.

When I run NS lookup on the client machine, I get the following message:

nslookup servername
server: home
address: 192.168.1.254

*** home can't find servername: Non-existent domain

The 192.168.1.254 is the ip address of the (home) router for DNS. I don't understand why it won't look to the VPN for resolution.

While I can access the data files via IP address (192.168.0.1/data), Outlook won't work because it can't find the exchange server.

This is getting to be a really issue for the client and I need help to clear it up. It'll be nice to know why this isn't working the way that I expect.

Thanks in advance for the assistance.

Regards,

Bill Marquardt
0
w_marquardt
Asked:
w_marquardt
  • 3
  • 2
1 Solution
 
brian_36526Commented:
Why not just add the exchange server to the host table. Not to mention an RV082 doesn't have a place in an environment that has their own exchange server.
0
 
cooleditCommented:
Hi, there

All DNS settings should be determined by the VPN server the router/server who hands out the IP address should also handle the DNS settings and so on.

As soon as you start the VPN clients all is handled by the VPN server, think it as a mobile network when you turn on your phone you get handed out a connection from the provider he knows your phone id. It works the same here.

Cooledit
0
 
w_marquardtOwnerAuthor Commented:
Brian_26526:

Maybe I'm not understanding how to add the exchange server specifically to the hosts table.

Here's what I have and maybe you can explain what I have wrong.

Lets say the server name is server1. This is small business server 2003 so the exchange server is built in.

In the hosts table I have already entered the following:

192.168.0.1    server1

I figured this would cover the exchange server too. If I ping server1, I get the correct ip address back. (192.168.0.1)
Is there something else I need to do for the hosts table to get it to relate to the exchange server?

CoolEdit:

I would think that DNS should be handed out by the router / pptp server as well but there's no provision for that on the RV082. The PPTP server hands out an IP address only. Wouldn't setting the DNS setting (on the INternet Protocol Properties page) to point to the server on the VPN have the same effect? Must not be as it's not working but I'm no seeing the difference.

Thanks,

BIll
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
brian_36526Commented:
You have to enter the server name as you configured it in the outlook client.
0
 
w_marquardtOwnerAuthor Commented:
Okay... I won't get a chance to check that out until Friday but it sounds promising.

Thanks,

Bill
0
 
w_marquardtOwnerAuthor Commented:
Sorry for the long delay on this. Didn't catch up with the client as expected and then she left of vacation. Made the change this morning and having the full name of the server in the hosts file resolved the problem completely.

Thanks,

Bill
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now