Solved

BoundsChecker causing cl.exe to crash

Posted on 2007-11-21
11
883 Views
Last Modified: 2013-12-14
Hello,

I am using Compuware BoundsChecker 8.2.1 version (I had same problems even with earlier versions) on VS 2005 and I get problems in building project with Instrumentation on. It shows that the Microsoft (R) C/C++ Optimizing Compiler has encountered a problem and needs to close.

In fact same crash occur in VC 6.0 too.
In VS 2005 I have installed SP1, but that did not helped. I have Incredibuild installed too, but I do not use it to build with instrumentation.

Did anyone had the same problem before and was luck to solve it?
Thanks
0
Comment
Question by:Reperio
  • 4
  • 3
  • 3
11 Comments
 
LVL 11

Expert Comment

by:DeepuAbrahamK
ID: 20326601
Try these settings:
Project->Properties->Config Properties->c++->Optimization-> Disable
Project->Properties->Config Properties->c++->Global Optimizations-> No
Best Regards,
DeepuAbrahamK
0
 

Author Comment

by:Reperio
ID: 20326618
They are off in "Debug" config. It do not help.
0
 

Author Comment

by:Reperio
ID: 20326635
Compuware replied:

"Having Incredibuild installed at the same time as DevPartner is a known
issue and will cause instrumentation problems along with possible crashing.
Also, any anti virus software installed on a development machine while using
DevPartner studio is a known issue and may cause problems.

It is recommend that you you remove Incredibuild and disable any
anti-virus software when profiling with DevPartner Studio as this constitutes an
unsupported environment."

But, figuratively speaking, it is not a good solution!!!
Its interesting, what causing such problems...
0
Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

 
LVL 40

Expert Comment

by:evilrix
ID: 20326765
BoundsChecker is instrumenting your code during a build, meaning it is injecting additional code into the final binary that is then used to facilitate its ability to check for out of bounds situations. I guess the problem is that Incredibuild is also attempting to modify the code (it's an aggressive optimizer, right?) and the two are conflicting. Are you able to disable Incredibuild on an ad-hoc basis? If so maybe you can just disable it when you need to do BoundsChecker intrumented builds.

As for the AV problem, I can only guess that the concern is that the AV Engine may scan a binary with instrumentation and false positive on it -- I've never had problems with AV Engines before when building instrumented code.

-Rx.
0
 

Author Comment

by:Reperio
ID: 20326786
It is strange, because there are two ways: to use VC++ Build or with Incredibuild. I use the first one for Instrumentation and Incredibuild should not influence this method of build.

I look for a way to disable Incredibuild quickly. Simple "Service Stop" do not works. I wonder how it could be done...
0
 
LVL 11

Expert Comment

by:DeepuAbrahamK
ID: 20326807
Not sure incredibuild injects any code though. I am using it diffrent profilers
Best Regards,
DeepuAbrahamK
0
 
LVL 40

Expert Comment

by:evilrix
ID: 20326841
>> Not sure incredibuild injects any code though
Yes, I've just looked at the website and it seems to be a build facilitator rather than an optimizer. It allows for, amongst other things, distributed builds. I suppose, if this is what's being done I can see how this could be a problem... if parts of the build are done with instrumentation and parts aren't.

http://www.xoreax.com/technology_architecture.htm

I can only suggest disabling it if you don't want to remove it -- if that's possible. I don't know this product so I cannot advise further.

-Rx.
0
 

Accepted Solution

by:
Reperio earned 0 total points
ID: 20337607
Problem was solved from IncrediBuild side.

Suggested actions:
1. Please set interoperability mode to Disabled and try again running the instrumented BoundsChecker build.
If the build finishes successfully, it means that BoundsChecker cannot run when IncrediBuild Interoperability mode is enabled.
2. Please remember to enable the Interoperability mode once running VS builds without BoundsChecker.

And it worked.
Thank you for support
0
 
LVL 40

Expert Comment

by:evilrix
ID: 20337671
Ah, good :)
Very welcome.
0
 
LVL 11

Expert Comment

by:DeepuAbrahamK
ID: 20337711
cool
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article will show you some of the more useful Standard Template Library (STL) algorithms through the use of working examples.  You will learn about how these algorithms fit into the STL architecture, how they work with STL containers, and why t…
Here is a helpful source code for C++ Builder programmers that allows you to manage and manipulate HTML content from C++ code, while also handling HTML events like onclick, onmouseover, ... Some objects defined and used in this source include: …
The viewer will learn how to use the return statement in functions in C++. The video will also teach the user how to pass data to a function and have the function return data back for further processing.
The viewer will be introduced to the technique of using vectors in C++. The video will cover how to define a vector, store values in the vector and retrieve data from the values stored in the vector.

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question