Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1950
  • Last Modified:

Send as permission

Hello, I'm using SBS 2003.
I created a new functional mailbox called "support".
I added this mailbox in the outlook profile of some users as "additional mailbox".
the users have the full mailbox access in the mailbox rights
the users have been added in the delivery options.
Problem : when i send an email to the support mailbox, the user is able to reply (the from field is support).
When the user try to send a new email using the from field with support, he receives a message saying that he's not authorized to send this message...
I tried to add the user in the security tab with the send as permission but without success...
Do you have any ideas ? thanks !!!
0
mmarchant
Asked:
mmarchant
1 Solution
 
mcse2007Commented:
i assume you have done the below already:

from 'support' account properties in exchange, you give this user a permission to "send as".

try getting that user to log off and login in again to get the security changed kicks in
0
 
mmarchantAuthor Commented:
hi, yes i already did it. no success :-(
0
 
SembeeCommented:
The Send As permission is what you need. However if you have made the permission change and then tried it immediately, I would not expect it to work. Exchange caches permissions and that cache is only flushed every couple of hours.

You should also be aware that additional permissions on certain protected accounts may be removed by Exchange automatically - if the account is a member of Domain Admins for example.

Simon.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
MrLonandBCommented:
I would try and delete the account being used with the mailbox, create another account and make sure it is not inheriting any permissions that would deny the send as ability, then reconnect the mailbox to the new NT account.
0
 
mmarchantAuthor Commented:
let me clarify the permissions i gave just to be sure there is no misunderstanding :
in the AD, in the "support" account properties :
1)in the "exchange advanced" tab, in "mailbox rights" : full mailbox access to the user
2)in the "exchange general" tab, in "delivery options" : I add the user
3)in the "security tab" : "send as" permissions for the user.
is that right ?

thanks
0
 
SembeeCommented:
Why are you adding the user in the delivery options? If you are doing that then having mailbox permissions as well is pointless, as they will already have a copy of the message in their own mailbox.

Otherwise the rest of the settings are correct, you may simply have permissions cache issues.

Simon.
0
 
mmarchantAuthor Commented:
well, it's still not working and i made the changes 3 hours ago...
How can I force to have these case permissions flushed manually ?
0
 
SembeeCommented:
The only way to force the cache to be flushed is to restart the information store. That will kick all of the users out though.

Simon.
0
 
mmarchantAuthor Commented:
i made the test on my 'test environment" which is exactly the same as my "prod environment" and it works with the following permissions :
1)in the "exchange advanced" tab, in "mailbox rights" : full mailbox access to the user
2)in the "exchange general" tab, in "delivery options" : I add the user in the "send on behalf"
I did not add the "send as" permission in the security tab.
I'll restart the prod SBS server this evening and see if it is working after the reboot but I doubt...
0
 
mmarchantAuthor Commented:
when i compare the permissions between the 2 environments, the only difference is the following :
in the exchange advanced permissions of my prod environment (where it is not working), in "mailbox rights", "advanced tab", i have "deny - exchange domain servers - full mailbox access - parent object"...
0
 
SembeeCommented:
In that case one of the servers is not fully up to date on patches.
Until Jan 06, Full Mailbox Access also granted you Send As permissions. That behaviour was changed by an update to Exchange.
It is discussed in this article: http://support.microsoft.com/default.aspx?kbid=895949

"Send on Behalf of" is different to Send As, and will result in email messages going out as User 1 on behalf of User 2.

The permissions that you are seeing for Full Mailbox Access is not what I would expect to see. A deny should not be present for that group.

Simon.
0
 
Pepe102598Commented:
Do anybody knows how to you give a user a permission to "send as" using vb script? I need it to use in a web application
0
 
SembeeCommented:
Pepe - this is an old question. Unlike a forum it is not possible to "bump" questions back up the list. The only people who will see your post are those that have already participated. Instead you should post your question as a new question in the Exchange Server Zone which will allow other experts the chance to see the question and respond.

Simon
Exchange Server Zone Advisor.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now