Solved

Backupexec throwing Access is Denied to network share

Posted on 2007-11-21
14
7,516 Views
Last Modified: 2013-12-01
I have a NAS which is running NASLITE-2, which is basically just a very tiny OS based on linux that runs as a NAS.

The drives on my NAS are all available for anyone to access with no login or password required. It is a member of a local Workgroup, unfortunately NASLITE does not have the option for joining a windows domain controller.

In Backup Exec everytime I try and select the network share on \\naslite I get an "Access is Denied error". In Backup Exec I have tried to set the login credentials to the admin/password of the nas, empty values, blank values, etc but nothing seems to work.

It shouldnt need any sort of credentials to connect to it, I can connect to naslite from Mac OS X, Windows XP, Linux servers, etc without problem.

Is there any kind of way to get Backup Exec to connect to those network shares or a work around?

Thanks
0
Comment
Question by:JasonWinn
14 Comments
 
LVL 2

Expert Comment

by:terrydavis
ID: 20329709
How do you restrict who can access the NAS?  If you don't use authentication, does it look at the source IP address of the client?
0
 
LVL 12

Expert Comment

by:opie6373
ID: 20329751
i have one linux server in my environment and i have a linux remote agent installed it to back it up.  can you put a linux remote agent on the nas?
0
 
LVL 3

Author Comment

by:JasonWinn
ID: 20329886
Hey Guys,

To answer each of your questions, I cannot restrict access to the NAS. Basically its open to everyone as default.

If it was Ubuntu or something then yes I could install the remote agent but I dont think there is anyway of installing the remote agent on the nas.

Here is the OS that I am using:

http://www.serverelements.com/naslite-2-usb.php
0
 
LVL 12

Expert Comment

by:opie6373
ID: 20330472
so if you telnet to the nas you don't have to enter any login credentials?  
0
 
LVL 12

Expert Comment

by:opie6373
ID: 20330607
ooops disregard, appears you have already set the login credentials to those of the nas

according to this article, you can buy an add-on which should allow you to backup your NAS (if you are using 11d)

http://seer.entsupport.symantec.com/docs/284987.htm

9 and 10d it says NAS that don't run on windows OS are not compatible:
http://seer.entsupport.symantec.com/docs/237737.htm


0
 
LVL 12

Expert Comment

by:opie6373
ID: 20330614
my only other suggestion is to contact the vendor of the naslite device and find out what you can about backup options (or look at your documentation)

or contact Symantec
0
 
LVL 9

Expert Comment

by:cooledit
ID: 20333262
hi, there

in the selection list last is user selected is that where you have created the what to backup list. ?

Cooledit
0
Superior storage. Superior surveillance.

WD Purple drives are built for 24/7, always-on, high-definition security systems. With support for up to 8 hard drives and 32 cameras, WD Purple drives are optimized for surveillance.

 
LVL 23

Expert Comment

by:Iamthecreator
ID: 20339250
Try adding the NAS to the USER DEFINED SELECTION using the IP address.
If you are able to see it in the selction list you will be able to back it up
0
 
LVL 3

Author Comment

by:JasonWinn
ID: 20350699
Hi All,

Opie6373 - I will look into that NDMP option, it is $1800 tho which seems sort of pricey just for backing up to a NAS.


I tried making it a user defined selection, but when I try and pick to expand that user defined selection I receive this error:

An error has occurred while attempting to browse the contents of naslite-2\Shares\Disk-1. A communications failure has occurred.

Any idea's on why it's not working as a user defined selection?
0
 
LVL 12

Expert Comment

by:opie6373
ID: 20350818
i've seen this error when i tried to click on my linux server before the remote agent was installed.  

i doubt it will work but you have tried pushing a remote agent out to the device?  

whow on the add-on--$1800 huh?  that's insane.

have you tried mapping a drive to the nas and then selecting the share from the mapped drive in the select list?  i'm sure you already do, but you need to have the selection enabled to backup user shares

0
 
LVL 3

Author Comment

by:JasonWinn
ID: 20350969
Hey Opie,

Maybe it is not supported in 11d but this is what I did:
Tools > Options > Network & Security: Enable selection of user shares.

I mapped the network drive to Z and I can navigate to it from My Computer. I tried creating a new backup to disk folder and a new backup job and neither one see's the Z drive. Any ideas?

0
 
LVL 12

Accepted Solution

by:
opie6373 earned 500 total points
ID: 20351067
yeah, my bad BE doesn't see mapped drives.  it appears it'll only see shares and local drives.  

boy, i don't know.  i'm thinking of workarounds like doing a copy backup of the share on the nas to a drive that BE can see.

You could automate it by creating a batch file with the command to do the copy and then used scheduled tasks to run the batch daily or whatever.

Other than that, its not a windows os and BE can't communicate with it apparently.  

Again, I would contact symantec and the vendor of the nas and findout backup options for it.  
0
 
LVL 3

Author Comment

by:JasonWinn
ID: 20351110
I think you are right Opie. I may just format it to be a full linux distrubtion like Ubuntu and do a remote agent install on that.

Thanks for your help!

Jason
0
 
LVL 12

Expert Comment

by:opie6373
ID: 20351367
you got it
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

947 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now