Delphi 5 integrated debugger gone

I recently installed Delphi 6 for the first time on my PC, which had Delphi 5, 4, 3, and Delphi 1 installed on it.  Delphi 5 has always been a pain in the @!@ when it came to integrated debugging.  Half the time D5 would spit out a message regarding a Borland debug .DLL and would leave the project's EXE stuck in memory, unable to be terminated.  So when I found a copy of Delphi 6 recently, I thought to myself that it's time to give D5 the heave-ho.  But now, with D6 installed, every time I start D6 or D5, I get a message warning me 'You Just in Time Debugger is currently set to 'c:\program files\borland\delphi5\bin\bordbg50.exe' -aeargs %ld %ld'. In order for JIT Debugging feature to work correctly, it needs to be changed to..."

If I answer YES, then I get a variant of this message when I load Delphi 5.  Then when I answer YES when loading D5, I will then get the message the next time I load D6.  And on, and on.  Obviously Delphi can't keep their versions and debugger settings straight and isolated from each other.  Getting fed up with the messages, I ended up 'ticking' the "don't ask me again" option when loading Delphi 5, and I answered "NO" to the prompt about changing the debugger.   Problem is, now, I can't line by line debug in Delphi 5.  When I compile my code in Delphi 5, I no longer get those tiny dots in the left margin of the IDE.  And yes, the "Integrated debugger" check mark is ON in the Debug options menu.

How do I get back my Delphi 5 IDE debugging?

And isn't there a way to have D5 and D6 live together in harmony without going through the silly prompt every time I load each?
SofttechAsked:
Who is Participating?
 
TheRealLokiSenior DeveloperCommented:
Start "RegEdit.exe" and check this section of the registry

HKEY_CURRENT_USER\Software\Borland\Delphi\5.0\Debugging
     DontPromptForJITDebugger
     Integrated Debugging

valid values for these are 1 or 0

Make sure Delphi 5 is not running, try changing these
then restart Delphi 5
You should be able to set it so it asks you to pick a debugger again like it used to do...
Be careful when messing with the registry.. I'm sure you're aware of how bad it would be to change/delete the wrong thing :-)

0
 
MerijnBSr. Software EngineerCommented:
The JIT debugger has nothing to do with the integrated debugger in Delphi.
JIT is only used when an application crashes, then you can press a 'debug' button, and the executable is 'loaded' in to delphi so you can try to debug it, not really usefull.

So your problem has another cause, is optimization off?
0
 
SofttechAuthor Commented:
>> is optimization off?

No.  I have the Optimization check mark checked on.
0
 
TheRealLokiSenior DeveloperCommented:
oh, and the actual path to the debugger is stored here :-

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AeDebug
        Debugger
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.