Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

PIX 501 VPN Unable to access internal network

Posted on 2007-11-21
10
293 Views
Last Modified: 2011-04-14
I have a PIX 501 VPN setup and am able to connect to the VPN but not to the internal network.
Below is my configuration file.

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password F5UEMk//eGWA47uK encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname borlandpix
domain-name borland.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 10.101.1.0 255.255.255.248
access-list outside_cryptomap_dyn_20 permit ip any 10.101.1.0 255.255.255.248
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn_pool 10.101.1.1-10.101.1.5
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Borland address-pool vpn_pool
vpngroup Borland idle-time 1800
vpngroup Borland password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group isp request dialout pppoe
vpdn group isp localname xxxxxxxx
vpdn group isp ppp encapsulation pap
vpdn username xxxxxxx.net  password xxxxxxx
dhcpd address 192.168.1.10-192.168.1.20 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username dena password Bbv/hpk/k1rYQnMJ encrypted privilege 2
terminal width 80
Cryptochecksum:01370f18147513273644b0943c78b401
: end
0
Comment
Question by:jlgray48
  • 5
  • 3
  • 2
10 Comments
 
LVL 7

Expert Comment

by:chafer
ID: 20330802
Are you trying to connect from a Comcast network.  I have a number of VPNs that work from elsewhere, but not on Comcast.  I can take the laptops to any other network and they work fine.  Comcast is blocking a number of protocols and not admitting it - althought there have been a number of news reports about it.  Anyway, are you on Comcast?
0
 
LVL 7

Expert Comment

by:chafer
ID: 20330823
I forgot to mention - I have setup a number of PIX VPNs and people on about five of them all lost connectivity the same week.  They were all serviced by Comcast in the same county and no one else lost the ability to browse.  By the wya, they can all still complete the VPN login, but none of them can browse the internal network.  Sure they're not blocking protocols!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20331211
Add this command:


isakmp nat-traversal 20

Open in new window

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 79

Expert Comment

by:lrmoore
ID: 20331214
>ip address inside 192.168.1.1 255.255.255.0
Also, make sure your VPN Client home network is not the same as the inside of the PIX
0
 

Author Comment

by:jlgray48
ID: 20331888
Added both statements still no internal network.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20332019
Try adding this acl. Then post results of "show access-list" while your client is connected. Also make sure your VPN client is set to use UDP transparent nat in the transport tab.

access-list SPLIT_TUNNEL_ACL permit ip 192.168.1.0 255.255.255.0 10.101.1.0 255.255.255.0
vpngroup Borland split-tunnel SPLIT_TUNNEL_ACL

Open in new window

0
 

Author Comment

by:jlgray48
ID: 20332027
lrmoore,

I added the following to my config and I can now ping and access by ip but wins is not resolving to host names.

outside router 0.0.0.0 0.0.0.0 (outside interface ip) 255

Thanks,

jg
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20333936
That route statement makes no sense.  You never add a route to your own interface ip.
Add the wins-server config to the vpn configuration.

vpngroup Borland wins-server 192.168.1.x
0
 

Author Comment

by:jlgray48
ID: 20335156
It seems odd to me as well but I wonder if the reason I have to have that is because I have a bridged dsl modem between the pix and the outside. Is there a security issue with having it setup that way?

I've taken it out and I can't access the internal network. When I add it back it starts working again.

Any ideas?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 20336833
It shouldn't be a security issue, so if it works, as bizzar as it is, leave it as is.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Some of you may have heard that SonicWALL has finally released an app for iOS devices giving us long awaited connectivity for our iPhone's, iPod's, and iPad's. This guide is just a quick rundown on how to get up and running quickly using the app. …
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question