Solved

How I Stop the FlashPlayer from Prompting the User for the Debugger Version of the Player?

Posted on 2007-11-21
12
4,440 Views
Last Modified: 2010-04-21
When my Flash widget/application first loads into the page, an alert pop-up appears into the page asking the following:

"Where is the debugger or host application running?"

It then offers the user the chance to select localhost or to enter the IP address of their machine.  The message doesn't disappear until the user selects 'OK' or 'CANCEL'.  After the 'cancel' is chosen, no other errors appear...  Of course, this alert never shows up when I run the widget on my laptop, where it was created.  There are no errors on the laptop or on the network where it is currently deployed.

For the points: What is causing this alert to show up (on the network) and how do I turn it off?  

I don't want the user to be prompted for the debugger version of the player.  Is this a publishing setting (I'm using Flex Builder)?  Is there some undetected error causing this?

If you need code, let me know.
0
Comment
Question by:JaeWebb
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 23

Expert Comment

by:Siva Prasanna Kumar
Comment Utility
Check out the discussion here

http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?catid=581&threadid=1242505

When you were compiling the Flex application by any chance did you set -debug flag true ??? Thats when it tries to run the Flex app in debug mode.
0
 

Author Comment

by:JaeWebb
Comment Utility
When I click the link you supplied I get a "category not found" error.  Could you post some of that dialog here?  Thanks.
0
 
LVL 23

Assisted Solution

by:Siva Prasanna Kumar
Siva Prasanna Kumar earned 150 total points
Comment Utility
JaeWeb Even now I tryed clicking that link its working :) any way here are the complete details.

 This question was answered by KEY_NYC, on Sunday, March 4, 2007 9:13 PM
Answer

First, I've seen adobe suggest that you remove/uninstall all earlier flash player installations. I noticed multiple installs hanging around after all of my re-installing different versions, one of which gave me a bit of a hassle, but after removing an older player and an incorrect debug version I re-booted, went back in and uninstalled the stubborn player just fine. re-booted again, then installed the lastest debug version at.. http://www.adobe.com/support/flashplayer/downloads.html
But for me, the ultimate hurdle was configuring my firewall. A step I stumbled across during a re-installation of Flex Builder after I'd rolled my system back.
I'm more of an actionscript designer than I am a developer so I'm learning along the way but from what I can gather, when I was being asked "where is the debugger or host application running?" ,It was asking because I had disabled the connection by blocking it with Nortons. All parts were in place, just mis-configured.
I believe that I was blocking the necessary connection from my local host to my player/IE7.
Since re-installing and choosing to allow connections I've been fine.

Hope that helps.
KEY_NYC

User is offline
Junior Member Posts:       20
Joined:       09/21/2006
      

02/13/2007 02:27:10 PM

Reply  | Quote  | Top  | Bottom

When debugging I am asked, "where is the debugger or host application running?"
I select Local Host, as I am not networked with another machine.
i get the error message, "A connection to the debugger or profiler could not be established by Adobe Flash Player 9"

I've tried uninstalling and installing the latest debug player versions.

What next?
Print this message
jpwrunyan

User is offline
View Profile
Junior Member Posts:       272
Joined:       10/04/2004
      

02/21/2007 10:27:14 PM

Reply  | Quote  | Top  | Bottom

I have the same issue. Can you describe what you are doing to cause this message to appear?
After I did 2 things I started getting the same message:
1) I installed the new Flex SDK
2) I imported a FlexLibrary project into my normal project and set the link type to "RSL" (the default is "Merged into code")

to get around the problem I set the link type of my imported project back to "Merged into code" and now I don't get that annoying (and apparently faulty) prompt. The problem is, there are several applications in the project I am developing so not being able to set the imported project as RSL is going to be a major drawback (each Application .swf file is going to contain identical redundant component class information).

I hope this helps. If your situation is not as that described above, please provide details as to what you are doing/how your project is set up/being compiled/etc.
Print this message
jpwrunyan

User is offline
View Profile
Junior Member Posts:       272
Joined:       10/04/2004
      

02/27/2007 09:02:34 PM

Reply  | Quote  | Top  | Bottom

I think I made a little more headway on this. When you configure a project to be imported as an RSL you need to set the path to the .swf that is acting as an RSL. Now how you correctly set this is beyond me. I am running it locally and it wants to know if the debugger is on local host or another URL.
Print this message
KEY_NYC

User is offline
Junior Member Posts:       20
Joined:       09/21/2006
      

03/01/2007 09:30:53 AM

Reply  | Quote  | Top  | Bottom

My issue turned out to be firewall configuration. Specifically Norton's Internet Security. When originally setting up Flex, I'd been prompted to allow for a jre. or jav. connection? (I can't recall). I was originally opting for automatic configuration or something other than "always allow connections", which did the trick.

Good Luck.
Print this message
Harry240

User is offline
View Profile
Junior Member Posts:       3
Joined:       05/07/2002
      

03/02/2007 06:11:21 PM

Reply  | Quote  | Top  | Bottom

To KEY_NYC...
Can you be any more specific to the solution. I still can't get the de-bug version of Flash9 to install over or instead of Flash9 (non-debug). Thus, no trace for me when running or debugging apps.
Print this message
KEY_NYC

User is offline
Junior Member Posts:       20
Joined:       09/21/2006
AnswerAnswer       

03/04/2007 09:04:28 PM

Reply  | Quote  | Top  | Bottom

First, I've seen adobe suggest that you remove/uninstall all earlier flash player installations. I noticed multiple installs hanging around after all of my re-installing different versions, one of which gave me a bit of a hassle, but after removing an older player and an incorrect debug version I re-booted, went back in and uninstalled the stubborn player just fine. re-booted again, then installed the lastest debug version at.. http://www.adobe.com/support/flashplayer/downloads.html
But for me, the ultimate hurdle was configuring my firewall. A step I stumbled across during a re-installation of Flex Builder after I'd rolled my system back.
I'm more of an actionscript designer than I am a developer so I'm learning along the way but from what I can gather, when I was being asked "where is the debugger or host application running?" ,It was asking because I had disabled the connection by blocking it with Nortons. All parts were in place, just mis-configured.
I believe that I was blocking the necessary connection from my local host to my player/IE7.
Since re-installing and choosing to allow connections I've been fine.

Hope that helps.

Edited: 03/04/2007 at 09:12:58 PM by KEY_NYC
Print this message
chas_mast

User is offline
Junior Member Posts:       4
Joined:       02/15/2007
      

03/29/2007 06:03:27 AM

Reply  | Quote  | Top  | Bottom

Hey guys, heads up on this. You may get the "where is the debugger or host application running?" prompt if you are including flash 8 swfs in your flex app, and you've chosen to "compress movie" in your publish settings. Don't know if this is a bug or by design but it's certainly happening, so just unclick and it should work.
Print this message
chas_mast

User is offline
Junior Member Posts:       4
Joined:       02/15/2007
      

03/29/2007 06:18:20 AM

Reply  | Quote  | Top  | Bottom

whoops, my bad on the above post, it was actually a .swd (flash debugging) file that had been published from flash 8 that was causing the debugger prompt to appear. Make sure you don't have any .swd's in your flash directory...compression doesn't have anything to do with it.
0
 
LVL 19

Expert Comment

by:Gary Benade
Comment Utility
Flex compiles two different versions of the swf in the bin(default) folder of your project, one debug version that is larger and one meant for release, are you sure that you're not publishing the debug version by mistake?
0
 

Author Comment

by:JaeWebb
Comment Utility
No solution yet...

shivaspk -- The only similarity I see between my project and the post you pasted for me is that we are both using the new Flex SDK, assuming they are referring to Flex 3; this may be wrong since their post began in 02/07...  I'm not using a FlexLibrary and I know nothing about 'RSL' so I doubt it has anything to do with my widget project...  BTW, I don't get the debugger prompt on my laptop, where my widget was created, only on the network where it needs to be hosted.

hobbit72 -- I'm using Flex Builder 3.  The FB3 bin folder includes two SWF files.  The first is the project SWF (same name as the project; meant for deployment) and the second is the 'playerProductInstall.swf' file.  There are no other SWF files in the project (ActionScript 3.0 project).  None of the folders in FB3 projects include a debug SWF like FB2 does.  



0
 
LVL 34

Expert Comment

by:Aneesh Chopra
Comment Utility
Try this:

You might have .SWD file with your .SWF file in same folder.
Just remove .swd file from the folder where .swf file, and prompt for debugging version should not appear again.

-------------------
Aneesh Chopra
-------------------
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:JaeWebb
Comment Utility
aneeshchopra - I do not have a .SWD file anywhere in my project.  

I have another project where I'm experiencing the same problem (player is prompting user for debug version).  This project is accessible to the public (even though it is in the pre-demo stage of development).  I'm including a link so you all can visualize the error.

http://pdfserver.amlaw.com/Production/WebApp/view/pages/APTI/myaccountprofiledemo.html

Since this project is producing the same debug prompt, I'll describe its directory structure (which is similar to the structure of the widget project I described in the original question).  Please note that the page referenced in the link above contains the object tag that points to the target SWF, which exists in project folder described below (lines ending with '/' are folders):
-----------------------------------------------------------------------
controller/
history/
model/
view/
AC_OETags.js
playerProductInstall.swf
ProfileRegForm.swf
-----------------------------------------------------------------------

Any idea why this is happening?
0
 
LVL 34

Expert Comment

by:Aneesh Chopra
Comment Utility
It may be a issue caused by firewall settings

please review the following thread clearfully. it may help:
http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?catid=581&threadid=1242505

0
 
LVL 34

Expert Comment

by:Aneesh Chopra
Comment Utility
Flex Builder 3 also created a debug version SWF in bin folder.

I suggest you to recompile the project and update the SWF on server once again
0
 
LVL 2

Accepted Solution

by:
driscolltm earned 350 total points
Comment Utility
your issue might not be caused by anything you're doing at all. this problem is commonly caused by a known bug in certain releases of the debug player and if you're compiling via the flash IDE (CS3) and loading external swfs (so that flash thinks they are to be used as RSL) there is no way to avoid this other than updating your flash debug player to a later version. I'm not sure exactly which version fixed this but you're always best to go with the latest available.. i believe its up to 9,0,115,0 now. check which version of the flash debug player you are using here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19245&sliceId=1    
flex shipped with version 9,0,28,0 which had this bug in it so if this is the version you're using UPDATE IT.
you can find the latest versions (and pretty much any other version you want) in the player archives:
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14266
0
 

Author Comment

by:JaeWebb
Comment Utility
Update on this issue:

I figured out that this issue is not related to the network.  I visited the application where it was hosted on the network from my laptop and I did not see the debugger prompt.  This leads me to believe that the Flash Player installation on my desktop is where the problem lies.  Unfortunately, I don't have administrator rights on this desktop (corporate computer, not mine like the laptop) so I won't be able to verify my suspicion until the IT department does a player update for me.  

Thanks, Driscolltm.  It looks like the points are yours.  I'll let you know after the IT department does their thing; it should be soon.
0
 

Author Closing Comment

by:JaeWebb
Comment Utility
After the answers were supplied, it still took me a minute to find the core of the issue inside the paragraphs posted.  Though it wasn't the exact issue detailed in your answer, it did turn out to be a problem with the flashplayer installation on my computer.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Article by: DanRollins
This article describes a JavaScript program that creates a maze made of hexagonal cells.  In Part 2 (http://www.experts-exchange.com/Programming/Languages/Scripting/JavaScript/A_7850-Hex-Maze-Part-2.html), we'll extend the program by adding a depth-…
The task A number given should be formatted for easy reading by separating digits into triads. Format must be made inline via JavaScript, i.e., frameworks / functions are not welcome. So let’s take a number like this “12345678.91¿ and format i…
The goal of the tutorial is to teach the user how to live broadcast using Flash Media Live Encoder and connecting it to YouTube to broadcast. Log into your Youtube account, choose live stream settings, start live stream from Flash Media Live Enc…
The goal of the tutorial is to teach the user how to use the auto adjust feature and what the different options do. When your video is not working right you can choose the auto adjust feature to help choose your settings.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now