Enable a Field in Crystal Reports

We just finished a major upgrade of our accounting/inventory application. We have several custom designed reports that need to have fields that are defined as "string" changed to "number." These reports were designed by a consultant who is no longer available and the software vendor does not give support on custom designed reports. Per the upgrade dox, I need to use Field Explorer to edit the parameter fields on the reports to make these changes. The problem is that when I get to the Edit Parameter dialog, the Type: dropdown control is disabled, grayed out. How do I enable this control so that I can change field type?
gbrookeAsked:
Who is Participating?
 
MIKEConnect With a Mentor Software Solutions ConsultantCommented:
So are these "Fields" the Paramter Fields...OR...are the fields the fields that are used to CREATE the parameter.

If the field in question is a STRING and  you want to convert it to a NUMBER,...then...
Create a formula that changes the field in question.

For example:

//@FORMULA1
tonumber(yourtable.field)

Then use this field as needed.

I hope it helps...

MikeV
0
 
gbrookeAuthor Commented:
They are Parameter Fields. The dox indicated that those are the ones that needed to be changed.
0
 
MIKESoftware Solutions ConsultantCommented:
Right...but the Parameter is create by using a DATABASE field. SO what I'm wondering is what type of data format is the actual FIELD that is used to create the Parameter....?

Maybe you can post the SQL from your report here to let me have a look at it? Go to DATABASE >> VIEW SQL  then cut/paste here...thanks

MIkeV
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
mlmccCommented:
If you have based the parameter on a field then it must be the same type as the field.

I believe if you drop the connection in the parameter edit screen you will be able to change it.  Also ensure you aren't using the parameter in the report in a formula or the select expert.

mlmcc
0
 
gbrookeAuthor Commented:
The Database fields behind the Parameter fields are also STRING fields. I don't know how to drop the connection as mlmcc suggested but from what I can tell the Database field on at least one of the reports in question is being used in a formula. I can't attach the SQL code because Crystal Reports is asking for the sa password and the database it is trying to attach to is the developer's database PEVEYXP where our SQL server is NTPSISQL2. I can attach the .rpt file if that will help. How would I do that?
0
 
MIKESoftware Solutions ConsultantCommented:
Is this a Stand-Alone version of Crystal Reports...or ...are you using an "Enterprise" version like Crystal Reports XI Server....?

You may need to handle this differently if the "paramter" is in the Repository......as compared to the report...

Just curious

MikeV
0
 
gbrookeAuthor Commented:
It is the stand-alone version.
0
 
MIKESoftware Solutions ConsultantCommented:
Ok...so is the parameter a STATIC or a DYNAMIC parameter...?

MikeV
0
 
gbrookeAuthor Commented:
It is a STATIC parameter.
0
 
MIKESoftware Solutions ConsultantCommented:
Ok...so....why do you need to change it in the first place....?

I'm a little confused. IF the field is NOT a STRING data-type....why the need to change it in the parameter...?

A little more information please.

MikeV
0
 
gbrookeAuthor Commented:
MikeV,

I had to turn this over to someone with much more experience with Crystal Reports than I have and, though he had to wrestle with it for awhile, he got it working.

I appreciate your effort and will award you the points.

Thanks again.
0
 
gbrookeAuthor Commented:
MikeV,

I apologize for having to abandon this question but it was simply beyond my skills and we needed to get it working. I wanted to give you the points because you did spend some time on it and you should get something for your effort.

Gregg
0
 
MIKESoftware Solutions ConsultantCommented:
Glad I could be of service..

MikeV
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.