• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2124
  • Last Modified:

Oracle Error: ORA-12514 on local Ubuntu Installation of XE

I am trying a new installation of Oracle XE on an Ubuntu 7.10 Server.  After completing the installation, I attempt to login to SQLPLUS as follows:

sqlplus system@xe

SQL*Plus: Release 10.2.0.1.0 - Production on Wed Nov 21 21:17:37 2007

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

Enter password:
ERROR:
ORA-12514: TNS:listener does not currently know of service requested in connect
descriptor

If I do a tnsping on XE, it comes back as:

tnsping xe

TNS Ping Utility for Linux: Version 10.2.0.1.0 - Production on 21-NOV-2007 21:21:22

Copyright (c) 1997, 2005, Oracle.  All rights reserved.

Used parameter files:


Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = ubuntu-server)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))
OK (10 msec)


What is causing the ORA-12514 when I try to login using SQLPLUS?
0
TotalEnergy
Asked:
TotalEnergy
2 Solutions
 
schwertnerCommented:
For STATIC registration of the Oracle service to the Listener:

Go to the remote 10g installation where the Oracle server resides.

Backup LISTENER.ORA file!!!!!!!

In ...\network\admin open listener.ora

see

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = D:\Ora10g)
      (PROGRAM = extproc)
    )
    (SID_DESC =
      (SID_NAME = test)
      (ORACLE_HOME = D:\Ora10g)
    )
  )

Add the entry
    (SID_DESC =
      (SID_NAME = test)
      (ORACLE_HOME = D:\Ora10g)
    )
with regard to the particular Oracle Home and SID Name.

Restart the listener:
c:>lsnrctl stop
c:>lsnctl start

0
 
AkenathonCommented:
TNSPING proves that you can get to the LISTENER only. The problem is that no DB has registered under that service name with it.

1) Check your service_name db parameter
2) Ensure the DB reaches the listener: If it's not on the default 1521 port of the local host, you've got to tell the DB where the listener is running using the parameter local_listener
3) PMON registers every 60 seconds, but you can alter system register to force it
4) Check doing "lsnrctl services" which services the listener does know of

You'll no doubt troubleshoot the problem with all that, please update the thread :-)
0
 
TotalEnergyAuthor Commented:
I got it to work. I uninstalled oracle-xe and purged all configuration files. I did a fresh install but not before I installed the bc package.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now