?
Solved

Why are Volume Keys disabled Apple Wireless Keyboard?

Posted on 2007-11-22
5
Medium Priority
?
2,819 Views
Last Modified: 2013-11-24
Quite difficult to reproduce is the following behaviour:

if I press the Vol+,Vol- or Muite buttons (located above the numeric keypad), OSx displays the correct overlay window (just like the eject or brigthness adjust windiows), but below the volume bar, I see the disabled/not allowed icon.

Thus, these keys seem to work (at least they generate an event processed by OSx), but I didn't find any way to get them enabled again.

What works fine is the standard menu-sound-control or system settings/audio.

Additional information:
- Appearance:
just a few days ago, unfortunately I don't remember any different behaviour from my side. It happend also some time ago, but I'm not sure how I got it fixed.
- Sound setups
  - Internal soundcard
  - USB headset (mike / speakers), but no change if this is pugged in or not

I don't expect a first hit on this, but would be more than happy to have some advice to dig into this further.

Many thanx in advance,
Volker
0
Comment
Question by:vzkb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 19

Expert Comment

by:pheidius
ID: 20334859
Well, a first hit  try might be to repair permissions then reset  the smc.
 http://docs.info.apple.com/article.html?artnum=303319
0
 
LVL 1

Author Comment

by:vzkb
ID: 20341929
Dear pheidus,

unfortunately, your suggestion didn't work.

Any other ideas?

Kind regards,
Volker
0
 
LVL 19

Accepted Solution

by:
pheidius earned 750 total points
ID: 20370400
Well next reset nvram/pram. After that, try rebuilding the whole OS with disk Warior 4.
0
 
LVL 1

Author Closing Comment

by:vzkb
ID: 31410533
HI Pheidus,

thanx for listening, the reset of PRAM finally helped!

Kind regards,
Volker
NOTE: B comment, because I'm still curious what happened (we just cured the cause:-)
0
 
LVL 53

Expert Comment

by:strung
ID: 20857774
In System Preferences/Keyboard & Mouse/Keyboard, check the box which allows the F1, F2, etc. keys as standard function keys
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Smartwatches: just a fashion accessory or a useful device for all? The Apple Watch (http://www.apple.com/watch/) was launched in April of 2015 and has become a new way for iPhone users to stay connected. Ranging from $349 to $17,000, the Apple Watch…
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question