Solved

Outlook 2007: 'Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.

Posted on 2007-11-22
51
26,037 Views
Last Modified: 2012-11-01
Outlook 2007: 'Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.
users using outlook 2003 can configure out of office without no problem.
We are using exchange 2007.
Using out of office via Webmail works fine.
I try using this command: Set-Mailbox "brk" -ExternalOofOptions External
But it says the commands completed succefully but no settings of gorkana.local/gorkana users and groups/brk have been modifiled.
Gorkana is our domain.

Please help..... What more can i do.
0
Comment
Question by:bkebbay
  • 24
  • 24
  • +2
51 Comments
 
LVL 11

Expert Comment

by:bsharath
ID: 20333735
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20334062
The problem is the operation of AutoDiscover. If that isn't working correctly then many of the Outlook 2007 functions will fail. I would suggest that you read through this blog posting from ATIG to ensure that Autodiscover is working correctly.

http://exchange-genie.blogspot.com/2007/07/autodiscover-ad-attribute.html

Simon.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20338085
The above fix url is actually closed off and not a fix

Anyway I have fixed this on my network by looking at the outlook logs- there were a few reasons
our pcs are on a different domain and this is the main cause because the autodiscover urls do not match- i joined a pc to the domain and it worked fine but this was not an option in the live environment

Firstly yousimply need to be able to resolve an ip address against the server so it doesnt try to access via an external url in our case because this did not match our email domain
example 192.1.100.100      autodiscover.actualmaildomain.co.uki could not use a dns record as it matched our external domain and prevented certain users accessing our web page.

so the second obvious problems were our Proxy was blocking 2 addresses
autodiscover.actualemaildomain.co.uk;and als the fqdn of the 2007 server - ie servername.externaldomainname.co.uk

now it works with a couple of certificate errors but i guess we can add a couple of self signed ones to get around this.
0
 

Author Comment

by:bkebbay
ID: 20359138
Please can you help me how can i do this i have click on the autodiscover in IIS but i can see anything or anywhere to edit domains.

Please please help can you tell me exactly what i should do.

Regards
0
 

Expert Comment

by:eclipselegalsystems
ID: 20359156
please give me an example of your setup and i can try and advise - i did not modify anything on the server side it is simply on the outlook clients
0
 

Author Comment

by:bkebbay
ID: 20359514
we have Outlook 2007.

Our server is grkms1.gorkana.local.

Where can i locate the autodiscover on Outlook.

Please help.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20359591
you have to enable outlook logging and this will show you what the autodiscover service is trying to access.  i do not beleive there is an option in outlook where you modify autodiscover hence the name.  

the log files then live here (vista) or documents and settings for xp/2000
C:\Users\username\Local Settings\Temp\olkdisc.log

Look in there and it will tell you the url it is trying to access and if it is failing or not - let me know what the outcome is and we can take this further.

does your internal domain name match the external url?  if not i presume you are on a seperate windows domain to the exchange server as i am.

I expect that the autodiscover is using your email domain and the actual domain is grkms1.gorkana.local. and if they do not match it will do a dns lookup and fail.  if this is the case adding the failed domain in the outlook log into your host file with the ip address of the exchange server should fix this.
0
 

Author Comment

by:bkebbay
ID: 20359680
Sorry mate,

I am from AS 400 background i have little knowledge of exchange.

I can't find C:\Users\username\Local Settings\Temp\olkdisc.log
What i can see is C:\Documents and Settings\brk\Local Settings\Temp but there is no olkdisc.log files.

How can you see where the internal domain and external domain are.

many thanks.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20360346
Have you enabled logging in outlook 2007 - tools - options -advanced (restart of outlook required)
to be honest you will have to google to see where that log file exists if you cannot find it.

what is your
windows logon domain of the client pc you are using
windows logon domain of the exchange server
external url if any of your owa server -  

maybe wise not to put full details for security reasons
0
 

Author Comment

by:bkebbay
ID: 20364572
Hi Mate,

Thanks for helping me What i don't understand is why out of office is working with Webmail but not with Outlook 2007. Users can configure thier out of office in webmail but not in Outlook 2007.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20364589
Well the Webmail is directly connected to the exchange server and it knows exactly the correct domain to use - ie itself.  outlook 2007 uses the autodiscover feature and i am almost 99% sure that yours is querying the wrong domain.  please note you would not have this issue with earlier versions of outlook.
0
 

Author Comment

by:bkebbay
ID: 20366320
That is very true this works fine with Outlook 2003.

When i click on Server Configuration----Properties
under domain controller server being used by exchange is grkfs1....
                                                                                      and grkdc1 ... ...
Under glocal catalog server i can see
grkfs1....

grkfs1---- is our file server
grkdc1----is one of domain controllers

Our Exchange server is grkms1.

Should i change everythin to grkms1......

Or should i look in IIS and the Autodiscover. I have set this to anonymous.

What and where i should look to change things.

Thanks.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366415
I really need you to enable logging in outlook so i can see what fqdn it is trying to connect to.
http://support.microsoft.com/kb/300479
alternitavely put in any domains you are aware of that are related to your server and add an ip address
here is mine
127.0.0.1       localhost
::1             localhost
192.2.200.35        autodiscover.localpcdomain.co.uk
192.2.200.35                           autodiscover.webdomain.co.uk
bviously change the bit between autodiscover. and .co.uk to what you require

you do not need to do anything on the server
0
 

Author Comment

by:bkebbay
ID: 20366509
Mate can you help me is there anyways i can call you

Thanks.
0
 

Author Comment

by:bkebbay
ID: 20366592
I am using Outlook 2007 it is different

There is no
Click the Advanced Options button
4. Click to select the Enable mail logging (troubleshooting) check box.
5. Click OK to save the setting, and then return to the main Options screen
6. Click OK.
7. Quit and restart Outlook

There is tools--options--others---advanced options but no enable mail logging
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366649
yes thats correct - then the log file will be called something like - olkdisc.log please post those entries and ill look for you.  unfortunately im at work and i can not take calls whilst on "duty"
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366665
sorry - misread that
this is what i did on outlook 2007

tools - options
other
advanced
enable logging

if you do not have this then let me know the exact version of outlook 2007 you are using - but the quickest method is to use the outlooks own help or google it.  once you have it i can help
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366744
here is the correct link to enable logging in Outlook 2007
http://office.microsoft.com/en-us/outlook/HA012304211033.aspx
0
 

Author Comment

by:bkebbay
ID: 20366771
Your right i have done that many thanks what else should i do i have restarted Outlook.
0
 

Author Comment

by:bkebbay
ID: 20366787
I have locate the olkdisc.log  file can you tell me what i should do again
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366806
look for some entries at the bottom they should say the url that the autodiscover is trying to communicate with and it will say failed or success - then post that here but be careful you do not put any sensitive data in
0
 

Author Comment

by:bkebbay
ID: 20366857
unfortunately i can't see anything at the bottom.

But what am getting is this from the olkdisc.log are

Redirect check to http://autodiscover.gorkana.com/autodiscover/autodiscover.xml starting
3572      27550078      11/28/07 16:52:56      Redirect check to http://autodiscover.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80072EE7)
3780      27553125      11/28/07 16:52:59      Attempting URL https://mail.gorkana.com/autodiscover/autodiscover.xml found through SCP
3780      27553125      11/28/07 16:52:59      Autodiscover to https://mail.gorkana.com/autodiscover/autodiscover.xml starting
3780      27553937      11/28/07 16:53:00      Autodiscover request completed with http status code 403
3780      27553953      11/28/07 16:53:00      Autodiscover to https://mail.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80004005)
3780      27553953      11/28/07 16:53:00      Autodiscover to https://gorkana.com/autodiscover/autodiscover.xml starting
3780      27554953      11/28/07 16:53:01      Autodiscover request completed with http status code 502
3780      27554953      11/28/07 16:53:01      Autodiscover to https://gorkana.com/autodiscover/autodiscover.xml FAILED (0x80004005)
3780      27554953      11/28/07 16:53:01      Autodiscover to https://autodiscover.gorkana.com/autodiscover/autodiscover.xml starting
3780      27555437      11/28/07 16:53:01      Autodiscover request completed with http status code 502
3780      27555437      11/28/07 16:53:01      Autodiscover to https://autodiscover.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80004005)
3780      27555453      11/28/07 16:53:01      Local autodiscover for gorkana.com starting
3780      27555453      11/28/07 16:53:01      Local autodiscover for gorkana.com FAILED (0x8004010F)
3780      27555468      11/28/07 16:53:01      Redirect check to http://autodiscover.gorkana.com/autodiscover/autodiscover.xml starting
3780      27555468      11/28/07 16:53:01      Redirect check to http://autodiscover.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80072EE7)
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366888
simply try and add the following to your hosts file with the exchange servers internal address as you can see the outlook is trying to access the server via its external url which in my case and proabably yours is no use
xxx.xxx.xxx.xxx autodiscover.gorkana.com
or
xxx.xxx.xxx.xxx mail.gorkana.com
change xxx.xxx.xxx.xxx for the internal ip address of the exchange server

Ensure you close Outlook and ensure no outlook.exe processes are open before reopening outlook.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20366912
ive just checked mine and its the autodiscover.gorkana.com that needs to be in the hosts file - when the hosts file is done ping autodiscover.gorkana.com and if that replies from a local ip then it should work and prompt with a certificat error when opening outlook
0
 

Author Comment

by:bkebbay
ID: 20366949
Should i add that to the olkdisc.log

example 192.0.0.0 mail.gorkana.com.

Is that what i should do.  What host file should i add to ( olkdisc.log )

Thanks thanks
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Expert Comment

by:eclipselegalsystems
ID: 20366959
no c:\windows\system32\drivers\etc\hosts add it to here
0
 

Author Comment

by:bkebbay
ID: 20366995
So should i do this for all the 130 PC's or is there a simple way of doing this.

Or should i do this on each individual PC or on the Exchange Server.

Should the command start with

#      0.0.0.0     mail.gorkana.com          # source server

Mate, many thanks this is of course not my field but i think i have learnt something new today.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20367026
just on one pc type

the ip and the name
ie
192.168.1.100    autodiscover.gorkana.com
then  try to ping autodiscover.gorkana.com and ensure the reply is correct
if this pings correctly try outlook
if it works either add the entry to dns or yes you will have to put it on all pcs.  lets try just one for now.

i am leaving the office in 10 mins so try this asap if not we will speak tomorrow
0
 

Author Comment

by:bkebbay
ID: 20367047
Our IP for our mail server is as follows



Name:    grkms1.gorkana.local
Addresses:  192.168.0.0

So should i use the following

#     192.168.0.0     mail.gorkana.com          # source server

is this what i should add?

Thanks
0
 

Expert Comment

by:eclipselegalsystems
ID: 20367058
thats a subnet not an ip

simply ping grkms1.gorkana.local
this will return 192.168.0.?

then put the correct ip in the hosts file

192.168.0.?????     autodiscover.gorkana.com
0
 

Expert Comment

by:eclipselegalsystems
ID: 20367095
ill pick this up when i get home if you like - give me until 19:00 British Time and ill give you 30 mins
0
 

Author Comment

by:bkebbay
ID: 20367119
I know for security reasons i decided not to start it there.

However, should i put it on the exchange sever on on my computer in the file
c:\windows\system32\drivers\etc\hosts

Thanks
0
 

Author Comment

by:bkebbay
ID: 20367154
Have add the ip as you started and

192.168.0.?????     autodiscover.gorkana.com

Restart Outlook

ipconfig/Flushdns but it simply does not work.

Hope hearing from you.

07940744100
0
 

Expert Comment

by:eclipselegalsystems
ID: 20367440
ah i see - lets say for arguments sake the ip is 192.168.0.1
then the hosts file reads this - (this is on the pc with outlook not the server)
192.168.0.1 autodiscover.gorkana.com

what happens when you ping autodiscover.gorkana.com
0
 

Expert Comment

by:eclipselegalsystems
ID: 20367465
as you can see from this log file with this entry Autodiscover to
https://autodiscover.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80004005)

we have to fool the system to think that autodiscover.gorkana.com is a local IP and also ensure if you are using a proxy server that this is in the exception list.
0
 

Author Comment

by:bkebbay
ID: 20372486
when i ping ping autodiscover.gorkana.com i got reply which means is perfect.So how can we do that. It looks like you have alot IIS knowledge. You from a development background.

I am sick and tired with this Out of Office issue: When does it works fine for Webmail and not for Outlook 2007.

Please help
0
 

Expert Comment

by:eclipselegalsystems
ID: 20372491
do you use a proxy server for your internet access on the pc that can successfully ping autodiscover.gorkana.com and replies from 192.168.0....
0
 

Author Comment

by:bkebbay
ID: 20372827
Sure our mails and firewall setup goes through a third party.

Hence no proxy from our side
0
 

Expert Comment

by:eclipselegalsystems
ID: 20372895
what happens when you try and access https://autodiscover.gorkana.com
via internet explorer
you should now get a certificate error and then when you click ok you will get an iis message "under construcition" if not you have the wrong domain
what is the pc logon domain is it gorkana.com?
0
 

Author Comment

by:bkebbay
ID: 20372956
the domain is gorkana.

How can the domain be wrong when am login there and everyone else.

when i try to https://autodiscover.gorkana.com i got this below

Unable to display page  
 
It has not been possible to display the page you requested for the following reason:
502: Bad Gateway. The website you requested could not be found. Please check the website address you have entered and retry the request.
Contact your system administrator if you continue to experience difficulties.  
0
 

Expert Comment

by:eclipselegalsystems
ID: 20372972
my earlier post stated that this generally happens if you have 2 different windows domains one for the clients and one for the exchange 2007 server.

you have a big problem now - if you ping
https://autodiscover.gorkana.com
and it returns reply from 192.168.0.? whatever then you need to get the certificate error from the ie browser.  if not then you need to let me know what connection settings ie has as it is most likely that this is now blocking the next step.

please confirm teh internal ip - this is not a security issue i would just like to confirm we are on the correct track.
0
 

Author Comment

by:bkebbay
ID: 20373045
I have tried doing this

New-AutoDiscoverVirtualDirectory -websitename "Default Web Site" -WindowsAuthentication $true -DigestAuthentication $true

Remove-AutoDiscoverVirtualDirectory -Identity "grkms1\Autodiscover(Default Web Site)"

But i got the following error
For  deleting the virtual directory i got this

[PS] C:\Documents and Settings\Administrator.GORKANA\Desktop>New-AutoDiscoverVir
tualDirectory -websitename "Default Web Site" -WindowsAuthentication $true -Dige
stAuthentication $true
New-AutodiscoverVirtualDirectory : The virtual directory 'Autodiscover' already
 exists under 'grkms1.gorkana.local/Default Web Site'.
Parameter name: VirtualDirectoryName
At line:1 char:33
+ New-AutoDiscoverVirtualDirectory  <<<< -websitename "Default Web Site" -Windo
wsAuthentication $true -DigestAuthentication $true
[PS] C:\Documents and Settings\Administrator.GORKANA\Desktop>Remove-AutoDiscover
VirtualDirectory -Identity "grkms1\Autodiscover(Default Web Site)"
Remove-AutodiscoverVirtualDirectory : The operation could not be performed beca
use object 'grkms1\Autodiscover(Default Web Site)' could not be found on domain
 controller 'GRKDC1.gorkana.local'.
At line:1 char:36
+ Remove-AutoDiscoverVirtualDirectory  <<<< -Identity "grkms1\Autodiscover(Defa
ult Web Site)"
[PS] C:\Documents and Settings\Administrator.GORKANA\Desktop>




For creating a new one i got this error

         Welcome to the Exchange Management Shell!

New-AutodiscoverVirtualDirectory : The virtual directory 'Autodiscover' already
 exists under 'grkms1.gorkana.local/Default Web Site'.
Parameter name: VirtualDirectoryName
At line:1 char:33
+ New-AutoDiscoverVirtualDirectory  <<<< -websitename "Default Web Site" -Windo
wsAuthentication $true -DigestAuthentication $true
[PS] C:\Documents and Settings\Administrator.GORKANA\Desktop>
0
 

Expert Comment

by:eclipselegalsystems
ID: 20373430
Unless you previously broke the web site when using the shell i do not beleive you need to do anything on your server.  I am sure the problem currecnty lies with the client and its ie settings.  please can you confirm the name you can ping and the resulting ip and then if you ping the fqdn of the exchange server is that the same internal ip?

also please send me you iexplore network settings.
0
 

Author Comment

by:bkebbay
ID: 20375150
no it has nothing to do with the client, IP address or IE settings.

This is affect about 40 users using outlook 2007.

Does using 2003 are not affected.
0
 

Expert Comment

by:eclipselegalsystems
ID: 20375195
are any outlook 2007 users not effected?
2003 will never be effected by this as the autoreply function is the original rubbish one.
unfortunately i can not help you further if you are sure it is server related.

if you have some 2007 machines that work then i am baffled - if you dont i am pretty sure it is client releated as you are having the exact issues i had before i fixed it.
0
 

Author Comment

by:bkebbay
ID: 20381086
Trust me am not the only one affected by this everyone using outlook 2007 are affect those using outlook 2003 are not affected. So am wondering how can it be client related. It is a server related issue i think there is some problem with our Autodiscover settings in IIS.

Do you know the command to delete and create Autodiscover using exchange shell.

Thanks alot
0
 

Expert Comment

by:eclipselegalsystems
ID: 20381202
yes i aggree fully only our outlook 2007 clients had this issue and the problem was not a server issues and not a client issue persay but it is generally because of the domains not matching - do your email domains and windows domains actually match - and are the pcs joined to the same domain as the server - if not it is exactly the problem i had if not you may well try playing with the shell but out of the box it works.  if you are on a seperate domain a quick test to check the server is ok is to simply join an outlook 2007 pc to the exchange server domain
0
 

Author Comment

by:bkebbay
ID: 20381509
our domain is gorkana.com
our outlook is on the same domain.
sever name grkms1 gorkana.local.
I think the autodiscover is corrupt i have looked at view articles and what they are suggesting is to delete and create a new one.

Do you have the cmds to do that?
0
 
LVL 22

Expert Comment

by:ATIG
ID: 20396569
Redirect check to http://autodiscover.gorkana.com/autodiscover/autodiscover.xml FAILED (0x80072EE7)
I did an nslookup on this and there is no such record&..

Attempting URL https://mail.gorkana.com/autodiscover/autodiscover.xml found through SCP--
This is saying it was found via the set-clientaccessserver

there will be some other checks but I will skip them for now....

Question 1: what is the cert he has on the CAS for OL Anywhere?
What is set on the virtuals directories

Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl
What is the default email address of the users?  @gorkana.com?

When OL tries to connect to the autodiscover service it will first chec for Autodiscover.gorkana.com this should point to your CAS server which would need a matching cert else you will get a cert mismatch

If that fails and the client is domin joined it will look up the SCP in AD which can be found with the get-clientaccesserver commandlet
Which would appear why the domain joined client worked since this was set

also my blog should be accessible and walk you through all the configuration for this...
http://exchange-genie.blogspot.com/2007/07/autodiscover-ad-attribute.html

0
 

Accepted Solution

by:
bkebbay earned 0 total points
ID: 20694155
I got the solution finally.

If you are expriencing certificate error or out of office do the following: do the following

http://support.microsoft.com/kb/940726/

Set-ClientAccessServer -Identity GRKMS1 -AutodiscoverServiceInternalUri https://mail.gorkana.com/autodiscover/autodiscover.xml

·         Set-WebServicesVirtualDirectory -Identity "GRKMS1\EWS (Default Web Site)" -InternalUrl https://mail.gorkana.com /ews/exchange.asmx

·         Set-OABVirtualDirectory -Identity "GRKMS1\oab (Default Web Site)" -InternalUrl https://mail.gorkana.com /oab

·         Set-UMVirtualDirectory -Identity GRKMS1\unifiedmessaging (Default Web Site)" -InternalUrl https://mail.gorkana.com /unifiedmessaging/service.asmx

GRKMS = Server
mail.gorkana.com = our outlook mail address.
0
 

Author Comment

by:bkebbay
ID: 22923690
The above is the right way of doing it.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now