• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2795
  • Last Modified:

The Terminal Server has exceeded the maximum number of connections

I have a Windows 2003 Terminal Server with 20 TS Cals installed.

The RAID container on that server became corrupted today. I have all the data backed up.

I have a new Server 2003 which I have setup and configured TS on.

I can login through Remote Desktop with two concurrent sessions.

When I try and login with anymore users, I get the following error:

"The Terminal Server has exceeded the maximum number of connections" - I don't know the previous CAL agreement no.

Is there a way I can get a 120 day grace period to allow the server to issue temporary CAL's?

Can I copy a file from the previous Terminal server that crashed??

Thanks..
0
niallo32
Asked:
niallo32
1 Solution
 
DarylxCommented:
When you configured Terminal Services, did you select "application mode" or "remote administration" mode?  Sounds to me like you're in remote administration mode which only allows 2 connections.
0
 
Cláudio RodriguesFounder and CEOCommented:
Application Mode is for Windows 2000 Server only. There is no such thing on 2003.
Did you add Terminal Server using Control Panel | Add/Remove Programs | Windows Components?
If you do NOT add it there and simply enable Remote Desktop, you will be limited to two users.

Claudio Rodrigues
Microsoft MVP
Windows Server - Terminal Services
0
 
DarylxCommented:
"Application Mode is for Windows 2000 Server only. There is no such thing on 2003."

You learn something new every day :-)  thanks tsmvp.

0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
and235100Commented:
Specify max connections:
http://technet2.microsoft.com/windowsserver/en/library/e9d47093-1335-4091-be05-29c5edebe6451033.mspx?mfr=true
Bear in mind - you need to be licensed to use these.
0
 
Andrew DavisManagerCommented:
TSMVP has covered it quite well, but just in case. Make sure you havnt loaded SBS as this is only 2 users (3 if you include console) and administrators only.

i am sure you have but its worth saying ;)

Cheers
Andy
0
 
niallo32Author Commented:
Thanks for all the help guys. It was a schoolboy error on my part - I'd only enabled Remote Access and not actually installed Terminal Services.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now