?
Solved

Delete infcache.1 file in vista ultimate 64 bit

Posted on 2007-11-22
5
Medium Priority
?
4,070 Views
Last Modified: 2013-11-29
O/S: Windows Vista Ultimate 64-bit OEM.
AMD A2 dual 6000+ processor
4GB DDR2 memory
GeForce 8600GTS Video card.
Vista will not recognize my SanDisc Cruzer micro 4GB flash drive. I want to delte the infcache.1 file and get this message: "you need permission to perform this action. I am logged on as the administrator and the only person that uses this machine. I disable and enable flash drive in device manager. did not help.
0
Comment
Question by:dbegley1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 15

Expert Comment

by:vico1
ID: 20335626
Open a dos prompt as an administrator.
Even that you are logged in as an admin you need to open a command windows as and admin by right clicking an click on "Run as administrator"
Then browse to the folder of the file to be deleted and delete it.
Example:
CD \
CD C:\windows\system32\inf
delete infcache.1
or
You could type explorer from the prompt to browse from a GUI and delete the file.

Good luck!
0
 

Author Comment

by:dbegley1
ID: 20335727
Thanks vico1
Command prompt result: I opened as Administrator
CD C:\windows\system32\inf
The system cannot find the path specified.

Using explorer:
Tried to delete got this message:
You need permission to perform this action.
0
 
LVL 15

Expert Comment

by:vico1
ID: 20335757
Do you know exactly where the file is located?
0
 
LVL 15

Accepted Solution

by:
vico1 earned 200 total points
ID: 20335831
The path that I gave you was an example.
Now follow the step below:
1.- Open a command prompt as an administrator
2.- type the following commands:
     CD \
     CD windows
     cd inf
     takeown /f  infcache.1
     explorer

3.- From windows explorer browse to the folder C:\windows\inf
     Right click on the file infcache.inf then click on properties
     Then click on security tab

4.- Highlight Users(Yourcomputer\users)
     Click on Advance button

5.- Click on permissions tab
     Highlight Users(YourComputer\Users)
     Click on edit Button
     Then highlight Users(YourComputer\Users) and click edit button again.
     Then check The Full Control box

You should be able to rightclick and delete the file.

I suggest that you make a copy of it before you delete it.

Good luck!

vico1
     
0
 

Author Closing Comment

by:dbegley1
ID: 31410586
Unfortunetly, my system will not allow me to install my sandisk u3 cruzer micro 4gb usb device. I was told by someone that if i deleted the infcache.1 file it would accept the device. apparently they were wrong.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
When asking a question in a forum or creating documentation, screenshots are vital tools that can convey a lot more information and save you and your reader a lot of time
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question