Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Unbale to connect to Windows Terminal server 2003

Posted on 2007-11-22
19
Medium Priority
?
389 Views
Last Modified: 2013-11-21
Hi,

I am unable to connect to my Widows 2003 terminal Server.

I am obtaining the following error message:
To logon on this remote computer, you must have Terminal Server User access permissions on this cimputer. By default, members of Remote Desktop Users group have these Permissions. If you are not a member of the Remote Desktop Users group or anothe rgroup that has these permissions, or if the Remote Desktop User group does not have these permissions, you muts be granted these permissions manually.

the terminal license is located on another server.
It tells me that it ois active.
I have it setup per device.
My permission compatibility is set to Full Security
RDP-TCP settings for Permssions are: Remote Desktop Users, which have User access and Guest Access

thanks for your help

0
Comment
Question by:betemtl
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
  • 3
  • +2
19 Comments
 
LVL 25

Expert Comment

by:imitchie
ID: 20336210
on the Windows 2003 server, right click on My Computer, Manage

in the remote tab, add users as you would like
0
 
LVL 18

Expert Comment

by:Andrew Davis
ID: 20336246
As the message from the server says. There is a default security group that is created. you need to go into your users in AD, (Where you set them up) and in "member of" tab add them to the remote desktop users group.

cheers
Andy
0
 
LVL 31

Expert Comment

by:Cláudio Rodrigues
ID: 20336275
You must add your users (or Domain Users) to the Remote Desktop Users group (a local group on the terminal server itself).

Claudio Rodrigues
Microsoft MVP
Windows Server - Terminal Services
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:betemtl
ID: 20336286
hi,

the user is already part of the remote desktop users group.

sorry, i forgot to mention that
0
 
LVL 18

Expert Comment

by:Andrew Davis
ID: 20336298
OK on the TS go to the properties of "my computer" and ensure that allow remote desktop is ticked.
Also i have heard of a case where the users also had to be given the right to "log on to local machine" although i was sure that this was allready set in the remote desktop group.

Cheers
Andy
0
 

Author Comment

by:betemtl
ID: 20336337
allow remote destop is ticked.

remote desktop users have full access.
0
 
LVL 18

Expert Comment

by:Andrew Davis
ID: 20336345
Can the administrator login via rdp?
does the event log show anything?
0
 
LVL 25

Expert Comment

by:imitchie
ID: 20336362
have you clicked on Select Remote Users and added them from there? that's a shortcut to add them to the Remote Desktop Users group
0
 
LVL 11

Expert Comment

by:dekkar
ID: 20336659
Try and login in remotely as administrator.... If this works... then its a permissions thing... Promote a user to administrator (locally on the server) and see if it then works for them....

If this works, maybe you need to set log on locally or something along those lines to the remote users group.
0
 

Author Comment

by:betemtl
ID: 20336888
administrators work.

Well 3-4 times I was obtaining the same message for my administrator account. I rebooetd the system, and the administrrator accoutn started working.

But, for Remote desktop users, I never got it working on this system.

omitche, were is the shortcut located?
0
 
LVL 25

Expert Comment

by:imitchie
ID: 20336919
I mean right click on My Computer>Properties
Remote tab
there's a button near the bottom "Select Remote Users"
add them from there
0
 
LVL 11

Expert Comment

by:dekkar
ID: 20337081
hmmmmm I had a similar problem but it was a few years ago now....


As a test go into the Administrative settings --> Local Security Policy

Local Policies --> User Rights Assignment

In there, there is a Allow Log on locally, and Through Terminal Services.

Try adding a particular user you are testing into both of these..... see if this works.
0
 
LVL 11

Expert Comment

by:dekkar
ID: 20337088
Sorry... more.... Go into Administrative Tools --> Terminal Services Configuration

Click on Connections and go into the proerties of the RDP

Under Permissions, check that the remote desktop users group is in there.... BUT if this is a domain member, then you will be able to check to see if the DOMAIN\remote desktop users and the SERVER\remote desktop users are in there.... if it is only local... then the domain accounts may not work...

You might want to check this for the above post as well...

0
 
LVL 11

Expert Comment

by:dekkar
ID: 20337093
Finally... if the machine is a Domain Controller..... then it will be setup to not allow anything other than administrators to connect to it....

You can get around these settings by checking the above... Sorry about the million posts... but i keep remembering things..... that I think are related..;)

0
 

Author Comment

by:betemtl
ID: 20337135
thanks for your help. the system is NOT a domain controller.

In the properties of RDP, I have listed the remote desktop users.
In user rights assignment, remote desktop users has permission to log on locally and via terminal server. I also added the user manually.

But, I still cannot logon :(
0
 
LVL 11

Expert Comment

by:dekkar
ID: 20337166
can you logon locally?? as one of the users?
0
 

Author Comment

by:betemtl
ID: 20339846
HI,

I am able to logon with the account locally
0
 
LVL 11

Accepted Solution

by:
dekkar earned 2000 total points
ID: 20346760
hmmmmm reinstall terminal services ;)

0
 

Author Comment

by:betemtl
ID: 20350254
IHI, I tried reinstlling TS as well.

what worked is reinstalling the whole system.

thanks for your help.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After having deployed hundreds of thousands of Terminal Services seats worldwide, I still see all the time people asking me that same old question: "If TS/RDS is that reliable why are you telling me I should reboot it that often? My DC/SQL/Exchange/…
Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question