please help disable touchpad

my finger hits it.  very irritating.  have USB mouse that is werking.  both are werking.
that's the problem.
kayveyAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
TeRReFConnect With a Mentor Commented:
If there is two entries, try this:

killall moused
moused -p /dev/ums0

And see if the touchpad still works as well...
0
 
dlan75Commented:
Hi,
Take a look in your bios to see if there is an option to disable it. Also chek in your hardware settings. Can you give us the exact model of your computer?
0
 
TeRReFCommented:
Become root and type this in a shell:

Xorg -configure

If all went well, there is a file saved in /root called xorg.conf.

Can you show the InputDevice section(s) related to the mouse configuration?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Gary CaseRetiredCommented:
I suspect your real issue isn't disabling the touchpad --> but disabling tap-to-click (which I also find very irritating on touchpad-equipped laptops).

For Linux, you first have to install the appropriate touchpad driver;  then set MaxTapTime=0 in the configuration file.   It's all detailed here:  http://www.linuxforums.org/forum/linux-laptops/21900-how-do-i-disable-tapping-synaptech-mousepad.html

... first, however, just check your system's BIOS (as noted above) and see if you can simply disable the touchpad altogether => that will resolve it without any need for software.

0
 
kayveyAuthor Commented:
fyi i'm always root nowadays.. i'm not scared of messin' up on vi and stuff.. too good at that.. didn't even
bother creating a user yet, i don't think
0
 
kayveyAuthor Commented:
consolectl      kmem            psm0            ttyv8
# Xorg -configure

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.

#
0
 
kayveyAuthor Commented:

# synclient TapButton1=0
synclient: Command not found.
#
0
 
TeRReFCommented:
Press
CTRL + ALT + F2

In that console type:

ps -A | grep X11R6

Take the PID (first number in line) from the line that has
 /usr/X11R6/bin/X etc...

THen type
kill -9 PID (where PID is the number you took from the previous command)

THen try my previous suggestion again...

BTW, did you check the BIOS to see if you can disable the touchpad there?
0
 
kayveyAuthor Commented:
okay.. now i remembered to check the BIOS, there was something called "pointing device" i disabled..
but it didn't werk.
0
 
kayveyAuthor Commented:
when i killed -9 the PID it went blooie  and this screen came up:

http://www.monkeyview.net/id/965/fsck/ubcd/pb220021.vhtml

and when i logged in i got impatient because it seemed like all i had was a blue screen that
was like all dead.  i pressed the ACPI button and i got this ding dong

http://www.monkeyview.net/id/965/fsck/ubcd/pb220076.vhtml
0
 
kayveyAuthor Commented:
0
 
TeRReFCommented:
Try killing X like this:

/usr/local/etc/rc.d/gdm stop

but do it in a proper terminal, so use
CTRL + ALT + F2 to leave X first...
0
 
kayveyAuthor Commented:
point of info:  when i do ctrl-alt-F2 it makes me log in in character mode.  is that normal?
0
 
TeRReFCommented:
Yes, it's one of the available consoles. Once you've done CTRL + ALT + F2, you will have 8 at your disposal by pressing
ALT + F1 ... ALT + F8

0
 
kayveyAuthor Commented:
0
 
kayveyAuthor Commented:
# find / -name Synclient
# find / -name synclient
#

0
 
TeRReFCommented:
You're looking for this:

/usr/ports/x11-servers/synaptics

make install clean

and follow instructions I guess...
0
 
kayveyAuthor Commented:
i think we might have a little progress...

http://www.monkeyview.net/id/965/fsck/pb23000102.vhtml
0
 
kayveyAuthor Commented:
0
 
kayveyAuthor Commented:
0
 
ridCommented:
I think synclient is what you want, if not present see if you can find and install. then you need to adjust a parameter:  MaxTapTime=0 will disable tapping.

To have this work, a line needs to be present in the Xorg.conf in the synaptics section that enables "shared memory", otherwise the synclient command will not work. The line is:
 "option     "SHMConfig"      "on"

restart X and the synclient settings should work. Possibly not if it's an Alps touchpad.
/RID
0
 
kayveyAuthor Commented:
what is the path of "Xorg.conf?"

i am feeling a little uneasy about this syntax:

"option   "SHMConfig"     "on"

there seems to be an excess of spaces, i would feel better about an equal sign being there, and
on top of it all the quotes are not properly parsed.
0
 
TeRReFCommented:
In the config file they're not spaces but tabs, so only 1 between each text piece...

Xorg.conf might be non-existent if you never did the configure thingy I told you about before. Xorg is configuring on the fly aand thus you'll have to create it yourself and copy it to this location:
/etc/X11/xorg.conf
0
 
ridCommented:
/etc/X11/xorg.conf
in my system

There is a part like this, where the last line must be added

Section "Input Device"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option.......
Option.......
.
Option "SHMConfig" "on"

The part is tabbed, for clarity I suppose, but tab doesn't work here; you should see how it looks in your editor, just add the last line to conform with the ones above.

No equal signs in that part.
/RID
0
 
kayveyAuthor Commented:
:q
# cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory
# cat /etc/X11/Xorg.conf
cat: /etc/X11/Xorg.conf: No such file or directory
# ls /etc
0
 
kayveyAuthor Commented:
# ls /etc/X11
#
0
 
ridCommented:
Weird. Non-standard installation? Can you find any file anywhere that is xorg.conf (locate xorg.conf or find xorg.conf)? Run updatedb first (as root).
/RID
0
 
TeRReFCommented:
Read my previous comment again (ID: 20343320)...
0
 
alfadogCommented:
Thinking outside the box . . . or rather "inside the box".
Open the case and unplug the touchpad. Often you can do that by just removing the keyboard. Jut unplug the little ribbon cable and you can plug it back in if you ever want to.
0
 
kayveyAuthor Commented:
# updatedb
zsh: command not found: updatedb
#
# find / -name xorg.conf
#
0
 
kayveyAuthor Commented:
0
 
TeRReFCommented:
Each comment in THIS question has an ID, that's what I was referring to, I'll just copy and paste the comment again...

Xorg.conf might be non-existent if you never did the configure thingy I told you about before. Xorg is configuring on the fly and thus you'll have to create it yourself and copy it to this location:
/etc/X11/xorg.conf
0
 
kayveyAuthor Commented:
copy what? this verbatim:

Section "Input Device"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option.......
Option.......
.
Option "SHMConfig" "on"


?

this syntax makes my stomach hurt.  it doesn't look right to me.  
0
 
TeRReFCommented:
CTRL + ALT + F2

to leave X first. THen

/usr/local/etc/rc.d/gdm stop

Then (as root)

Xorg -configure

This will try to determine the best configuration for X and will put an xorg.conf file in /root
You copy/move  that file to

/etc/X11/xorg.conf

That will be the file you'll need to edit to add

Option "SHMConfig" "on"

in the proper section...
0
 
kayveyAuthor Commented:
otay.  at kinkos now. printed out yer instructions because printing is why i go to kinkos
0
 
ridCommented:
The syntax of this xorg.conf file is like that, if you find it you'll see. The only thing that needs to be added is the; option  "SHMConfig"  "on"   line. You'll find as you edit that the spaces are tabs; just follow the design for the other option lines.
/RID
0
 
kayveyAuthor Commented:
if i would have found it i wouldn't have been balking.  it gives me a stomach ache to start
these things from scratch.

news flash: i bought a new hard drive and now am on a new *@##*ING Vista.  can't figger
out how to fix freeBSD netwerk again.
0
 
kayveyAuthor Commented:
0
 
kayveyAuthor Commented:
Section "InputDevice"
        Identifier "Mouse0"
        Driver "mouse"
        Option  "Protocol" "auto"
        Option  "Device"  "/dev/sysmouse"
        Option "Emulate3Buttons" "on"
        Option "ZAxisMapping" "4 5"
        Option "SHMConfig" "on"
EndSection

0
 
kayveyAuthor Commented:
okay.. i'm gonna reboot now
0
 
kayveyAuthor Commented:
that didn't werk.  howcome yer not telling me manual pages i should be reading?
0
 
kayveyAuthor Commented:
hmm.. maybe this is the culprit?


Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection


can i comment out with #'s ?

i will try that
0
 
kayveyAuthor Commented:
that didn't werk. it doesn't feel like tapping is the problem to me
0
 
kayveyAuthor Commented:
did i already do this?

kv_bsd# cd /usr/ports/x11-servers/synaptics
kv_bsd# make install clean
===>  Vulnerability check disabled, database not found
=> synaptics-0.14.6.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/xorg.
=> Attempting to fetch from http://web.telia.com/~u89404340/touchpad/files/.
synaptics-0.14.6.tar.bz2                      100% of  123 kB  103 kBps
=> X11R6.9.0-src3.tar.gz doesn't seem to exist in /usr/ports/distfiles/xorg.
=> Attempting to fetch from ftp://ftp.gwdg.de/pub/x11/x.org/pub/X11R6.9.0/src/.
X11R6.9.0-src3.tar.gz  
0
 
kayveyAuthor Commented:
       :
/etc/xorg.conf (or /etc/XF86Config) ---------------

===============================================================================
===>   Compressing manual pages for synaptics-0.14.6
===>   Registering installation for synaptics-0.14.6
===>  Cleaning for xorg-server-6.9.0_5
===>  Cleaning for gmake-3.81_1
===>  Cleaning for xorg-libraries-6.9.0
===>  Cleaning for imake-6.9.0
===>  Cleaning for gettext-0.14.5_2
===>  Cleaning for libdrm-2.0.2
===>  Cleaning for freetype2-2.2.1_1
===>  Cleaning for fontconfig-2.3.2_6,1
===>  Cleaning for perl-5.8.8
===>  Cleaning for libtool-1.5.22_2
===>  Cleaning for libiconv-1.9.2_2
===>  Cleaning for pkg-config-0.21
===>  Cleaning for expat-2.0.0_1
===>  Cleaning for synaptics-0.14.6
kv_bsd#
0
 
kayveyAuthor Commented:
ithink i have to fix the tabs or something
0
 
kayveyAuthor Commented:
should there be the right number of tabs to make them line up?  one of them didn't line up.
0
 
kayveyAuthor Commented:
okay now it looks like this with tabs

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection
0
 
kayveyAuthor Commented:
didn't werk
0
 
ridCommented:
I have a man xorg.conf file, but that is Ubuntu Linux, may not be applicable to FreeBSD.

This looks mostly OK:
'Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection'

but the Identifier should be "Synaptics Touchpad", Driver should be "Synaptics". Perhaps your FreeBSD install doesn't find/accept touchpads as anything else than a PS/2 mouse (which they emulate).
/RID
0
 
TeRReFCommented:
Change this line:
        Driver          "mouse"

to
        Driver          "synaptics"

and add this one:
        Option        "TouchpadOff"       "2"
0
 
kayveyAuthor Commented:
kv_bsd# ls /etc/X11
xorg.conf.bad
kv_bsd# cat /etc

kv_bsd# head -30 /etc/X11/xorg.conf.bad
#Section "InputDevice"
        #Identifier     "Synaptics Toucpad"
        #Driver         "Synaptics"
        #Option         "Protocol"              "auto"
        #Option         "Device"                "/dev/sysmouse"
        #Option         "Emulate3Buttons"       "on"
        #Option         "ZAxisMapping"          "4 5"
        #Option         "SHMConfig"             "on"
#EndSection

0
 
kayveyAuthor Commented:
kv_bsd# vi /etc/X11/xorg.conf.bad
0
 
kayveyAuthor Commented:
kv_bsd# head -12 /etc/X11/xorg.conf.bad
Section "InputDevice"
        Identifier      "mouse"
        Driver          "synaptics"
        Option          "TouchpadOff"           "2"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

Section "ServerLayout"
kv_bsd# mv /etc/X11/xorg.conf.bad /etc/X11/xorg.conf
kv_bsd#
0
 
kayveyAuthor Commented:
kv_bsd# shutdown -r now
0
 
kayveyAuthor Commented:
more failures.. if u guys ain't careful, gheist is gonna swoop in and git these here points.
0
 
kayveyAuthor Commented:
http://www.monkeyview.net/id/965/booze/PC130489.vhtml

sorry.. FAILURE

http://www.monkeyview.net/id/965/booze/PC130488.vhtml

that's what happened when i did exactly what TeRReF said..   it should be obvious
from my other recent postings that the same applies to me folloing rid's suggestions.
0
 
kayveyAuthor Commented:
i can't do anything right.  messing up my J shaped curve as well

http://www.monkeyview.net/id/965/booze/PC130497.vhtml
0
 
TeRReFCommented:
You can't just change the identifier and expect it to work. It's there for a reason.
Go back to your working configuration (you did make a backup of xorg.conf right?)

THen go to this section:

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

and replace it with:

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
        Option          "TouchpadOff"       "2"
EndSection
0
 
kayveyAuthor Commented:
we started from scratch, remember? you told me to do a command and it produced a file
called xorg.conf.new and i moved that to /etc/X11/xorg.conf   then i added some stuff to it,
admittedly without properly RTFMing.  sorry.  i still need to grow my comfort but it is imperitive
that i do.  i like to just try things to learn, and with this matter i know i can do this in a safe way.
if i simply delete the file /etc/X11/xorg.conf i have been finding i get X back.
0
 
TeRReFCommented:
Yes, but I told you to make a backup of the generated file right away so you could add stuff to it, but still could go back to the original situation. Read the comments with care...

Anyway, did you do it? Last time when you claimed you did exactly as I told you to, you didn't. you made the identifier mouse instead of Mouse0
0
 
kayveyAuthor Commented:
THERE WAS NEVER ANY FILE TO BACKUP!!!
0
 
TeRReFCommented:
I was talking about the generated xorg.conf.new that was generated by Xorg -configure. You still haven't answered my question...
0
 
kayveyAuthor Commented:
i haven't done yer latest suggestion yet, but i hate to be a person who chases away ppl trying to help him, but it seems to me you didn't read about my situation with care.  of course i am astute enough to feel paranoid about stepping on existing configurations.  in fact, i have posted at least a couple
questions with a term like "nervous" in the title that are exactly about that!
0
 
kayveyAuthor Commented:
should i make another simple question now?  i have to go hand in my timesheet.

i await yer cherished thoughts...
0
 
ridCommented:
Does FreeBSD use another approach here, something like the XF86Config file or just another path?

Also, FreeBSD may not actually recognise a Synaptics touchpad for what it is, but treat it as another PS/2 mouse, in which case you're out of luck....

Not-so-modern Linux distros relied on a thing called tpconfig to set the tap feature. Possibly we're barking up the wrong tree here.
/RID
0
 
kayveyAuthor Commented:
why do i need to make a back up of something i can re-generate?

i guess i haven't  it isn't like we are making gargantuan changes, so it doesn't feel that
important to me.  i can look back over what we have did, and actually, i think the exercise
of doing that is a good thing.  i had to remake my system with this new HD, and i didn't know
how to do it right away.  that is a bad thing.  i need to be better at this.
0
 
kayveyAuthor Commented:
here are two views of the error message i got with yer latest suggstion, TeRReF.

on the Identifier "mouse" thing.. i swear somebody told me to do that.  i was backlogged
trying to do things.  i was thinking the other guy told me that.

on "you didn't do what i told you," i know this seems like a correct thing to say, and it may
be true.  i can't find where i thought the identifier was supposed to be mouse and not
Mouse0.  it made sense to me that there might be two different identifiers because
there are two different mice!  that is the way they appeared under windows when
i solved this problem.. two differnt devices..

but anyway.. we all know puters don't make any mistakes, ppl do.  now i am on
windows because i wanted to show the error message and i wasn't sure if i had my
foto zipper fixed.. oh maybe i did.. whatever.. now for verification i will show another
head -12 of the /etc/X11/xorg.conf file.  i don't know why ppl complain about unix
command line pastes i think they are the greatest things in the werld.  they show you
exactly what to do.  if i made a mistake again, of course suggest something new, but
i just want to say "you didn't do what i told you" reads like i did nothing, which isn't the
case.  a better werding is "what i am seeing in yer data does not match my suggestion."

i'm just saying.  it's sort of irksome to be accused of being such a lame freek i am trying to
get better i don't need the aggrivation.


so u don't have a tizzy fit i will make a backup, but
as i said, none of these xorg.confs have been werth #*@& so far so i don't feel that attached
to them to feel the need for backups.
0
 
kayveyAuthor Commented:
okay.. just to reiterate.. i really feel i saw "Identifier  "mouse"" somewhere, and i feel it definitely wasn't
TeRReF's suggestion.  it's hard to document every single thing you do, and this is like the third iteration
of this xorg.conf file that i am really getting a little tired of it just seems like a good for nothing file doing
nothing for me.. but i am bearing with everyone.. actually.. i think i do remember maybe booting up with
it once.. okay fine.. maybe it did happen and i didn't go ::SNAP:: time for backup.. point taken.. so now
here i am doing some nice unix commands that every freshman in puter science learns (i was that in 1985,
and i know.. i must be a sorry sot, but i hate the green paper icecap melting blitering idiocy so i studied
molecular biology for like a decade and it totally messed up my quantitative abilities or something.. plus
i have never ever tried to run my very own unix until like a few years ago no, and i am sick of the
werld sick of being broke sick of not being able to improve in chess and don't feel werld beating or whatever,
but i am trying to be wiser and more patient so here goes

kv_bsd# ls /etc/X11
xorg.conf.bad   xorg.conf.bak
kv_bsd# diff /etc/X11/xorg.conf.bak /etc/X11/xorg.conf.bad
kv_bsd#

that means those two files are identical, right?  

okay

all i did in the character based freek was get that bad boy pain in my @*#&@ file from the
name "xorg.conf" which makes it active, did a cp command and a mv command so now instead
of one active file in that entire freeking directory i got two identical inactive ones.. and now
here is the head command on one of them to show you what i just did that didn't
freeking werk.

kv_bsd# head -12 /etc/X11/xorg.conf.bak
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "TouchpadOff"           "2"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

Section "ServerLayout"
kv_bsd#


okay.. point of info.. i can think of one thing to do right now.. TeRReF i believe if you scroll up,
you will see that you ::precisely:: suggested a driver "synaptic" that is not capitalized while somebody
else capitalized "Synaptic"  i think a permutation that i may not have tried is the Mouse0 plus the
capitalized Synaptics.. so what the hey.. i will try that now.

/etc/X11/xorg.conf: 154 lines, 5011 characters.
kv_bsd#
0
 
kayveyAuthor Commented:
also.. i am aware that my options happen in a different order than yer suggestion.. it doesn't seem to me
that this should matter, but just so you can't say "i didn't do what you told me to," i will probably try that
as soon as i REcapitalize "synaptics"  

actually.. you can see from the above that i have pasted the terminus of a vi command.. hmm.. perhaps
you are not a vi guy (if so you are cursed and vile!!!  {:D  jk)  also.. umm.. i guess it doesn't really tell
u much..

oh wait.. it DOES tell you SOMETHING.. i just made sure the ACTIVE filename now exists.. so
you DO know that i did THAT right now
0
 
kayveyAuthor Commented:
didn't werk.   i think the same error happened, but here are two more fotos of a bad boot

http://www.monkeyview.net/id/965/fsck/newhd/pc140001.vhtml

kv_bsd# mount -t msdosfs /dev/da0s1 /mnt/pix
kv_bsd# ls /mnt/pix
dcim
kv_bsd# head -12 /etc/X11/xorg.bak /etc/X11/xorg.bad
head: /etc/X11/xorg.bak: No such file or directory
head: /etc/X11/xorg.bad: No such file or directory
kv_bsd# head -12 /etc/X11/xorg.conf.bak /etc/X11/xorg.conf.bad
==> /etc/X11/xorg.conf.bak <==
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "Synaptics"
        Option          "TouchpadOff"           "2"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

Section "ServerLayout"

==> /etc/X11/xorg.conf.bad <==
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "TouchpadOff"           "2"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

Section "ServerLayout"
kv_bsd#


okay.. ::sigh:: now just so you can't complain i will have to reorder the Options
0
 
kayveyAuthor Commented:
kv_bsd# head -12 /etc/X11/xorg.conf
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
        Option          "TouchpadOff"           "2"
EndSection

Section "ServerLayout"
kv_bsd#

kv_bsd# shutdown -r now

0
 
kayveyAuthor Commented:
that was actually mildly interesting.  i feel i was right, order of Options does not matter, but
it did cause a different effect, i think because the first 5 options did not cause an error
while the Touchpad did .. hmm.. is "synaptics" right?

i feel like trying an Hungarian "TouchPadOff" now.  how about them apples?

kv_bsd# ls /etc/X11
xorg.conf.bad   xorg.conf.bak   xorg.conf.bak2
kv_bsd#

kv_bsd# cd /etc/X11
kv_bsd# mv xorg.conf.bak2 xorg.conf
kv_bsd# vi xorg.conf

0
 
kayveyAuthor Commented:
xorg.conf: 154 lines, 5011 characters.
kv_bsd# head -12 xorg.conf
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
        Option          "TouchPadOff"           "2"
EndSection

Section "ServerLayout"
kv_bsd#


almost fergot
http://www.monkeyview.net/id/965/fsck/newhd/pc140003.vhtml

kv_bsd# ls /mnt/pix/dcim/100olymp/
pc140001.jpg    pc140003.jpg    pc140005.jpg
pc140002.jpg    pc140004.jpg    pc140006.jpg
kv_bsd# umount /mnt/pix
kv_bsd# shutdown -r now

0
 
kayveyAuthor Commented:
kv_bsd# pwd
/root
kv_bsd# ls
.ICEauthority           .gnome2_private         .mozilla
.Xauthority             .gstreamer-0.10         .nautilus
.config                 .gstreamer-0.8          .profile
.cshrc                  .gtkrc-1.2-gnome2       .ssh
.dmrc                   .history                .xsession-errors
.gconf                  .k5login                Desktop
.gconfd                 .lesshst                xorg.conf
.gnome                  .login
.gnome2                 .metacity
kv_bsd#
0
 
kayveyAuthor Commented:
rid:
/etc/X11/xorg.conf
in my system

There is a part like this, where the last line must be added

Section "Input Device"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option.......
Option.......
.
Option "SHMConfig" "on"

The part is tabbed, for clarity I suppose, but tab doesn't work here; you should see how it looks in your editor, just add the last line to conform with the ones above.

No equal signs in that part.
/RID
0
 
kayveyAuthor Commented:
kv_bsd# cd /etc/X11
kv_bsd# ls
xorg.conf.bad   xorg.conf.bak   xorg.conf.bak2
kv_bsd# head -12 xorg.conf.bak2
Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/sysmouse"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

Section "ServerLayout"
        Identifier     "X.org Configured"
kv_bsd#

dang.. i knew it.. i didn't even create user "kayve"  my foto script isn't here.. there's too many fotos
this time.. i did hecka stuff rebooted multiple times its all in my digital camera right now.
0
 
kayveyAuthor Commented:
i am going to *W@#&@ UNCLe bills @*#& NOW
0
 
kayveyAuthor Commented:
okay.  a number of reboots.. nothing werked.  tried a number of permutations

http://www.monkeyview.net/id/965/fsck/newhd/PC140008.vhtml
0
 
kayveyAuthor Commented:
hmm.. this looks interesting.. is this relevant?

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-xdm.html

 Configuring XDM
The XDM configuration directory is located in /usr/local/lib/X11/xdm. In this directory there are several files used to change the behavior and appearance of XDM. Typically these files will be found:

File Description
Xaccess Client authorization ruleset.
Xresources Default X resource values.
Xservers List of remote and local displays to manage.
Xsession Default session script for logins.
Xsetup_* Script to launch applications before the login interface.
xdm-config Global configuration for all displays running on this machine.
xdm-errors Errors generated by the server program.
xdm-pid The process ID of the currently running XDM.
0
 
TeRReFCommented:
XDM is like GDM (Gnome Display Manager), and will do nothing to help you with this problem.
I seem to remember that you already checked the BIOS to see if you could disable it there right? But there was no option present in the BIOS...

There are ways to disable it in the BIOS even though you might not see it among the options. Can you boot into windows and go to a DOS box (start->run and type cmd)

And then type
PS2 ?

What do you see?
0
 
kayveyAuthor Commented:
Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Users\kayve>PS2
'PS2' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\kayve>


0
 
kayveyAuthor Commented:
how about control panel...

bunch of things in the dropdown list..i sort of have no idea

3 new fotos

http://www.monkeyview.net/id/965/fsck/newhd/PC150031.vhtml

hit right arrow

0
 
kayveyAuthor Commented:
49 pictures of updated BIOS clearly deliniated in Puter Pwobwems Album:

http://www.monkeyview.net/id/965/fsck/

click on the "BIOS" close up and you can browse those if you want
0
 
TeRReFCommented:
If you do a

ps -A | grep moused

what do you see?
0
 
kayveyAuthor Commented:
kv_bsd# ps -A | grep moused
  527  ??  Ss     0:02.02 /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid
  718  ??  Is     0:00.01 /usr/sbin/moused -p /dev/psm0 -t auto
kv_bsd#
0
 
kayveyAuthor Commented:
kewl!  unix stuff!  i like it!  it werked
0
 
kayveyAuthor Commented:
i made a new related but differnt question that should be easy at this point:

http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_23026627.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.