Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

ASP.NET, IIS 6: HTTP/1.1 New Application Failed

Posted on 2007-11-22
10
Medium Priority
?
3,031 Views
Last Modified: 2010-04-21
I have a new installation of Server 2003 with IIS 6 running and serving simple static pages successfully. I'd like to get Active Server Pages working so I can teach myself ASP scripting. I added a file called default.asp to C:\Inetpub\wwwroot. The file only contains:

<html>
<body>
<%
Response.Write("<h1>Hello World!</h1>")
%>
</body>
</html>

When I point a browser to this page, all it shows is:  HTTP/1.1 New Application Failed.

Both the ASP.NET Machine Account and the Internet Guest Account have Read & Execute, List, and Read rights for the wwwroot folder. Also, in IIS Manager Web Service Extensions, Active Server Pages, ASP.NET v1.1.4322 and ASP.NET v2.0.50727 are all Allowed.

I'm new at this and have never used IIS before. Any suggestions? By the way, I installed PHP on this server and it seems to be working.

Jim
0
Comment
Question by:JamesPhelan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20339336
Go to iis and check which site is pointing to your C:\Inetpub\wwwroot folder and then check in the Documents tab in website's property and check if Default.asp is added in default content page.
0
 
LVL 7

Expert Comment

by:MHenry
ID: 20340017
If the above didn't work, are you pointing the browser by using:
http://localhost/yourfolder/default.asp

I don't think you can just point directly to the file with asp. I know you can't with .Net but it's been a while since I used asp.

Best,
MH

0
 
LVL 9

Accepted Solution

by:
Bob Stone earned 1500 total points
ID: 20340112
Did you enable ASP in Server roles?

See this article for instructions on how to do so.
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9fc367dd-5830-4ba3-a3c9-f84aa08edffa.mspx?mfr=true 
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 29

Expert Comment

by:rdivilbiss
ID: 20340627
I agree with stone5150...ASP is not enabled by default in IIS 6.x
0
 
LVL 37

Expert Comment

by:samtran0331
ID: 20341641
One thing to keep in mind is that there is a major difference between ASP and ASP.Net.
Since your test page is "default.asp", IIS will see this as a classic "ASP" page, which is enabled in IIS without doing anything special; so I"m not sure stone5150's suggestion applies.

mhenry might be on a closer track....when you say you "point the browser to the page"...in the browser, are you browsing to:
c:\inetpub\wwwroot\default.asp
or are you browsing to:
http://localhost/default.asp
?

it should be the latter.



is this server on a domain? if yes, also check out this article:
http://support.microsoft.com/default.aspx/kb/210842
0
 

Author Comment

by:JamesPhelan
ID: 20341727
Thanks for the suggestions. I'll address them in order (sort of):

I only have one website on the server; it's the Default Website that was installed when I activated IIS, and Default.asp is in the content list in the Documents tab of the site's Properties. It's at the top of the list.

As for MHenry's and samtran0331's comments, are you referring to the difference between just opening the file with a web browser on the server and having the file actually served up by IIS? I'm accessing the file from another machine on my network by entering the IP address of the server into the browser on the other machine, so it's being served up by IIS.

According to the link supplied by stone5150, there are two ways to enable ASP. The first is to do it when you activate the Application Server role. The second is through Add/Remove Windows Components in the Control Panel. I couldn't remember if I had enabled it when I activated the role, but when I looked at the Details of the Application Server in the Windows Components Wizard, ASP.NET was already checked.

It seems like it should work!

0
 

Author Comment

by:JamesPhelan
ID: 20341729
Oops, I left out one thing, the server is not part of a domain.
0
 
LVL 37

Expert Comment

by:samtran0331
ID: 20342993
have you checked the event logs on the server?
0
 

Author Closing Comment

by:JamesPhelan
ID: 31410800
After following the link provided by stone5150, I found another article which suggested that the IIS Application Server role should be installed after the .NET framework is installed. In order to be sure that this was the case, I removed the Application Server role and re-installed it. Now the server succesfully prcoesses and serves both .asp and .aspx pages.

Thanks to everyone for your help.

Jim
0
 

Author Comment

by:JamesPhelan
ID: 20344381
After following the link provided by stone5150, I found another article which suggested that the IIS Application Server role should be installed after the .NET framework is installed. In order to be sure that this was the case, I removed the Application Server role and re-installed it. Now the server succesfully prcoesses and serves both .asp and .aspx pages.

Thanks to everyone for your help.

Jim
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question