Gateway of Last resort

I am trying a basic set-up that I want to look like this:

Internet
 |
ISP router (cisco 870)
 |
ASA 5510
 |
LAN

My ISP has given me a /29 network of public IP addresses, the first address is assigned to the ISP's router. I have assigned the second in the range to the Outside interface of my ASA. I am planning to use the rest of the IPs in a DMZ and for some NATting. The problem is that when I try to specify the default route to be the IP of the ISP's router, I get warned that the route is directly connected, which it is.
But how do I specify my gateway of last resort to use the ISP router?
CurlysafricanAsked:
Who is Participating?
 
CurlysafricanConnect With a Mentor Author Commented:
Restarting the device allowed the next hop to be entered.
I noticed a default route "speciified" on the management interface when issuing a show route.
After the restart I was able to apply the conifg:

ASA(config)# route Outside 0.0.0.0 0.0.0.0 <IP address of router> 1
0
 
mediaonegraphicsCommented:
Question. Why dont you have the ISP's router setup as a bridge and your ASA as the 1st public?
0
 
CurlysafricanAuthor Commented:
My ISP doesn't do bridging on the routers. Part of their policy/strategy.
0
Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

 
mediaonegraphicsCommented:
The ISP's router should be configured as your default gateway:
http://www.cisco.com/warp/public/105/default.html
0
 
CurlysafricanAuthor Commented:
I have tried to specify the ISP's router as my default gateway with no joy. Thanks for the link, but the ASA's CLI works a little different to that of the routers mentioned.

I entered the following:
ASA(config)# route Outside 0.0.0.0 0.0.0.0 <IP address of router> 1

Then I get the following output:
ERROR: Cannot add route, connected route exists.

Even when I try to add the router's external IP, I get this message.
0
 
mediaonegraphicsCommented:
Try using the gateway IP as used in the ISP's router.
0
 
CurlysafricanAuthor Commented:
I get the same result.
ERROR: Cannot add route, connected route exists.
0
 
batry_boyCommented:
Post the current ASA configuration...is it using DHCP for Ethernet0 with the "setroute" option at the end?  If so, the ASA is picking up the default route from the ISP's router.
0
 
batry_boyCommented:
Cool...did that fix your issue?
0
 
CurlysafricanAuthor Commented:
It did resolve the issue that I had and now I can talk out without problem. Thanks for all your input.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.