Solved

link aggregation from cisco 3020 blade switch, through cascaded 3750Gs to Netapp FAS 3020c filers

Posted on 2007-11-23
3
2,960 Views
Last Modified: 2013-11-14
Hi All,

Firstly I must apologise, my knowledge of cisco is extremely lacking so please try to be gentle :) Any help would be MUCH appreciated.

Ive placed a visio of how we would like to configure our switches here,
http://webuser.a4e.co.uk/linkagg.vsd
each black line signifies 2 ethernet cables, i have drawn them as one to avoid cluttering the diagram

I am trying to configure both the cisco 3750s which are cascaded btw and the cisco 3020 blade switches for link aggregation to allow effectively 16 gb between the filer and the blade system (which is hp c class populated with bl460s)
The Blades are connected to the 3750s via two 3020 blade switches, then each 3750 (which are cascaded) is in turn connected to the two netapp filers, where each filer has a vif setup with one ip address assigned to a vif containing 8 ports each that we are looking to aggregate (8 ports to each filer = 16 ports contained within 2 vifs). Hope the diagram makes it clear. The vifs are setup on the netapp filer end so it is mainly how to configure both the ciscos to aggregate the 16 ports from the blade switches and aggregate the 16 ports to the filer.

 

From initial research, on the 3750s, Ive tried to put together a config but its probably way off the mark (sorry)


 
(config)Vlan2

(config)int po 1
(config-if-po 1) switchport access vlan 2
(config-if-po 1)switchport mode trunk
(config-if-po 1)switchport trunk encapsulation dot1q
(config-if-po 1)Switchport trunk allow vlan 2
(config-if-po 1)no shut
 
(config)int range gi 1/0/1-8
(config-if-range)#descrip Bladeconnsw1
(config-if-range)#switchport mode trunk
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#spanning-tree portfast
(config-if-range)#speed auto
(config-if-range)#duplex auto
(config-if-range)#channel-group 1 mode active
(config-if-range)#shut
(config-if-range)#no shut
 
(config)int po 2
(config-if-po 2) switchport access vlan 2
(config-if-po 2)switchport mode trunk
(config-if-po 2)switchport trunk encapsulation dot1q
(config-if-po 2)Switchport trunk allow vlan 2
(config-if-po 2)no shut


(config)int range gi 2/0/1-8
(config-if-range)#descrip Bladeconnsw2
(config-if-range)#switchport mode trunk
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#spanning-tree portfast
(config-if-range)#speed auto
(config-if-range)#duplex auto
(config-if-range)#channel-group 2 mode active
(config-if-range)#shut
(config-if-range)#no shut



(config)int po 3
(config-if-po 3) switchport access vlan 2
(config-if-po 3)switchport mode trunk
(config-if-po 3)switchport trunk encapsulation dot1q
(config-if-po 3)Switchport trunk allow vlan 2
(config-if-po 3)no shut
 

(config)int range gi 1/0/17-24
(config-if-range)#descrip netapp
(config-if-range)#switchport mode trunk
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#spanning-tree portfast
(config-if-range)#speed auto
(config-if-range)#duplex auto
(config-if-range)#channel-group 3 mode active
(config-if-range)#shut
(config-if-range)#no shut

(config)int po 4
(config-if-po 4) switchport access vlan 2
(config-if-po 4)switchport mode trunk
(config-if-po 4)switchport trunk encapsulation dot1q
(config-if-po 4)Switchport trunk allow vlan 2
(config-if-po 4)no shut


(config)int range gi 2/0/17-24
(config-if-range)#descrip netapp
(config-if-range)#switchport mode trunk
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#spanning-tree portfast
(config-if-range)#speed auto
(config-if-range)#duplex auto
(config-if-range)#channel-group 4 mode active
(config-if-range)#shut
(config-if-range)#no shut

port-channel load-balance src-dst-ip
 
 
*Note - The vifs are only capable of 802.3ad and need to use lacp
 
And then for the 3020 blade switches, (config on each as)
 

(config)int po 1
(config-if-po 1) switchport access vlan 1
(config-if-po 1)switchport mode trunk
(config-if-po 1)switchport trunk encapsulation dot1q
(config-if-po 1)no shut

(config)int range gi 1/0/17-24
(config-if-range)#descrip 3020agg
(config-if-range)#switchport mode trunk
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#spanning-tree portfast
(config-if-range)#speed auto
(config-if-range)#duplex auto
(config-if-range)#channel-group 1 mode active
(config-if-range)#shut
(config-if-range)#no shut



Any advise, help or general guidance is much appreciated.

Thanks,
0
Comment
Question by:A4eIT
  • 2
3 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 20338762
Your config looks pretty good with one exception. I wouldn't run portfast on any ports that connect to other switches. Portfast should only be used on edge ports (ports that connect to end stations).
0
 

Author Comment

by:A4eIT
ID: 20580796
Hi All,

We eventually got a CCIE to produce this on the 3750s

#######################################################################
User Access Verification

Password:
SanSwitch1>en
Password:
SanSwitch1#sh run
Building configuration...

Current configuration : 8212 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SanSwitch1
!
enable secret 5
!
no aaa new-model
switch 1 provision ws-c3750g-24ts
switch 2 provision ws-c3750g-24ts
system mtu routing 1500
vtp domain SanSwitch1
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
cluster enable SanSwitch 0
!
!
!
port-channel load-balance src-dst-ip
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 24576
!
vlan internal allocation policy ascending
!
!
interface Port-channel5
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface Port-channel6
 description EtherChannel-Bundle-Filer-A
 switchport mode access
spanning-tree portfast
 spanning-tree bpduguard enable
!
interface Port-channel10
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
!
interface Port-channel11
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
!
interface GigabitEthernet1/0/1
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/2
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/3
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/4
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
channel-group 10 mode active
!
interface GigabitEthernet1/0/8
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet1/0/9
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet1/0/10
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
 description Link-to-router
 switchport trunk encapsulation dot1q
 switchport mode trunk

interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet1/0/16
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet1/0/17
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet1/0/18
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
channel-group 11 mode active
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
 description EtherChannel-Bundle-Filer-A
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/22
 description EtherChannel-Bundle-Filer-A
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/23
 description EtherChannel-Bundle-Filer-A
 switchport mode access
channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/24
 description EtherChannel-Bundle-Filer-A
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/25
 switchport mode access
!
interface GigabitEthernet1/0/26
 switchport mode access
!
interface GigabitEthernet1/0/27
 switchport mode access
!
interface GigabitEthernet1/0/28
 switchport mode access
!
interface GigabitEthernet2/0/1
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/2
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/3
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/4
 description EtherChannel-Bundle-Filer-B
switchport mode access
 channel-group 5 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet2/0/8
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet2/0/9
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active

interface GigabitEthernet2/0/10
 description Cluster-Link-to-Switch-01-Slot6
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet2/0/16
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active

interface GigabitEthernet2/0/17
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet2/0/18
 description Cluster-Link-to-Switch-02-Slot5
 switchport mode access
 channel-group 11 mode active
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/22
description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/23
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/24
 description EtherChannel-Bundle-Filer-B
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/25
!
interface GigabitEthernet2/0/26

interface GigabitEthernet2/0/27
!
interface GigabitEthernet2/0/28
!
interface Vlan1
 ip address xxx.xxx.xxx.xxx 255.255.255.0
!
interface Vlan10
 no ip address
!
ip classless
ip route xxx.xxx.xxx.xxx 255.255.255.0 xxx.xxx.xxx.xxx
ip route xxx.xxx.xxx.xxx 255.255.255.0 xxx.xxx.xxx.xxx
ip http server
!
!
!
!
control-plane
!
banner login ^CCCC


                    ** I M P O R T A N T   N O T I C E **


###############################################################################
#                                                                             #
#   DO NOT ATTEMPT TO ACCESS THIS DEVICE WITHOUT PERMISSION FROM THE OWNER.   #
#                                                                             #
#           ALL ACTIVITY IS REGULATED, MONITORED AND RECORDED.                #
#                                                                             #
###############################################################################


         
         
         
^C
!
line con 0
 password 7
line vty 0 4
 password 7  login
line vty 5 15
 password 7  login
!
end

###############################################

and this on the 3020s

###############################################

 speed 1000
 spanning-tree portfast
!
interface GigabitEthernet0/14
 speed 1000
 spanning-tree portfast
!
interface GigabitEthernet0/15
 speed 1000
 spanning-tree portfast
!
interface GigabitEthernet0/16
 speed 1000
 spanning-tree portfast
!
interface GigabitEthernet0/17
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/18
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/19
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/20
 description Link-to-3750
switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/21
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/22
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/23
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface GigabitEthernet0/24
 description Link-to-3750
 switchport mode access
 channel-group 10 mode active
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
 password 7
line vty 0 4
 password 7
 login
line vty 5 15
 password 7
 login
!
end

######################################################

Anyone any comments please?
0
 

Author Comment

by:A4eIT
ID: 22375533
no further comments so Im closing and awarding points to donjohnson for taking the time to read, undersatnd and comment - Thanks!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
gns3 with layer 3 switch 6 30
Nortel Baystack 5510-48T Web GUI problems 27 43
Server Room Hardware 5 47
stacking Catalyst 3650 11 10
This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now