Book a room Resource past 180 days

We have Exchange 2007 and Outlook 2007 - I have users who would like to book resources (meeting rooms) for a whole year. However when they try to do so the resource rejects meeting:

Your meeting request was declined.

The end date of this series of recurring meetings is too far in the future. This resource can only be scheduled up to 180 days in advance. The end date must be before 5/20/2008.

Can I change the default property on the resource to a higher value - and if so - how? Link to the powershell cmd would be great!!
LVL 3
tmorrison3Asked:
Who is Participating?
 
mikemsdCommented:
Oops, I'm sorry, I just realized I left off a dash:

Set-MailboxCalendarSettings <mailbox alias> -BookingWindowInDays <Days>
0
 
mikemsdCommented:
Do a:

Get-MailboxCalendarSettings <mailbox alias> |fl

You will see an option labeled

BookingWindowInDays     : 180

Do the following:

Set MailboxCalendarSettings <mailbox alias> -BookingWindowInDays <Days>
0
 
tmorrison3Author Commented:
Im already changing the settings thanks!
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
DataForceDKCommented:
if you want it to stop saying that you booked over the limmet:

Set-MailboxCalendarSettings <mailbox alias> -EnforceSchedulingHorizon  $False

sorry for the spelling
0
 
mick_waters76Commented:
Hi, I was able to successfully change the BookingWindowInDays for mailboxes in out environment, however there are these 24 mailboxes that would not change. I have checked their settings against the one ones that were changed and they look the same. No matter what I did with these 24 mailboxes, the default setting of 180 will not change.
Any help on this will be greatly appreciated.
0
 
mick_waters76Commented:
Hi,
I found a solution to my own problem. Some mailboxes had been NOT logged on to ever, so had to give myself full permission to the mailbox and log on once. After this I was able to successfully change the BookingWindowInDays for these calendars...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.