Solved

Bandwidth issue between 2 Cisco ASA 5505s

Posted on 2007-11-23
2
1,012 Views
Last Modified: 2010-04-21
I am trying to figure out why I am only getting around 58-60kbs on a site-to-site VPN tunnel between 2 Cisco ASA 5505s. Both locations have a business class cable connection (7mb download / 5mb upload). I have tested each site's bandwidth out to the internet and am getting extremely fast downloads. I have lowered the encryption level on both ends and still only getting the speed of a 'dial-up' connection. We are not seeing any errors or dropped packets either. My guess it is a wrong setting that is beyond me. I have also tested the VPN connection to the main site acting as the VPN 'server', if you will, with my laptop from another location (also cable modem) using Cisco's VPN client software. The connection is made just fine, but when I try to copy files from a directory on the server to my desktop I am stuck at the 58-low 60's kbs range. This leads my to think the problem is with the configuration of the one ASA 5505 accepting the VPN connections. Here is the running-config for that device. I can not state enough that any/all assistance is greatly appreciated!

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password smgkRwvHZMtAu5eB encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 24.1xx.xxx.xxx 255.255.255.252
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd smgkRwvHZMtAu5eB encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outside_access_in extended permit tcp any interface outside eq finger
access-list outside_access_in extended permit tcp any interface outside eq 3
access-list outside_access_in extended permit tcp any interface outside eq 1594
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq 1694
access-list outside_access_in extended permit tcp any interface outside eq citrix-ica
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool offsite 192.168.3.1-192.168.3.200 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface finger 192.168.1.5 finger netmask 255.255.255.255
static (inside,outside) tcp interface 1594 192.168.1.2 1594 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.201 www netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.4 https netmask 255.255.255.255
static (inside,outside) tcp interface 1694 192.168.1.2 1694 netmask 255.255.255.255
static (inside,outside) tcp interface citrix-ica 192.168.1.3 citrix-ica netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 24.129.190.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy neifeld internal
group-policy neifeld attributes
 dns-server value 65.32.1.70 65.32.1.80
 vpn-filter none
 vpn-tunnel-protocol IPSec
 client-firewall none
username chris password E5wzPjT.AedJkXBY encrypted privilege 15
username chris attributes
 vpn-group-policy neifeld
username ann1 password gOA29A4Qf2I.o7pZ encrypted privilege 10
http server enable
http 192.168.3.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt connection tcpmss 1200
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec df-bit clear-df inside
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set peer 24.xxx.xxx.xxx
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group neifeld type ipsec-ra
tunnel-group neifeld general-attributes
 address-pool offsite
 default-group-policy neifeld
tunnel-group neifeld ipsec-attributes
 pre-shared-key *
tunnel-group 24.xxx.xxx.xxx type ipsec-l2l
tunnel-group 24.xxx.xxx.xxx ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:59bf98ede11076a9892f40592a36ffee
: end
0
Comment
Question by:cchumbley
2 Comments
 
LVL 4

Accepted Solution

by:
CCIE8122 earned 500 total points
ID: 20339747
Have you verified upload speed on each side?  Broadband connections are almost always the culprit in this type of scenario because the *actual* upload speed often varies significantly from the *advertised* upload speed.

Although I am pretty sure it has nothing to do with the ASA, you can double-check by creating an null IPSec transform set "cry ip tr NULL esp-null esp-none" on each side and use that for the tunnel (on the crypto map command) and see if your speed changes (no need to modify the IKE/ISAKMP transform set as that will have no effect on transport whatsoever).  You should then turn off the VPN altogether and just try and run FTP back and forth by simply allowing access through the firewall on each side and NATting as necesary.

If you see any difference that will tell you if the firewall is causing any of the degradation -- for example, if turning off the encryption but still tunneling through the VPN yields no improvement, but untunneled FTP works great, then you have an issue with the tunnel -- probably an MTU/fragment problem or something.

My guess is you will only see a slight improvement in throughput (if any at all) by turning off encryption and/or turning off  the VPN altogether, but nothing significant.  If that is the case then the broadband connection is almost certainly the culprit.

HTH

kr
0
 

Author Closing Comment

by:cchumbley
ID: 31410673
Thank you very much! We did what you recommended and found the problem to be with the ISP.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now