How do I use GPO to assign Proxy Server settings to a group of computers, not a group of users

On our network some of our computers use a private network and require going through a Proxy Server to reach the Internet.  GPOs can be designed to assign Proxy Server settings on a user basis (User Config|Windows Settings|Internet Explorer Maintenance|Connection), but there is no similar setting under Computer Configuration.  I want proxy settings to be set based on the computer, not the user.
There was an accepted solution which referred to loopback processing, but I don't see how this applies, if there is no relevent setting available in Computer Configuration.
Is there a way of creating an Administrative template under Computer Configuration that will set Proxy Server Settings?
dakota5Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
KCTSCommented:
You need to put the computers in an OU, create the policy and assigin it to the OU and select Loopback - with replace to ensure that the computer settings taje precidence
0
 
dakota5Author Commented:
KCTS:
Thank you for your answer.  I tried this, and it does not work.  There is no computer setting for Proxy Settings, thus there is nothing to take preference over the user settings.  Perhaps I am missing it.
Please specify where exactly Proxy Settings are located in the Computer Settings part of a GPO.

Thanks in advance.
0
 
Alan Huseyin KayahanConnect With a Mentor Commented:
  Hi dakota5
       Proxy Settings do not exist under Computer Configuration. You should modify it under User Configuration. And as far as this GPO is applied to Computer Objects, users which log on to that computer will be effected by the User Configuration part of this GPO. Do not forget to issue policy loopback as KCTS mentioned.

Regards
0
 
dakota5Author Commented:
I've looked at the Microsoft documentation and what KCTS stated is how this should work.  MrHusy is correct in stating that Proxy Server is a User Configuration only, but will be picked up from the User Configuration in the computer group GPO.
This isn't actually working for me yet (the users are not picking up proxy settings computer group GPO), but I believe the error must be mine.  Because we are going through an unrelated time-consuming system upgrade, I don't want to tie up the thread.
Many thanks to both.
0
All Courses

From novice to tech pro — start learning today.