[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1495
  • Last Modified:

Starting Weblogic 8.0 from MyEclipse.

How to make start both Admin and Managed servers of Weblogic 8.1from MyEclipse?
I have configured two servers for my "mocdomain" domain: administration server "admserver" and managed server "mocserver". "admserver" sits on the port 7001 and managed server sits on 7002.
1)
In Preferences\Weblogic\Weblogic 8.x  I set the following:
Execution domain root:     D:\workspace
Execution domain name:  mocdomain
Execution server name:  mocserver
Hostname:Port number:   localhost:7002

Launch:"This server is externally managed" was checked

I got this log message when push start button in MyEclipse:
<Notice> <WebLogicServer> <BEA-000327> <Starting WebLogic Admin Server "myserver" for domain "mydomain">

In administration console I see that admserver is in RUNNING state but mocserver is in UNKNOWN state and deploymnet was deferred.

Then I tried to put in preferences:
2)
Execution domain name:  mocdomain
Execution server name:  admserver
Hostname:Port number:   localhost:7001

Launch:"This server is externally managed" was unchecked


After start logs look like:

<Nov 23, 2007 3:18:48 PM EST> <Notice> <WebLogicServer> <BEA-000331> <Started WebLogic Admin Server "admserver" for domain "mocdomain" running in Development Mode>
<Nov 23, 2007 3:18:48 PM EST> <Notice> <WebLogicServer> <BEA-000355> <Thread "ListenThread.Default" listening on port 7001, ip address *.*>
<Nov 23, 2007 3:18:48 PM EST> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>

In administration console I see again that admserver is in RUNNING state but mocserver is in UNKNOWN state and deploymnet was deferred.

So the question is how to make both servers in RUNNING mode?
0
pvm99
Asked:
pvm99
1 Solution
 
pvm99Author Commented:
I have found solution:

You need configure it as managed server in ME (case 1)  and add in JDK
-Dweblogic.management.server=http://localhost:7001
0
 
EE_AutoDeleterCommented:
pplan,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now