Solved

Asterisk: Installing x100p card

Posted on 2007-11-23
21
360 Views
Last Modified: 2013-11-12
i cant get my x100p card installed. please help
0
Comment
Question by:jonnydollar
  • 11
  • 10
21 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 20342199
What is the problem you are having exactly?

Are you running straight Asterisk, Trixbox or AsteriskNOW?


After fitting the card can you go to a linux prompt and enter the command 'lsmod' and post the output here. I can then see if the correct zaptel module is loaded and then we can progress from there.
0
 

Author Comment

by:jonnydollar
ID: 20342740
its still trixbox. Im tring to setup another machine this time with a x100p. and i have done it successfully before with help from a book called 'trixbox without tears'. but for some reason this isnt working for me. A lspci shows that the hardware is picked up but i seem to have trouble getting the zaptel drivers to interface with it. when i install the card wht procedure should i follow? show i config the zaptel and zapata cofig files first or do i do some other process?

For instance modprobe zaptel  gives me
[root@asterisk1 ~]# modprobe zaptel
FATAL: Module zaptel not found.




or help on trixbox commands you can use from this
command shell type help-trixbox.

[root@asterisk1 ~]# lsmod
Module                  Size  Used by
md5                     4033  1
ipv6                  235137  12
autofs4                24773  0
i2c_dev                11329  0
i2c_core               22081  1 i2c_dev
sunrpc                162725  1
dm_mirror              27825  0
dm_mod                 57557  1 dm_mirror
ohci_hcd               21713  0
ehci_hcd               30917  0
snd_intel8x0           33897  0
snd_ac97_codec         63889  1 snd_intel8x0
snd_pcm_oss            49017  0
snd_mixer_oss          17985  1 snd_pcm_oss
snd_pcm                96841  2 snd_intel8x0,snd_pcm_oss
snd_timer              29893  1 snd_pcm
snd_page_alloc          9673  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         8769  1 snd_intel8x0
snd_rawmidi            26597  1 snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    55461  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9889  1 snd
8139too                25921  0
mii                     5185  1 8139too
floppy                 58481  0
ext3                  116809  2
jbd                    71385  1 ext3
[root@asterisk1 ~]#
0
 
LVL 36

Expert Comment

by:grblades
ID: 20342752
The modprobe output indicates that the zaptel module isnt even installed. A module is a plugin for the kernel but being trixbox it should come with the system.

Can you have a look to see if the module exists. It should be in a directory like :-
/lib/modules/2.4.20-31.9/misc/zaptel.o
The 2.4.20-31.9 will be whatever the version of the kernel you are running is.
0
 

Author Comment

by:jonnydollar
ID: 20342952
In my modules directory is see these directories
2.6.9-34.0.2.EL
2.6.9-34.0.2.ELsmp
kabi-4.0-0

the only place is see mention of zaptel is under 2.6.9-34.0.2.ELsmp/extra
there i see files called zaptel.ko,ztdummy.ko, wcfxo.ko amonst others

this this what we are looking for?

0
 
LVL 36

Expert Comment

by:grblades
ID: 20343018
smp is the multiprocessor version of the kernel. Can you check to see what version of the kernel you are running.
You should really have the files for both kernel versions. Have you changed the kernel yourself?

I dont know if trixbox uses grub as a bootloader but if it does then you can see its configuration in /boot/grub/grub.conf
0
 

Author Comment

by:jonnydollar
ID: 20343119
nah i didnt change any kernel info. below is the grub.conf file. I have reinstalled trixbox three time on this machine with the same result. cud it be the computer itself? its a shuttle x. or perhaps can the zaptel modules be installed manually?

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda2
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
#hiddenmenu
title CentOS-4 i386 (2.6.9-34.0.2.EL)
      root (hd0,0)
      kernel /vmlinuz-2.6.9-34.0.2.EL ro root=LABEL=/1 acpi=off
      initrd /initrd-2.6.9-34.0.2.EL.img

0
 
LVL 36

Expert Comment

by:grblades
ID: 20343198
Can you post the output of the "ls -l /" command.

I am thinking there might be a bug with the trixbox installation routine and it is detecting a single processor and installing a different kernel instead which happens not to have zaptel support included.
If the smp version of the kernel is still there then that can be added to the grub config and made the default and then it should work. Running a multiprocessor kernel on a single processor will work fine but just a fraction slower than a single processor kernel.
0
 
LVL 36

Expert Comment

by:grblades
ID: 20343213
Sorry that should be :-
ls -l /boot/
0
 

Author Comment

by:jonnydollar
ID: 20343953
here is the output u asked for



[root@asterisk1 ~]# ls -l /boot/
total 2837
-rw-r--r--  1 root root   49517 Jul  7  2006 config-2.6.9-34.0.2.EL
drwxr-xr-x  2 root root    1024 Nov 23 18:22 grub
-rw-r--r--  1 root root  587925 Nov 23 18:19 initrd-2.6.9-34.0.2.EL.img
drwx------  2 root root   12288 Nov 23 13:16 lost+found
-rw-r--r--  1 root root    9371 Aug 12  2006 message
-rw-r--r--  1 root root    9371 Aug 12  2006 message.ja
-rw-r--r--  1 root root  733742 Jul  7  2006 System.map-2.6.9-34.0.2.EL
-rw-r--r--  1 root root 1473712 Jul  7  2006 vmlinuz-2.6.9-34.0.2.EL
[root@asterisk1 ~]#
0
 
LVL 36

Expert Comment

by:grblades
ID: 20343978
It looks like the trixbox installer installed the zaptel drivers in the libraries for the smp kernel but installed the normal kernel instead of the smp one.

I think you should report the bug to them.

On the CD that you installed from you should be able to find the smp kernel image. I think if you installed that manually (rpm -i probably) and choose the smp kernel upon bootup afterwards it should work.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:jonnydollar
ID: 20344101
tht sounds complicated. is there any other way to install the module seperatly? if not can to out line what i need to do with the trixbox cd files
0
 
LVL 36

Expert Comment

by:grblades
ID: 20344167
Do you know how to mount a cdrom?

Generally you would need to :-
1) Mount the cdrom. Sometimes this can be as easy as 'mount /mnt/cdrom'.
2) Identify the smp kernel. Its probably be in RPM format so called something like kernel-2.6.9-34.0.2.ELsmp.RPM.
3) Run 'rpm -i kernel-2.6.9-34.0.2.ELsmp.RPM'.
4) Reboot ant make sure you select the smp kernel from the grub boot menu.

Let me know if you need help with any of the steps and I will give you a hand tomorrow.


If you dont feel comfortable doing it then I can connect and do it for you. I dont normally suggest it this way as it helps if you know what to do if you encounter the problem again and it is never advisible telling someone your root password even if you do change it again afterwards.


The other way would be to install the zaptel source but this could be more complex depending on what software is already loaded. Trixbox is not designed for software development so may not have all the packages your require available.
0
 

Author Comment

by:jonnydollar
ID: 20345701
well im only just beginning linux so i might botch things up even more. also i dont mind you connecting to the server running thru the setup and letting me know the steps and commands thereafter
0
 
LVL 36

Expert Comment

by:grblades
ID: 20345731
Ok if you want to do that then email me the IP address and password (address is in my profile) and put the install cd in the drive.
0
 

Author Comment

by:jonnydollar
ID: 20345769
ok i will need to get home in a few hours to hook up the machine again. is and hours and a half from now good? and will u be using ssh?
0
 
LVL 36

Expert Comment

by:grblades
ID: 20345772
That time will be fine.
Yes I will be connecting via ssh directly to the root account. Thats the way I have done it before and it worked fine.

Will it be ok to remotely reboot it after the other kernel is installed?
Or would you rather I let you know so that you can do that yourself?
0
 

Author Comment

by:jonnydollar
ID: 20346271
ok the info is sent please reply once u have completed or for an update
0
 
LVL 36

Accepted Solution

by:
grblades earned 500 total points
ID: 20346303
Ok this is what I have done :-

mount /media/cdrecorder
rpm -i /media/cdrecorder/CentOS/RPMS/kernel-smp-2.6.9-34.0.2.EL.i686.rpm
vi /boot/grub/grub.conf     (change default=1 to default=0 so that the smp kernel is the default)
umount /media/cdrecorder

Now if you reboot the trixbox machine it should default to loading the smp kernel and then it should be able to find the zaptel modules.
If there are any problems with it booting you can choose the 2nd option from the grub boot loader to boot onto the old kernel.
0
 

Author Comment

by:jonnydollar
ID: 20346389
wow thats a winner again. thanks alot. i will keep that setup becuase i suspect i will have to do this often this these computers.

now you think we can conclude that echo issue with the other server?
0
 
LVL 36

Expert Comment

by:grblades
ID: 20346411
If you get the additional exco cancelation code from digium then I can certenly help you install it.
0
 

Author Comment

by:jonnydollar
ID: 20346455
well they have yet to respond to the request. so i dont know how long this takes
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Although VoiceOver IP has been around for a while, internet connections have only recently become fast enough to provide good call quality. Now, VoIP has become a real option for businesses looking at ways to improve their business model. In this ar…
Every year the snow affects people and businesses. According to the Federation of Small Businesses (FSB), in 2009, UK businesses lost an estimated £1.2bn (http://news.bbc.co.uk/1/hi/business/7864804.stm) because of bad weather. This article was c…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now