Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 931
  • Last Modified:

windows mobile to sbs exchange wireless sync

i have a sbs 2003 server.  i owa works fine and my exchang has been working well.

i can't for the life of me figure out why my treo (windows mobile) will not wirelessly sync with my exchange server.

i have gone over countless articles and even set IIS back to default.  

i have a SSL certificate from godaddy.  Even when i sync my device with my pc via it's usb cable, it still will not see the exchange server?

wirelessly, it just keeps saying 'syncronizing folders' and then times out after five minutes.

any suggestions?  help!!!!
0
americanmobile
Asked:
americanmobile
  • 12
  • 3
  • 3
  • +2
1 Solution
 
rolustCommented:
Hi

Follow this if its a windows mobile, if not you´ll need third party for ex, Road Sync.
http://www.microsoft.com/technet/prodtechnol/sbs/2003/deploy/winm5.mspx

Robert Lundqvist
Small Business Specialist
Sweden
0
 
americanmobileAuthor Commented:
i followed that article but i am still getting a invalid certificate error.  and if i disable the certificate, it just eventually times out.

it's got to be something with the certificate.  i have done a hard reset on my phone and set IIS back to defaults several times.  My SSL certificate came from godaddy and it works well both internally and externally with regards to owa.  i installed the certificate on my phone as well but still am getting errors.  there is no firewall blocking anything locally on the machine.  I had a domain name created and it is now pointed at my WAN ip and like I said, owa works well.

must be something to do with godaddy's SSL or my configuration in IIS.  

if my domain name is www.blablabla.com, then in IIS, under default web site, is that where the certificate needs to be installed?  also in company folder?  i can even access www.blablabla.com/oma

what settings in IIS need to be added.  that's the only type of info I can't find.

is there a way I can test to see if OMA is working properly before I try to sync with my phone?





0
 
rolustCommented:
Hi

If you havent changed which cert to use under each site default will be SBS self signed. Install that on your phone and try. (c:\clientapps\cert) or surf to RWW and export it from your IE in DER format.

Robert Lundqvist
Small Business Specialist
Sweden
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
americanmobileAuthor Commented:
i've done that as well several times, but still get the error.  I don't have selfsigned, i have a 3rd party through godaddy.

i followed this article here

www.amset.info/ssl/gd-root-install.asp





0
 
americanmobileAuthor Commented:
for whatever reason though, even after i follow his instructions, my certificate still looks incorrectly installed:

i only have 3 steps...?

www.amset.info/ssl/wmerror.asp

0
 
americanmobileAuthor Commented:
ok.

this may help.  if i go to www.blablabla.com/oma it tells me a system error has occured.  

where should I look for this at?
0
 
americanmobileAuthor Commented:
here is what is in the error log:

An unknown error occurred while processing the current request: Error executing child request for oma.aspx.

 Stack trace:
   at System.Web.HttpServerUtility.ExecuteInternal(String path, TextWriter writer, Boolean preserveForm)
   at System.Web.HttpServerUtility.Transfer(String path, Boolean preserveForm)
   at Microsoft.Exchange.OMA.UserInterface.UserError.OkClick(Object sender, EventArgs e)
   at System.Web.UI.MobileControls.Command.OnClick(EventArgs e)
   at System.Web.UI.MobileControls.Command.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String argument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.MobileControls.MobilePage.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
   at System.Web.UI.Page.ProcessRequestMain()
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

 Inner Error: Exception of type System.Web.HttpUnhandledException was thrown.

 Stack trace:
   at System.Web.UI.Page.HandleError(Exception e)
   at System.Web.UI.Page.ProcessRequestMain()
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at System.Web.HttpServerUtility.ExecuteInternal(String path, TextWriter writer, Boolean preserveForm)

 Inner Error: No ServicesObject found!

 Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Page.InitSessionVars()
   at Microsoft.Exchange.OMA.UserInterface.Page.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.MobileControls.MobilePage.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
dlan75Commented:
Hi,
Put your godaddy certificate aside and try with the link I provided yesterday for your other question in order to see if it works following those instructions with a personnal certificate :
http://www.msexchange.org/tutorials/SSL_Enabling_OWA_2003.html
0
 
americanmobileAuthor Commented:
when you say, 'put aside', just remove the certificate for the default website and company website?
0
 
dlan75Commented:
yes sorry, remove it (but keep it in a secured place as you will reinstall it later on)
0
 
americanmobileAuthor Commented:
you sure I should do that even though my OWA works perfectly, which means my current SSL is working fine?  I don't mind doing it, but the problem seems to be only with Outlook mobile access?
0
 
dlan75Commented:
Ah ok I didn't realised that sorry.
Here is what I could find :
http://www.experts-exchange.com/Hardware/Handhelds_-_PDAs/Palm_OS/Q_22669652.html
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1348045&SiteID=17
http://forums.techarena.in/showthread.php?t=725385
Hope that will help, it is the only thing I can do as I am not expert on palm (I use blackberry)
0
 
americanmobileAuthor Commented:
I just realized i don't have sp2 for exchange on the 2003 sbs.  i have sbs 2003 sp2, but not exchange.  i am going to install that now..
0
 
americanmobileAuthor Commented:
ok.  sp2 is installed but still the same.  has to be the certificate.  is there a way to have them reissued.  if i go to www.mydomain.com/oma i get that error:

-------
A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
-------

OWA works great both internally and externally.  just OMA....

the cert is on the phone as well?

what changes can i make in IIS?

0
 
mediaonegraphicsCommented:
With the godaddy certificates you need to make absolutely sure you have the Publishers trusted root certificate installed. I have found that alot of the less expensive certificates do not have the corresponding root certificate in mobile devices. Even though it says Equifax or Geotrust ro Thawte, their are many different types of certificates issued with these credentials and you must have the corresponding root certificate to make it work.

http://help.godaddy.com/article.php?article_id=1140&topic_id=186&isc=thanks01
0
 
rolustCommented:
Hi

Try to use selfsigned, I always use them if it´s not a public site or the phones require it like Sony Ericson, Nokia etc.  I have both Windows Mobile 5 and 6 and there´s problem with self signed.

Robert Lundqvist
Small Business Specialist
Sweden
0
 
americanmobileAuthor Commented:
i reinstalled the godaddy certificate and don't get a ssl error anymore, only this one now when i type in www.mydomain.com/oma.

Outlook(R) Mobile Access is supported only on Microsoft(R) Exchange Server 2003. Currently your mailbox is stored on an older version of Exchange server. Please contact your system administrator for additional assistance.

i also now get a 8000FFFF error when i try to sync.  microsoft has an article on it i think i am going to try.
0
 
americanmobileAuthor Commented:
i bypassed the ssl certificate on the phone and now it has decided it wants to work.  makes no sense but i am not going to complain.

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It sounds like you didn't install your ssl certificate correctly.  Please see http://sbsurl.com/ssl for instructions on how to do that.

Jeff
TechSoEasy
0
 
americanmobileAuthor Commented:
that's the exact link i used?  i even had godaddy go through it with me.  originally i put the wrong certificate on my phone, then i used a certificate i got from their site.   still not making any sense though.

i have setup plenty at other sites for people, but this one was weird.  i am going to look at it some more tonight and will get back to you.  thanks for the response...
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 12
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now