Solved

DHCP Help

Posted on 2007-11-24
5
1,253 Views
Last Modified: 2008-02-01
I have a Adtran Netvanta 3120 that is doing dhcp to a couple of workstations. When the machines boot up they don't get a ip address. If you run ipconfig /renew it will get a ip. With debugging turned on I get this stuff.
 
2007.11.24 00:03:59 DHCP.SERVER Processing Inform Message (Xid = 27deeb3d) on 192.168.1.0/255.255.255.0 from 00:30:48:75:C2:3D
2007.11.24 00:03:59 DHCP.SERVER Server sent an Ack to the client
2007.11.24 00:04:02 DHCP.SERVER Processing Inform Message (Xid = 27deeb3d) on 192.168.1.0/255.255.255.0 from 00:30:48:75:C2:3D
2007.11.24 00:04:02 DHCP.SERVER Server sent an Ack to the client
 
 
The config is as follows:
!
!
! ADTRAN OS version 16.01.00.E
! Boot ROM version 14.04.00
! Platform: NetVanta 3120, part number 1700600L2
! Serial number LBADTN0740AJ839
!
!
hostname "NetVanta3120"
enable password ....
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway ....
ip routing
!
ip domain-proxy
!
!
no auto-config
!
event-history on
no logging forwarding
logging forwarding priority-level info
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "...."
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
no dot11ap access-point-controller
!
!
!
ip dhcp-server ping packets 2
ip dhcp-server ping timeout 500
ip dhcp-server excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp-server pool "DATA"
  network 192.168.1.0 255.255.255.0
  domain-name "...."
  dns-server 208.67.222.222 208.67.220.220
  netbios-node-type h-node
  default-router 192.168.1.1
!
ip crypto
!
crypto ike policy 100
  initiate main
  respond anymode
  local-id address ....
  peer ....
  attribute 1
    encryption 3des
    hash md5
    authentication pre-share
!
crypto ike remote-id fqdn .... preshared-key ... ike-policy 100 crypto map VPN 10 no-mode-config no-xauth
crypto ike remote-id address .... preshared-key ...ifr3123 ike-policy 100 crypto map VPN 10 no-mode-config no-xauth
!
crypto ipsec transform-set esp-3des-esp-md5-hmac esp-3des esp-md5-hmac
  mode tunnel
!
crypto map VPN 10 ipsec-ike
  description 32nd to HQ
  match address VPN-10-vpn-selectors
  set peer ....
  set transform-set esp-3des-esp-md5-hmac
  ike-policy 100
!
!
!
!
vlan 1
  name "Default"
!
interface eth 0/1
  ip address  ....  255.255.255.248
  access-policy Public
  crypto map VPN
  no shutdown
  no lldp send-and-receive
!
!
interface switchport 0/1
  no shutdown
!
interface switchport 0/2
  no shutdown
!
interface switchport 0/3
  no shutdown
!
interface switchport 0/4
  no shutdown
!
!
!
interface vlan 1
  ip address  192.168.1.1  255.255.255.0
  access-policy Private
  no shutdown
!
interface modem 0/1
  dialin
  no shutdown
!
!
!
!
!
ip access-list standard wizard-ics
  remark Internet Connection Sharing
  permit any
!
!
ip access-list extended remote-access
  permit tcp any  any eq telnet  
  permit icmp any  any     log
  permit tcp any  any eq www  
  permit tcp any  any eq https  
!
ip access-list extended self
  remark Traffic to NetVanta
  permit ip any  any     log
!
ip access-list extended VPN-10-vpn-selectors
  permit ip 192.168.1.0 0.0.0.255  10.0.0.0 0.0.0.255    
!
ip policy-class Private
  allow list VPN-10-vpn-selectors stateless
  allow list self self
  nat source list wizard-ics interface eth 0/1 overload
!
ip policy-class Public
  allow reverse list VPN-10-vpn-selectors stateless
  allow list remote-access self
!
!
!
ip route 0.0.0.0 0.0.0.0 ....
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
!
line con 0
  login
line con 1
  login local-userlist
!
line telnet 0 4
  login local-userlist
  password ....
  no shutdown
line ssh 0 4
  login local-userlist
  no shutdown
!
sntp server tick.ucla.edu
!
!
!
!
end
0
Comment
Question by:simprix
  • 3
5 Comments
 
LVL 43

Accepted Solution

by:
ravenpl earned 115 total points
Comment Utility
That's because workstations are too fast, when they trying to fetch the ip the switchport intercase is up but not forwarding due to network topology recognision timeout.

You have to enable portfast option. http://www.cisco.com/warp/public/473/12.html
0
 
LVL 3

Author Comment

by:simprix
Comment Utility
This is on a Netvanta, My topology is

WAN ----- Netvanta 3120(DHCP Server) ------ Netgear Switch ------ Workstation.


The netgear switch is plugged into switchport 1 which is up. Here is my spanning tree setup.

 STP 0
 Vlan 1
  Spanning Tree enabled protocol ieee 802.1w (Rapid Spanning-Tree)
  Root ID    Priority     32768
             Address      00:a0:c8:2d:9f:75
             The root of the spanning tree
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority     32768
             Address      00:a0:c8:2d:9f:75
             Aging Time   300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- ------------------------------
swx 0/1          Desg FWD 19         128.1   P2p  
0
 
LVL 3

Author Comment

by:simprix
Comment Utility
I also get things like this, The clients don't seem to get a ip.

2007.11.24 01:24:14 DHCP.SERVER Processing Request Message (Xid = c6a830f8) on 192.168.1.0/255.255.255.0 from 00:0E:2E:C8:4A:1B
2007.11.24 01:24:14 DHCP.SERVER Server sent a Nak to the client
2007.11.24 01:24:15 DHCP.SERVER Processing Discover Message (Xid = 5f8082f5) on 192.168.1.0/255.255.255.0 from 00:0E:2E:C8:4A:1B
2007.11.24 01:24:16 DHCP.SERVER Offering IP Address 192.168.1.2 to 00:0E:2E:C8:4A:1B
2007.11.24 01:24:16 DHCP.SERVER Server sent an Offer to the client
2007.11.24 01:24:16 DHCP.SERVER Processing Request Message (Xid = 5f8082f5) on 192.168.1.0/255.255.255.0 from 00:0E:2E:C8:4A:1B
2007.11.24 01:24:16 DHCP.SERVER No Reply required
0
 
LVL 4

Expert Comment

by:Joediggity2
Comment Utility
What RAVENPL is saying makes sense.  Although port 0/1 is up, the port that the workstation is on may not be up.  It is still trying to negotiate speed and duplex while the workstation is trying to get an ip address.  As an unscientific test of this, hook a cheap hub up to the switch.  This will make the switchport active, then hook the computer up to the hub.  If the computer gets its IP on boot, it is a problem with portfast.  I am not sure of the commands to turn the equivilent of fastport on a netgear switch.
0
 
LVL 3

Author Comment

by:simprix
Comment Utility
Thanks, Ill give it a try.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now