SonicWall TZ 190, Can not send email

i have this weird problem.
i have to mail serves outside my network. usually i can use both my email on these server to send and receive emails.
recently we added a sonicwall firewall, one of my email still works fine (incoming and outgoing). the other one on the other hand is only getting incoming emails, i cant seem to send emails out.

i can ping the mail server.
telnet on the mail server, on port 25, was fine.
sonicwall firewall has an allow access on port 25.

am i missing something? anything i should check for?
Who is Participating?
kgrutzConnect With a Mentor Commented:
I spoke to support on this.  they had me change the mtu value from 1500 to 1492.
that was it.  the mail sent out fine after that.
beashaAuthor Commented:
now i'm getting this undeliverable message:

Your message did not reach some or all of the intended recipients.

      Sent:      11/25/2007 10:28 PM

The following recipient(s) could not be reached:

      '' on 11/25/2007 10:29 PM
            550 not local host, not a gateway

any ideas?

thank you
beashaAuthor Commented:
never mind my last comment
Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

Let me get this right - you have 2 email servers on your LAN? You can send out email from one but not the other?
And on the one that can't send emails you can telnet to a mail server on the internet on port 25?
beashaAuthor Commented:
email servers outside my lan.
So you're sending email TO email servers outside your LAN?
Using an email client? Which one? Are they POP accounts / IMAP / Exchange / what?
Are you using the correct SMTP server on your ISP?
did you figure this out yet?
I have the same problem with a tz170
beashaAuthor Commented:
sorry rutz, not yet

chawla. my company, they use to email domains. the mail servers for this company are outside my LAN. i'm not trying to send email to my own email server, i'm trying to send from them. as i said one of them works fine, and the other can't send emails out.

i use outlook 2003.
Glad you resolved it...
beashaAuthor Commented:
rutz man
saved my day
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.