• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3366
  • Last Modified:

proliant dl360 +boot problems?

I have been handed a second hand proliant dl360 server with a linux distro loaded on it.  When I boot the server is says (not exact words):

This server was designed for a different operating system:

(f1) to continue
(some other options)

I press f1 and the OS loads just fine.  I basically just want to know how to get rid of this message?  I have checked the bios and nothing jumps out at me.  It is a real pain to walk down to the server room if this thing needs to be rebooted.

Thanks
0
savone
Asked:
savone
  • 9
  • 6
1 Solution
 
alfalfa6945Commented:
Go to http://h18007.www1.hp.com/support/files/server/us/download/22678.html?jumpid=reg_R1002_USEN  and burn to a CD. Boot from this CD and click the "Run System Configuration Utiity". Select "Review or modify hardware settings".  Go to "Step 3: View or edit details".
On the "Primary Operating System" line, hit enter. From this list, use "Unix" or "Other".

Voila, no more F1 and "designed for a different operating system" during boot. :)
0
 
savoneAuthor Commented:
I may have the disk, what would it say on it? They left me like 125 CD's.
0
 
alfalfa6945Commented:
It should just be marked SmartStart (could be any version)
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
savoneAuthor Commented:
Thanks found it, i will update you ASAP, Thanks for your help.
0
 
savoneAuthor Commented:
I inserted smartstart v5 and I get:

This server is not supported with this version of smart start

error 10

0
 
alfalfa6945Commented:
Okay, what are the specs of your dl360? (ie processor speed) Or do you know of the generation number of the DL360 (ie G2, G3, etc)?

We just need the correct version of SmartStart is all. Reson for this is because as you may have noticed, the dl360 has no bios button (ie you can't just hit Del or F2 to enter bios). The CD is the way into the bios, someone has just set the bios to boot from likely a windows OS, hence the error on boot when you use Linux.
0
 
savoneAuthor Commented:
actually one of the options listed after it says

This server was designed for a different operating system:

(f1) to continue
(some other options)

one of the options is f9 (or f8) which brings me into the bios and some other stuff... Can I do this from there?

0
 
alfalfa6945Commented:
Cool, did not know it would do that for you without the CD.
If you are in the bios, look for something like "Primary Operating System". You should be able to see somewhere in the bios then where to set this to either Linux, Unix, or Other (Linux may or may not be an option, depending on the age of the server bios).

Don't give up, this is the problem, we just have to find where to set it. Might still need the SmartStart version for this server in the end, but if you have a bios screen, it will be in there.
0
 
savoneAuthor Commented:
Ok, after further messing around... here are the option I am given...

f1 - continue
f9 - Rom based setup utility
f10 - system maintenance setup
f12 - PXE boot

So I chose f10 and found system options.  The first option is system OS.  I set it to linux and exited.  It does the same thing, comes to this screen and waits for input.  I also tries selecting Other and it also does the same thing.  

any other ideas?
0
 
savoneAuthor Commented:
BTW, i also found the generation number in the BIOS:  Its g3 and bios p31 5-1-2004

Processor info as posted by the bios:
intel 2.80GHZ 512KB l2 cache
0
 
alfalfa6945Commented:
Set it to Linux, then cold start (ie, shut it off and then turn back on).

The system partition isn't always installed, you seem to have it installed, which is good. But, SmartStart is the be-all-end-all for this problem if everything else fails. A complete shutdown of the server is in order also, not just a warm boot.
0
 
alfalfa6945Commented:
0
 
savoneAuthor Commented:
Ok i will try a cold start and if that doesnt work i will try the CD, I may not be able to get to it for a while after today (going back to regular production on monday) :)
0
 
savoneAuthor Commented:
Ok, I got it...

Thank you for your help, you were close but no cigar.

There is actually an option to enable/disable f1 prompt.   I set it to disabled and it now still gives me the other options for 2 seconds or so then just goes ahead and boots.

Thanks again for your time, I will award you some points anyhow.

0
 
savoneAuthor Commented:
Lead me to the correct solution, thanks.
0
 
fluffduneCommented:
In System Setup, choose "Advanced options" and then "POST F1 Prompt". Set to "Disabled" and you'll be off fine!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now