Solved

CIsco PIX 506E VPN Issue

Posted on 2007-11-25
4
593 Views
Last Modified: 2008-02-01
Hi,
I cant seem to connect to the vpn using the cisco vpn client 5.0, need someone to verify my config is correct?

Upon logging through the cisco client I get this message:
 - Sev=Info/4      IPSEC/0x63700014 Deleted all keys
-IKE/0x63000017 Marking IKE SA for deletion  (I_Cookie=33AE2E75B77F4BDF R_Cookie=0000000000000000) reason = DEL_REASON_PEER_NOT_RESPONDING

I have troubleshooted for 2 days now, below is my show ver and show run, any advice would be appreciated:
show ver:
Hardware:   PIX-506E, 32 MB RAM, CPU Pentium II 300 MHz
Flash E28F640J3 @ 0x300, 8MB
BIOS Flash AM29F400B @ 0xfffd8000, 32KB

0: ethernet0: address is 0017.9514.9b47, irq 10
1: ethernet1: address is 0017.9514.9b48, irq 11
Licensed Features:
Failover:           Disabled
VPN-DES:            Enabled
VPN-3DES:           Disabled
Maximum Interfaces: 2
Cut-through Proxy:  Enabled
Guards:             Enabled
URL-filtering:      Enabled
Inside Hosts:       Unlimited
Throughput:         Limited
IKE peers:          Unlimited

show run:

PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 9agJM/py4xp6BE7N encrypted
passwd 98XJM/py4wsrBE7N encrypted
hostname cisco-PIX
domain-name cisco.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list inside_outbound_nat0_acl permit ip 192.168.120.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip 192.168.120.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list vpn3000_splitTunnelAcl permit ip 192.168.120.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
interface ethernet0 auto
interface ethernet1 auto
icmp permit any echo outside
icmp permit any time-exceeded outside
icmp permit any outside
icmp permit any echo inside
icmp permit any time-exceeded inside
mtu outside 1500
mtu inside 1500
ip address outside 74.x.x.x 255.255.255.248
ip address inside 192.168.120.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.1.1-192.168.1.254
pdm location 0.0.0.0 255.255.255.255 outside
pdm location 0.0.0.0 255.255.255.255 inside
pdm location 192.168.10.0 255.255.255.192 inside
pdm location 192.168.10.0 255.255.255.192 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 74.10.135.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set myset
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash sha
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 192.168.120.10
vpngroup vpn3000 wins-server 192.168.120.10
vpngroup vpn3000 default-domain attitude.local
vpngroup vpn3000 split-tunnel vpn3000_splitTunnelAcl
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
username administrator password P/ajEzRsqt8.fVz6 encrypted privilege 15
terminal width 80
Cryptochecksum:9fba6cc83054fa957d99684421d851e5
: end

Additionally: I have noticed that enven is I delete the isakmp 10(s) they come back and I cant seem to add a isakmp nat-trasversal rule.. Also not sure is the fact I cant use 3des has any impact on my issue?
0
Comment
Question by:pxenakis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 28

Expert Comment

by:batry_boy
ID: 20346400
You should be able to connect with the VPN client with only DES enabled, but if you have a SmartNet maintenance contract on this firewall, I would:

1.  Upgrade the code to 6.3(5), which is the latest version.  Not only will it fix numerous bugs found in the version of code you are currently using, this will allow you to put in the "isakmp nat-traversal" command which was introduced in 6.3x versions of the code...definitely something you want in your config.

2.  Apply for a free 3DES activation key.  Cisco used to charge for the upgraded encryption capability, but they give it away for free now...but you can only get to the page to register for one when you have a cisco.com user account.
0
 

Author Comment

by:pxenakis
ID: 20346438
Thanks for the advice, will the upgrade wipe the config? Just wondering if I can do it remotely?
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 20346565
No, it won't wipe the config.

Yes, you can perform the upgrade remotely, but it is very risky and unless you are within driving distance to it in case something happens, I wouldn't recommend it...I've done it once in a pinch, but I don't make a habit of it.
0
 

Author Comment

by:pxenakis
ID: 20346976
Your the man, that worked! I should have upgraded the code earlier.
0

Featured Post

Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco vWLC DHCP issues 36 103
Single Number Reach 3 55
TLS 1.0 & Windows 7 - How to disable? 16 128
HP Storage and Cisco Nexus 4 11
From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question