Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2916
  • Last Modified:

Exchange 2007 ActiveSync Error

Hello Experts,

I tring to setup my Mobile Device (Treo 680 Smartphone) to sync emails and other data from my exchange 2007 server. When i try to sync i get this error iin the device:

An error occurred during the processing of a configuration file required to service this request.

I tried to open in web browser, using the URL: https://MYSERVER/Microsoft-Server-ActiveSync              and get this error:


Server Error in '/Microsoft-Server-ActiveSync' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Microsoft.Exchange.Clients.Owa' or one of its dependencies. The system cannot find the file specified. (D:\Microsoft\Exchange\ClientAccess\Owa\web.config line 64)

Source Error:


Line 62:             <!-- OWA HTTP Modules -->
Line 63:             <httpModules>
Line 64:                   <add type="Microsoft.Exchange.Clients.Owa.Core.OwaModule, Microsoft.Exchange.Clients.Owa"
Line 65:                         name="OwaModule"/>
Line 66:             </httpModules>
 

Source File: D:\Microsoft\Exchange\ClientAccess\Owa\web.config    Line: 64


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

In The Event Log:

Event code: 3008
Event message: A configuration error has occurred.
Event time: 11/25/2007 5:23:03 PM
Event time (UTC): 11/25/2007 8:23:03 PM
Event ID: fa9b16d30ac64e81af70dc63d64bfec9
Event sequence: 5
Event occurrence: 4
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/Microsoft-Server-ActiveSync-1-128404817158279157
    Trust level: Full
    Application Virtual Path: /Microsoft-Server-ActiveSync
    Application Path: D:\Microsoft\Exchange\ClientAccess\sync\
    Machine name: XXXXXXX-EMAIL-1
 
Process information:
    Process ID: 3916
    Process name: w3wp.exe
    Account name: NT AUTHORITY\SYSTEM
 
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: Could not load file or assembly 'Microsoft.Exchange.Clients.Owa' or one of its dependencies. The system cannot find the file specified. (D:\Microsoft\Exchange\ClientAccess\Owa\web.config line 64) (D:\Microsoft\Exchange\ClientAccess\Owa\web.config line 64)
 
Request information:
    Request URL: https://XXXXXXX.XXXXXX.com.br/Microsoft-Server-ActiveSync 
    Request path: /Microsoft-Server-ActiveSync
    User host address: 11.220.37.38
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\SYSTEM
 
Thread information:
    Thread ID: 5
    Thread account name: NT AUTHORITY\SYSTEM
    Is impersonating: False
    Stack trace:    at System.Web.Configuration.HttpModuleAction.get_Entry()
   at System.Web.Configuration.HttpModulesSection.CreateModules()
   at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
   at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
   at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
 
 
Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

------------------------------------------------------------------------------------------------------------------------------------

Relevanto Info:


Owa Works Fine
I have Aspnet enabled is IIS
I have a trusted and valid SSL certificate in IIS

Any Clues ?



0
tullioc
Asked:
tullioc
1 Solution
 
seeimredCommented:
Is this server a CAS role server?
0
 
tulliocAuthor Commented:
Only one server, all roles
0
 
OblikonCommented:
I was having the exact same problem as above.  The only way to resolve it was to reinstall the CAS, which was a pain, but it is working perfectly now.
0
 
lbocCommented:
You can also remove the directory:

C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\microsoft-server-activesync

You must stop the application pool before. That solved the problem for me.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now